在线检测未来函数

通达信涨停基因主图指标公式

来源:Internet,编辑:股旁网,2014-05-17

C2:=REF(C,1);
非ST涨停:=IF((C-C2)*100/C2>=(10-0.01*100/C2),1,0);
涨停:=非ST涨停;
STICKLINE(涨停,OPEN,CLOSE,2,0),COLORYELLOW;
STICKLINE(涨停,H,L,0,0),COLORYELLOW;
非ST跌停:=IF((C2-C)*100/C2>=(10-0.01*100/C2),1,0);
跌停:=非ST跌停;
STICKLINE(跌停,OPEN,CLOSE,2,0),COLORWHITE;
STICKLINE(跌停,H,L,0,1),COLORWHITE;
半涨1:=IF((C-C2)*100/C2>=(5-0.01*100/C2),1,0);
半涨2:=IF((C-C2)*100/C2<(10-0.01*100/C2),1,0);
JRS:=半涨1 AND 半涨2 ;
STICKLINE(JRS,OPEN,CLOSE,2,0),COLOR0066FF;
STICKLINE(JRS,H,L,0,0),COLOR0066FF;
〖3〗:MA(C,3) ,COLORMAGENTA;
〖5〗:MA(C,5) ,COLORWHITE;
〖13〗:MA(C,13) ,COLORYELLOW ;
〖34〗:MA(C,34) ,COLORRED;
〖55〗:MA(C,55) ,COLORGREEN;
〖56〗:MA(C,56) ,COLORGREEN;
〖89〗:MA(C,89) , COLORGRAY ;
〖144〗:MA(C,144) , COLORD9D919;
〖233〗:MA(C,233) ;
〖377〗:MA(C,377) ;
ZT:=C/REF(C,1)>1.0945 AND C=H;
AA:=REF(C,BARSLAST(ZT AND CURRBARSCOUNT<60));
DRAWLINE(ZT,C,1,REF(AA,1),1);
DD:=ABS((CLOSE-MA(CLOSE,5))/MA(CLOSE,5)*100)>=10;
DRAWTEXT(DD,H*1.02,''),COLORGREEN,LINETHICK3;

通达信涨停基因主图指标公式

 

相关文章