在线检测未来函数

飞狐红灯高照主图指标公式

来源:Internet,编辑:股旁网,2014-05-18

Var1:=MA(CLOSE,5);
Var2:=MA(CLOSE,10);
Var3:=MA(CLOSE,20);
Var4:=MA(CLOSE,30);
Var5:=(Var1+Var2+Var3+Var4)/4;
Var6:=(Var5-REF(Var5,15))/REF(Var5,15)*100;
Var7:=(Var5-REF(Var5,15))/REF(Var5,15)*100;
Var8:=EMA(Var6,3);
底部信号: STICKLINE(Var6>REF(Var6,1) AND Var6<0 AND Var6<Var8,OPEN,CLOSE,8,0),colorwhite,linethick2 ;
低位转强: STICKLINE(Var8>REF(Var8,1) AND Var6<0 AND Var6>Var8 AND CLOSE>OPEN,OPEN,CLOSE,8,0),colormagenta ,linethick2 ;
红灯高照: STICKLINE(Var6>REF(Var6,1) AND Var6>0 AND Var8<0 AND CLOSE>OPEN,OPEN,CLOSE,10,0),colorred ,linethick2 ;
坚定持股: STICKLINE(Var8>REF(Var8,1) AND Var8>0,OPEN,CLOSE,8,0),coloryellow ,linethick2 ;
振荡洗盘: STICKLINE(Var8>REF(Var8,1) AND Var8>0 AND CLOSE<OPEN,OPEN,CLOSE,8,1),color0033cc ,linethick2 ;
谨慎观望: STICKLINE(Var6<REF(Var6,1) AND Var8>REF(Var8,1) AND Var6>0 AND CLOSE>OPEN,OPEN,CLOSE,10,0),colorffff00 ,linethick2 ;
谨慎持股: STICKLINE(Var6<REF(Var6,1) AND Var6<Var8 AND Var8>0 AND CLOSE>OPEN,OPEN,CLOSE,8,0),color0066cc ,linethick2 ;
果断持币: STICKLINE(Var6<REF(Var6,1) AND Var6<Var8 AND Var8>0 AND CLOSE<OPEN,OPEN,CLOSE,9,1),colorwhite ,linethick2 ;
阴跌绵绵: STICKLINE(Var6<REF(Var6,1) AND Var6<Var8 AND Var8<0 AND CLOSE<OPEN,OPEN,CLOSE,8,1),colorgreen ,linethick2 ;
下跌反弹: STICKLINE(Var6<REF(Var6,1) AND Var6<Var8 AND Var8<0 AND CLOSE>OPEN,OPEN,CLOSE,8,0),color3333cc ,linethick2 ;
箱顶: HHV(MA((LOW+HIGH+CLOSE+OPEN)/4,5),58),color0066cc , ;
箱底: LLV(MA((LOW+HIGH+CLOSE+OPEN)/4,6),58)-0.2,colorgreen , ;
Var9:=EMA((HIGH+LOW+CLOSE)/3*(HHV(HIGH,10)-CLOSE)/(HHV(HIGH,10)-LLV(LOW,10))*20/10+箱底,2);
VarA:=(3*Var9-2*SMA(Var9,5,1))*0.3;
VarB:=(HHV(INDEXH,13)-INDEXC)/(HHV(INDEXH,13)-LLV(INDEXL,13));
VarC:=EMA(3*VarB-2*SMA(VarB,18,1),5);
VarD:=(INDEXC-LLV(INDEXL,8))/(HHV(INDEXH,8)-LLV(INDEXL,8));
VarE:=3*SMA(VarD,3,1)-2*SMA(SMA(Var5,3,1),5,1);
VarF:=(INDEXC*2+INDEXH+INDEXL)/4;
Var10:=EMA(VarF,13)-EMA(VarF,34);
Var11:=EMA(Var10,5);
Var12:=(Var10-Var11+箱底)*1;
Var13:=1.86*EMA(CLOSE,12)-EMA(CLOSE,34);
Var14:=Var13;
Var15:=箱底;
牛气冲天: STICKLINE(Var14>=Var15,Var15,Var14,4,0),colorred , ;
STICKLINE(Var14<=REF(Var14,1) AND Var14>Var15,Var15,Var14,4,1),color3366cc , ;
Var16:=STICKLINE(REF(Var14,2)<REF(Var14,1) AND Var14<=REF(Var14,1) AND Var14>Var15,Var15,Var14,4,0);
Var17:=STICKLINE(Var14<Var15-0.5,Var15-0.5,Var14,8,1);
Var18:=STICKLINE(REF(Var14,2)>REF(Var14,1) AND Var14>=REF(Var14,1) AND Var14<Var15-0.5,Var15-0.5,Var14,8,0);
转强信号: STICKLINE(Var14>REF(Var14,1) AND Var14<Var15-0.5,Var15-0.5,Var14,2,0),color3366cc , ;
Var19:=MA(CLOSE,3);
Var1A:=MA(CLOSE,34);
Var1B:=MA(CLOSE,45);
Var1C:=MA(CLOSE,60);
Var1D:=DRAWTEXT(CROSS(Var19,箱顶) AND CLOSE>箱顶,箱顶*0.99,'追');
R: DRAWTEXT(CROSS(箱顶,Var19) AND CLOSE<箱顶,HIGH,'卖'), ,;
Var1E:=DRAWTEXT(REF(Var12,2)<REF(Var12,1) AND REF(Var12,1)>Var12 AND Var12>箱顶 AND CLOSE>箱顶,HIGH*1.005,'顶');
Var1F:=DRAWTEXT(CROSS(Var19,箱底),LOW*0.98,'试');
Var20:=DRAWTEXT(CROSS(Var19,Var1A),LOW*0.98,'买');
Var21:=MA(CLOSE,10);
Var22:=MA(CLOSE,20);
Var23:=MA(CLOSE,30);
Var24:=MA(CLOSE,62);
Var25:=MA(CLOSE,250);

飞狐红灯高照主图指标公式

 

相关文章