在线检测未来函数

通达信缠论MACD指标公式

来源:Internet,编辑:股旁网,2014-05-20

SHORT:=12;
LONG:=26;
MID:=9;
TSARROW:=1;
DIFF:=EMA(CLOSE*100,SHORT)-EMA(CLOSE*100,LONG);
DEA:=EMA(DIFF,MID);
MACD2:=(DIFF - DEA)*2;
DIF:DIFF;
DEF:DEA;
MACD:MACD2,NODRAW;
获利比:WINNER(C),NODRAW;
STICKLINE((MACD2>=0),0,MACD2,0,1),COLORRED;
STICKLINE(((MACD2>=0) AND (MACD2 < REF(MACD2,1))),0,MACD2,0,0),COLORMAGENTA;
STICKLINE((MACD2<0),0,MACD2,0,0),COLORGREEN;
STICKLINE(((MACD2<0) AND (MACD2 > REF(MACD2,1))),0,MACD2,0,1),COLORWHITE;
DRAWICON(LONGCROSS(CLOSE,MA(CLOSE,5),17),MACD2,1);
DRAWICON(LONGCROSS(MA(CLOSE,5),CLOSE,17),MACD2,2);
低位金叉:=CROSS(DIFF,DEA) AND DIFF<-0.1;
JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));
二次金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;
DRAWTEXT(二次金叉,0,'二次金叉');
三次金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=3,60)=1;
DRAWTEXT(三次金叉,0,'三次金叉');
A1:=IF(MACD2>0,1,-1);
A2:=REF(A1,1);
A3:=A1*A2;
A4:=BARSLAST(A3<0);
A5:=A4+1;
累计面积:SUM(MACD2,A5),NODRAW;
平均力度:SUM(MACD2,A5)/A5,NODRAW;
0,DOTLINE;
WK:="KD.K#WEEK"(9,3,3);
WD:="KD.D#WEEK"(9,3,3);
DK:="KD.K#DAY"(9,3,3);
DD:="KD.D#DAY"(9,3,3);
DRAWICON(CROSS(WK,WD) AND WK<70 AND PERIOD>4,LLV(MACD2,30),9);
DRAWICON(CROSS(DK,DD) AND DK<70 AND PERIOD>4,LLV(MACD2,10),10);
TJ:=MACD2>0;T:=MACD2<0;
A:=LLV(MACD2,50)=MACD2;
DRAWICON(A AND FILTERX(A,20), MACD2,1);
DRAWTEXT(BARSLAST(TJ)=1,MACD2,'1'),COLORYELLOW;
DRAWTEXT(BARSLAST(TJ)=2,MACD2,'2'),COLORYELLOW;
DRAWTEXT(BARSLAST(TJ)=3,MACD2,'3'),COLORYELLOW;
DRAWTEXT(BARSLAST(TJ)=5,MACD2,'5'),COLORYELLOW;
DRAWTEXT(BARSLAST(TJ)=8,MACD2,'8'),COLORYELLOW;
DRAWTEXT(BARSLAST(TJ)=13,MACD2,'13'),COLORYELLOW;
DRAWTEXT(BARSLAST(TJ)=21,MACD2,'21'),COLORYELLOW;
DRAWTEXT(BARSLAST(TJ)=34,MACD2,'34'),COLORYELLOW;
DRAWTEXT(BARSLAST(TJ)=55,MACD2,'55'),COLORYELLOW;
DRAWTEXT(BARSLAST(T)=1,MACD2,'1'),COLORGREEN;
DRAWTEXT(BARSLAST(T)=2,MACD2,'2'),COLORGREEN;
DRAWTEXT(BARSLAST(T)=3,MACD2,'3'),COLORGREEN;
DRAWTEXT(BARSLAST(T)=5,MACD2,'5'),COLORGREEN;
DRAWTEXT(BARSLAST(T)=8,MACD2,'8'),COLORGREEN;
DRAWTEXT(BARSLAST(T)=13,MACD2,'13'),COLORGREEN;
DRAWTEXT(BARSLAST(T)=21,MACD2,'21'),COLORGREEN;
DRAWTEXT(BARSLAST(T)=34,MACD2,'34'),COLORGREEN;
DRAWTEXT(BARSLAST(T)=55,MACD2,'55'),COLORGREEN;

通达信缠论MACD指标公式

 

相关文章