在线检测未来函数

通达信烽火成交量指标公式

来源:Internet,编辑:股旁网,2014-05-20

TOTAL:=IF(PERIOD=1,5,IF(PERIOD=2,15,IF(PERIOD=3,30,IF(PERIOD=4,60,IF(PERIOD=5,240,1)))));
MTIME:=MOD(FROMOPEN,TOTAL);
CTIME:=IF(MTIME<0.5,TOTAL,MTIME);
虚拟量:IF(CURRBARSCOUNT=1,VOL*TOTAL/CTIME,DRAWNULL),NODRAW;
STICKLINE(CURRBARSCOUNT=1 && (SETCODE=0 || SETCODE=1),虚拟量,0,-1,-1),COLORFFFFFF;
成交量:VOL,VOLSTICK;
V5:MA(V,5),COLORWHITE;
V10:MA(V,10),COLORYELLOW;
V20:MA(V,20),COLORMAGENTA;
V120:MA(V,120),POINTDOT;
{20日内高量}
M:=10;
HDX:=FILTER(BACKSET(FILTER(REF(V,M)=HHV(V,2*M+1),M),M+1),M);
AAX:=REF(V,BARSLAST(HDX));
T1AX:=BARSLAST(HDX);
STICKLINE(T1AX,AAX,AAX,9,0),COLORWHITE;
二十量高点:IF(T1AX,AAX,AAX),COLORWHITE,NODRAW;
{30日内高量}
P:=15;
HDZ:=FILTER(BACKSET(FILTER(REF(V,P)=HHV(V,2*P+1),P),P+1),P);
AAZ:=REF(V,BARSLAST(HDZ));
T1AZ:=BARSLAST(HDZ);
STICKLINE(T1AZ,AAZ,AAZ,9,0),COLORF00FF0;
三十量高点:IF(T1AZ,AAZ,AAZ),COLORF00FF0,NODRAW;
{60日内高量}
MP:=30;
HDH:=FILTER(BACKSET(FILTER(REF(V,MP)=HHV(V,2*MP+1),MP),MP+1),MP);
AAH:=REF(V,BARSLAST(HDH));
T1AH:=BARSLAST(HDH);
STICKLINE(T1AH,AAH,AAH,9,0),COLOR0099FF;
六十量高点:IF(T1AH,AAH,AAH),COLOR0099FF,NODRAW;
量60:=IF(VOL>REF(HHV(VOL,60),1),222,0),COLORFF3399;
DRAWTEXT(CROSS(量60,1),六十量高点,'超量'),COLORGREEN;
{黄金柱}
绿低量:=13;
蓝低量:=55;
灰低量:=100;
H_L:=0.1*CONST(HHV(VOL,240));
VVOL:=IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,DRAWNULL);{模拟量}
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,VVOL,0,1,-1),COLOR00C0C0;
量:VOL,VOLSTICK;
换手: VOL*10000/FINANCE(7),NODRAW; {DYNAINFO(37)*100}
换10T: SUM(换手,10),NODRAW;
倍数:=1.9;
倍量: VOL>=REF(V,1)*倍数 AND (IF(C<O,C>REF(C,1),1)),COLORYELLOW,NODRAW;
倍缩: REF(V,1)>=VOL*倍数,COLORMAGENTA,NODRAW;
平量: RANGE(V/REF(V,1),0.97,1.03) AND BARSCOUNT(V)>=2,COLORWHITE,NODRAW;
低量10: VOL=LLV(VOL,绿低量) AND BARSCOUNT(V)>=绿低量,COLORGREEN,NODRAW;
低量50: VOL=LLV(VOL,蓝低量) AND BARSCOUNT(V)>=蓝低量,COLORBLUE,NODRAW;
地量: VOL=LLV(VOL,灰低量) AND BARSCOUNT(V)>=灰低量,COLORGRAY,NODRAW;
V1:=VOL*0.9;{图标位置}
V2:=VOL*0.8;
STICKLINE(倍量, 0,V1,1,0),COLORYELLOW;
STICKLINE(平量,0,V1,1,0),COLORWHITE;
STICKLINE(低量10,0,V2,1,0),COLORLIGREEN;
STICKLINE(低量50,0,V2,1,0),COLORBLUE;
STICKLINE(地量,0,V2,1,0),COLORGRAY;
STICKLINE(倍缩,0,V*0.45,1,0),COLORMAGENTA;
STICKLINE(C<O AND C>REF(C,1),0,V,0,0),COLORRED;{假阴柱}
真阳或假阴:=C>O OR C>REF(C,1);
收阳:= REF(真阳或假阴,3);
倍量1:=REF(倍量,3);
高量:=REF(V,3)>=HHV(V,7);
三日不破:= LLV(C,3)>=REF(L,3);
价升:=COUNT(C>=REF(C,1),3)=3;{收盘价逐升}
量缩:=COUNT(V<=REF(V,1),3)=3;
连阳:= COUNT(真阳或假阴,3)=3;
倍量将军柱:= 倍量1 AND 三日不破 AND 收阳;
高量将军柱:= 高量 AND 三日不破 AND 收阳;
将军柱:= 倍量将军柱 OR 高量将军柱;
黄金柱:= 将军柱 AND 价升 AND 量缩 AND 连阳 ;
STICKLINE(黄金柱,0.3*V,0.7*V,1,0),COLORRED; {红柱}
DRAWICON(黄金柱,V*1.5,1);
V100:= V<=LLV(V,100)*1.2 AND V>0 AND BARSCOUNT(V)>=100;
百日地量群:=COUNT(V100,5)>=3;
DRAWTEXT(FILTER(百日地量群,4),V+3*H_L,'地量群'),COLORGRAY;
长阴短柱:=C/REF(C,1)<=0.96 AND V<HHV(V,30)/1.9;
DRAWTEXT(长阴短柱 ,V+1.6*H_L,'!'),COLORLICYAN;
{信息}
虚与量柱比:=虚拟量/六十量高点,NODRAW;
DRAWTEXT_FIX(1,0.00,0.00,0,STRCAT('虚拟与量柱比:',CON2STR(虚与量柱比,2))),COLOR0099FF;
本虚拟实比:=虚拟量/V,NODRAW;
DRAWTEXT_FIX(1,0.00,0.18,0,STRCAT('虚拟与实量比:',CON2STR(本虚拟实比,2))),COLORMAGENTA;
虚昨量比:=虚拟量/REF(V,1),NODRAW;
DRAWTEXT_FIX(1,0.00,0.36,0,STRCAT('虚拟与昨量比:',CON2STR(虚昨量比,2))),COLORMAGENTA;
量比:=DYNAINFO(17);
DRAWTEXT_FIX(1,0.35,0.00,0,STRCAT('量比:',CON2STR(量比,2))),COLORYELLOW;
{涨幅:=(C-REF(C,1))/REF(C,1)*100;
DRAWTEXT_FIX(1,0.21,0.34,0,STRCAT('涨幅:',CON2STR(涨幅,2))),COLORYELLOW;}
量填满:=V/MA(VOL,5);
DRAWTEXT_FIX(1,0.35,0.18,0,STRCAT('量填满:',CON2STR(量填满,2))),COLORWHITE;
实昨量比:=V/REF(V,1),NODRAW;
DRAWTEXT_FIX(1,0.35,0.36,0,STRCAT('实量与昨量比:',CON2STR(实昨量比,2))),COLORCYAN;
量能饱和:=(AMOUNT/CLOSE)/HHV((AMOUNT/CLOSE),11)*100,COLORLIMAGENTA,NODRAW;
VAR1:=AMOUNT/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
主动买盘:=IF(CLOSE>OPEN,VAR1*(HIGH-LOW),IF(CLOSE<OPEN,VAR1*((HIGH-OPEN)+(CLOSE-LOW)),AMOUNT/2)),COLORYELLOW;
{STICKLINE(量能饱和=100,主动买盘/8000,0,2,0),COLORMAGENTA;}
百日低量柱:=MIN(LLV( VOL,99),VOL)=VOL;
DRAWTEXT(百日低量柱,VOL*1.06,'百日低'),COLORYELLOW;
DRAWICON(V=LLV(V,99),V5,26);
总家数:=INDEXADV+INDEXDEC,NODRAW;
涨家数:=INDEXADV,NODRAW;
跌家数:=INDEXDEC,NODRAW;
差数:=INDEXADV-INDEXDEC,NODRAW;
DRAWTEXT_FIX(1,0.55,0.00,0,STRCAT('【涨家数】:',CON2STR(涨家数,0))),COLORMAGENTA;
DRAWTEXT_FIX(1,0.55,0.18,0,STRCAT('【跌家数】:',CON2STR(跌家数,0))),COLORGREEN;
DRAWTEXT_FIX(1,0.75,0.00,0,STRCAT('【总家数】:',CON2STR(总家数,0))),COLORYELLOW;
DRAWTEXT_FIX(1,0.75,0.18,0,STRCAT('【差 数】:',CON2STR(差数,0))),COLORGREEN;

通达信烽火成交量指标公式

 

相关文章