在线检测未来函数

大智慧MA大趋势主图指标公式

来源:Internet,编辑:股旁网,2014-05-24

a:=(3*c+l+o+h)/6;
ma3:ema(a,3);
ma5:ema(a,5);
ma10:ema(a,10);
ma20:ema(a,20);
X:=(20*a+19*ref(a,1)+18*ref(a,2)+17*ref(a,3)+16*ref(a,4)+15*ref(a,5)+
14*ref(a,6)+13*ref(a,7)+12*ref(a,8)+11*ref(a,9)+10*ref(a,10)+9*ref(a,11)+8*ref(a,12)
+7*ref(a,13)+6*ref(a,14)+5*ref(a,15)+4*ref(a,16)+3*ref(a,17)+2*ref(a,18)+
ref(a,20))/210;
回调认同:eMA(X,13),colorFF00FF;
STICKLINE(close>=open,open,close,4,1),colorred;
STICKLINE(open>close,close,open,5,0 ),colorffff50;
STICKLINE(close>=open,close,HIGH,0.5 ,0 ),colorred;
STICKLINE(close>=open,open,low,0.5 ,0),colorred;
STICKLINE(open>close,close,low,0.5 ,0 ),colorffff50;
STICKLINE(open>close,open,HIGH,0.5 ,0 ),colorffff50;
aaA:=CLOSE/REF(CLOSE,1)>=1.09;
STICKLINE(aaA,open,close,4,0),coloryellow;
STICKLINE(aaA,low,HIGH,0.5 ,0 ),coloryellow;
LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
卖:=CROSS(84,RSI);
DRAWTEXT(卖,(HIGH * 1.02),'●'),colorwhite;
M17:EMA(CLOSE,17),color00ffff;
STICKLINE(m17>=回调认同,m17,回调认同,4,0),color00ffff;
STICKLINE(m17<回调认同,回调认同,m17,4,0),colorff00ff;
ab:=sma(ema((c-ref(c,1))/ref(c,1),5)*100,3,1)*10;
买:=cross(ab,0);
STICKLINE(买,open,close,4,0),colorFF00FF;
STICKLINE(买,low,HIGH,0.5 ,0 ),colorFF00FF;
QH:=REF(H,2);
QL:=REF(L,2);
QO:=REF(O,2);
QC:=REF(C,2);
ZO:=REF(O,1);
ZC:=REF(C,1);
JYZHK:= ABS(QO-QC)/QO<0.02 AND ZO/ZC>1.02 AND ABS(O-C)/O<0.02 AND C>MA(C,30);
JYZHV:=V<REF(V,1) ;
JYZH:=JYZHK AND JYZHV;
DRAWTEXT(JYZH,LOW/1.01,'★'),COLORRED;
c2:=EMA(a,6);
c3:=EMA(a,5);
c4:=CROSS(c2,c3);
DRAWTEXT(c4,LOW/1.01,'▲'),COLORRED;
{aa线}
aa:ema(c,17);
{if(aa>=ref(aa,1),aa,0),LINETHICK2,COLORyellow;
if(aa<ref(aa,1),aa,0),LINETHICK2,COLORff9900; }
STICKLINE(C>aa,L,H,0.1,1),COLORRED;
STICKLINE(C>aa,C,O,4,1),COLORRED;
STICKLINE(C>aa,C,O,4,1),COLORRED;
STICKLINE(C<aa,C,O,4,1),COLORFFFF00;
STICKLINE(C<aa,C,O,4,1),COLOR00FF00;
STICKLINE(C<aa,L,H,0.1,1),COLOR00FF00;

大智慧MA大趋势主图指标公式

 

相关文章