在线检测未来函数

通达信约好逃顶主图指标公式

来源:Internet,编辑:股旁网,2014-05-24

DRAWNUMBER(ISLASTBAR ,C,C),COLORMAGENTA;
N8:=STRCAT(CON2STR(YEAR,0),' 年 ');
Y8:=STRCAT(CON2STR(MONTH,0),' 月 ');
R8:=STRCAT(CON2STR(DAY,0),' 日 ');
买线:=EMA(C,2);
卖线:=EMA(SLOPE(C,21)*20+C,42);
BU:=CROSS(买线,卖线);
SEL:=CROSS(卖线,买线);
STICKLINE(买线>=卖线,LOW,HIGH,0.0,1),COLORLIRED;
STICKLINE(买线>=卖线,CLOSE,OPEN,3,1),COLORLIRED;
MA5:MA(CLOSE,5),COLORFFFFFF;
MA10:MA(CLOSE,10),COLORYELLOW;
MA20:MA(CLOSE,20),COLORMAGENTA;
MA30:MA(CLOSE,30),COLORGREEN;
MA(C,20),COLORWHITE,LINETHICK2;
IF(MA20>REF(MA20,1),MA20,DRAWNULL),COLORRED,LINETHICK2;
IF(MA20<REF(MA20,1),MA20,DRAWNULL),COLORGREEN,LINETHICK2;
JC:=(REF(C,3)+REF(C,5)+REF(C,7)+REF(C,8)+REF(C,13)+REF(C,21))/6;
参考价:=SMA(JC,5,1),COLORCYAN;
价:=IF(C>=参考价,参考价,参考价*0.98 ), CIRCLEDOT,COLOR0000FF;
STICKLINE(买线<卖线,LOW,HIGH,0.0,1),COLORCYAN;
STICKLINE(买线<卖线,CLOSE,OPEN,3,1),COLORCYAN;
SJ8:=STRCAT(STRCAT(N8,Y8), R8);
DRAWTEXT(CROSS(83,RSI),H*1.04,' 逃顶')COLORYELLOW;
今日保护价:(REF(C,2)+REF(C,1)+O)/3 ,COLORCC3299,NODRAW;
顶点:IF(CURRBARSCOUNT<=44, CONST(IF(ISLASTBAR=1,HHV(H, BARSLAST(CURRBARSCOUNT=44)),1)),DRAWNULL),COLORRED,DOTLINE;
低点:IF(CURRBARSCOUNT<=44, CONST(IF(ISLASTBAR=1,LLV(L, BARSLAST(CURRBARSCOUNT=44)),1)),DRAWNULL),COLORMAGENTA,DOTLINE;
STICKLINE(CCI>=200 AND H>=顶点,O,C,3,0),COLORBLUE;
STICKLINE(CCI<=100 AND L<=低点,O,C,3,0),COLORYELLOW;
DRAWTEXT_FIX(C>0,0.5,0,0,SJ8),COLOR00FFFF;
DRAWTEXT(ISLASTBAR,顶点,'顶点'),COLORRED;
DRAWTEXT(ISLASTBAR,低点,'低点'),COLORMAGENTA;

通达信约好逃顶主图指标公式

 

相关文章