在线检测未来函数

飞狐极品稳赚指标公式

来源:Internet,编辑:股旁网,2014-05-26

QW1:=(HIGH+LOW+CLOSE*2)/4;
QW3:=EMA(QW1,10);
QW4:=STD(QW1,10);
QW5:=(QW1-QW3)*100/QW4;
QW6:=EMA(QW5,5);
RK7:=EMA(QW6,10);
涨:EMA(QW6,10)+100/2-5,LINETHICK1,COLORRED;
跌:EMA(涨,4),LINETHICK1,COLORFFFF34;
多线:IF(CROSS(涨,跌) AND 跌<-10,30,0),LINETHICK1,COLORFF00FF;
空线:IF(CROSS(跌,80),70,100),COLOR0099FF,LINETHICK1;
买1:EMA(跌,4),COLORWHITE;
买2:EMA(买1,4),COLORGREEN;
买M3:=EMA(买2,4),COLORYELLOW;
买M4:=EMA(买M3,4),COLORCC9900;
-10,POINTDOT,COLOR888888,LINETHICK2;
80,POINTDOT,COLOR888888,LINETHICK2;
STICKLINE(涨<REF(涨,1),涨,MA(涨,3),2,0 ),COLOR00EE00;
STICKLINE(涨<REF(涨,1),涨,MA(涨,3),1,0 ),COLOR00FF00;
STICKLINE(涨> REF(涨,1),涨,EMA(涨,3),3,0) ,COLOR0099FF;
STICKLINE(涨> REF(涨,1),涨,EMA(涨,3),2,0) ,COLOR00AAFF;
STICKLINE(涨> REF(涨,1),涨,EMA(涨,3),1,0) ,COLOR00BBFF;
DRAWICON(多线,30,1),COLORFF00FF;
DRAWICON(CROSS(跌,80),70,2),COLORGREEN;
DRAWTEXT(CROSS(涨,跌) AND 跌<20 AND 跌>-10,40,'买入'),COLORCCFF99;
DRAWTEXT(多线>0,-20,'看涨'),COLOR0000FF;
VAR2:=MA(CLOSE,194);
VAR3:=VAR2+2*STD(CLOSE,170);
顶:(CLOSE>VAR3)*13*10,COLORBLUE,LINETHICK2;
VAR18:=HHV(HIGH,30);
VAR19:=LLV(LOW,30);
NL:=EMA((CLOSE-VAR19)/(VAR18-VAR19)*100,5)/8*10,COLORYELLOW,LINETHICK2;
DRAWTEXT(CROSS(5,NL),30,'★做底'),COLORWHITE;
VAR44:=REF(CLOSE,1);
VAR45:=SMA(MAX(CLOSE-VAR44,0),6,1)/SMA(ABS(CLOSE-VAR44),6,1)*100;
STICKLINE(CROSS(84,VAR45),0,VAR2*15+3,3,1),COLORGREEN;
DRAWTEXT(CROSS(84,VAR45),80,'防空警报'),COLORGREEN;
VAR55:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,5);
VAR56:=INDEXC;
VAR57:=MA(VAR56,5);
VAR58:=MA(VAR56,20);
VAR5B:=VAR57>VAR56*1.03 AND VAR58>VAR56*1.13;
VAR5D:=IF(FILTER(VAR55<6,5)=1,1,0);
VAR5F:=VAR55<6 AND VAR5B;
VAR61:=VAR5F AND VAR5D*80;
VAR7C:=IF(EMA(CLOSE,5)/EMA(EMA(CLOSE,9),16)<=0.85 AND CLOSE/REF(CLOSE,1)>0.905 AND CLOSE/REF(CLOSE,1)<1.05 AND VOL/CAPITAL*100<5,50,0);
VAR7D:=(-100)*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34))+100;
VAR7E:=(-100)*(HHV(HIGH,50)-CLOSE)/(HHV(HIGH,50)-LLV(LOW,50))+100;
VAR7F:=(-100)*(HHV(HIGH,70)-CLOSE)/(HHV(HIGH,70)-LLV(LOW,70))+100;
VAR80:=((CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*100+10)*5;
VAR81:=((CLOSE-MA(CLOSE,50))/MA(CLOSE,50)*100+10)*5;
VAR82:=((CLOSE-MA(CLOSE,70))/MA(CLOSE,70)*100+10)*5;
VAR83:=(VAR7D+VAR7E+VAR7F+VAR80+VAR81+VAR82)/6;
VAR84:=EMA(VAR83,3);
VAR85:=ABS(VAR80-VAR82);
VAR86:=(VAR83+VAR85)/2;
VAR87:=(-1)*(EMA(100*(1-WINNER(CLOSE)),1)-50)+50;
VAR88:=VAR87+VAR86;
VAR89:=IF(VAR7C>0 AND VAR88<0,200,0);
VAR8A:=IF(VAR86<0 AND CLOSE=LLV(CLOSE,5) AND CLOSE/REF(CLOSE,1)>0.905 AND CLOSE/REF(CLOSE,1)<1.05 AND VOL/CAPITAL*100<5,-50,0);
VAR8B:=IF(VAR88<0 AND VAR8A=-50,100,0);
VAR8D:=REF(CLOSE,2)*0.865;
VAR8E:=REF(CLOSE,13)*0.772;
VAR8F:=MIN(VAR8D,VAR8E);
VAR90:=100*VOL/CAPITAL;
VAR92:=IF((CLOSE-VAR8F)/CLOSE<0.03 AND SUM(VAR90,5)/5<1.8,1,0);
VAR96:=(VAR89>0 AND VAR8B>0 AND SUM(VOL/CAPITAL*100,5)/5<1 OR VAR92>0) AND (VAR8A<0 OR VAR7C>0);
VAR97:=VAR89>0 AND VAR8B>0 AND SUM(VOL/CAPITAL*100,5)/5<1 OR VAR92>0 AND REF(CLOSE,1)/REF(CLOSE,2)>0.902;
VAR98:=VAR96 OR VAR97;
VARA4:=AMOUNT/VOL/100;
VARA5:=(3*HIGH+LOW+OPEN+2*CLOSE)/7;
VARA7:=SUM(AMOUNT,13)/VARA4/100;
VARAE:=DMA(VARA5,VOL/VARA7);
VARB1:=MA(HHV(HIGH,488),18);
VARB2:=MA(HHV(HIGH,220),18);
VARB3:=MA(HHV(HIGH,98),18);
VARB4:=MA(LLV(LOW,488),18);
VARB5:=MA(LLV(LOW,220),18);
VARB6:=MA(LLV(LOW,98),18);
VARB7:=MA((VARB4*0.96+VARB5*0.96+VARB6*0.96+VARB1*0.558+VARB2*0.558+VARB3*0.558)/6,18);
VARB8:=MA((VARB4*1.25+VARB5*1.23+VARB6*1.2+VARB1*0.55+VARB2*0.55+VARB3*0.65)/6,18);
VARB9:=MA((VARB4*1.3+VARB5*1.3+VARB6*1.3+VARB1*0.68+VARB2*0.68+VARB3*0.68)/6,18);
VARBA:=MA((VARB7*3+VARB8*2+VARB9)/6*1.738,18);
VARBC:=LOW;
VARBD:=REF(LOW,1);
VARBE:=SMA(ABS(VARBC-VARBD),3,1)/SMA(MAX(VARBC-VARBD,0),3,1)*100;
VARBF:=MA(IF(CLOSE*1.35<=VARBA,VARBE*10,VARBE/10),3);
VARC0:=LLV(LOW,30);
VARC1:=HHV(VARBF,30);
VARC2:=IF(LOW<=VARC0,(VARBF+VARC1*2)/2,0);
WXBM:(MA(VARC2 AND CLOSE<COST(1),3) AND (CLOSE-VARAE)/VARAE*100<-11)*118,COLORRED,LINETHICK2;
DRAWTEXT(VAR61 OR VAR98,70,'★大黑马'),COLORYELLOW;
DRAWTEXT(WXBM,100,'BM'),COLORRED;
STICKLINE(VAR61,0,120,3,0),COLORWHITE;
STICKLINE(VAR98,0,90,3,0),COLORYELLOW;
X:=C-REF(MA(C,20),11);
LGL:=IF(EMA(C,5)/EMA(EMA(C,9),16)<=0.85 AND C/REF(C,1)>0.905 AND C/REF(C,1)<1.05 AND VOL/CAPITAL*100<5,50,0);
WR1:=-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34))+100*X;
WR2:=-100*(HHV(HIGH,50)-CLOSE)/(HHV(HIGH,50)-LLV(LOW,50))+100;
WR3:=-100*(HHV(HIGH,70)-CLOSE)/(HHV(HIGH,70)-LLV(LOW,70))+100*X;
BIAS1:=((CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*100+10)*5;
BIAS2:=((CLOSE-MA(CLOSE,50))/MA(CLOSE,50)*100+10)*5;
BIAS3:=((CLOSE-MA(CLOSE,70))/MA(CLOSE,70)*100+10)*5;
S1:=(WR1+WR2+WR3+BIAS1+BIAS2+BIAS3)/6*X;
S2:=EMA(S1,3);
S3:=ABS(BIAS1-BIAS3);
SX:=(S1+S3)/2;
XC1:=(-1)*(EMA(100*(1-WINNER(CLOSE)),1)-50)+50;
CCC:=XC1+SX;
ZJZ:=IF( LGL>0 AND CCC<0,200,0)*X;
LXL:=IF(SX<0 AND C=LLV(C,5) AND C/REF(C,1)>0.905 AND C/REF(C,1)<1.05 AND VOL/CAPITAL*100<5,-50,0);
JBJ:=IF(CCC<0 AND LXL=-50,100,0)*X;
MA3:= MA(C,3);
C0:=REF(C,2)*0.865;
C1:=REF(C,13)*0.772;
BOT:=MIN(C0,C1);
HSL:=100*VOL/CAPITAL*X;
MA13:=MA(C,13)*X;
CXC:=IF((C-BOT)/C<3/100 AND SUM(HSL,5)/5<1.8,1,0);
VMC:=IF(CXC>0 AND (LXL<0 OR LGL>0),10,0);
满仓:IF((VMC>0),120,0),COLORRED,LINETHICK3;
DRAWTEXT(满仓>0 AND REF(满仓,1)=0,100,'满仓'),COLORRED;
半仓:IF(((ZJZ>0 AND JBJ>0 AND SUM(VOL/CAPITAL*100,5)/5<1) OR (CXC>0 AND REF(C,1)/REF(C,2)>0.902)) OR (((ZJZ>0 AND JBJ>0 AND SUM(VOL/CAPITAL*100,5)/5<1) OR CXC>0) AND (LXL<0 OR LGL>0)) AND VMC<10 ,100,0),COLORMAGENTA,LINETHICK2;
V93:=(((ZJZ>0 AND JBJ>0 AND SUM(VOL/CAPITAL*100,5)/5<1) OR CXC>0) AND (LXL<0 OR LGL>0)) ;
V90:=((ZJZ>0 AND JBJ>0 AND SUM(VOL/CAPITAL*100,5)/5<1) OR (CXC>0 AND REF(C,1)/REF(C,2)>0.902));
买11:IF((V93 OR V90),80,0),COLORYELLOW,LINETHICK2;
VAR2Q:=(MA(CLOSE,80)-MA(CLOSE,13)/3);
神奇线:= MA((CLOSE-VAR2Q)/VAR2Q,2);
买12:IF(CROSS(神奇线,0) AND LOW/REF(HIGH,1)<1.012 AND ((C-REF(C,2))/C)>0.06,100,0),COLORMAGENTA,LINETHICK2;
YY:=SMA(SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,18,1),12,1);
YT:=SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,12,1);
ST:=IF(CROSS(YT,YY),30,0);
VAR5PT:=(HIGH+LOW+CLOSE)/3;
VAR6PT:=(VAR5PT-MA(VAR5PT,14))/(0.015*AVEDEV(VAR5PT,14));
VAR7PT:=(VAR5PT-MA(VAR5PT,85))/(0.015*AVEDEV(VAR5PT,85));
SA:=IF(VAR7PT>=200 AND VAR6PT>=150,10,0);
VAR3QQ:=REF(CLOSE,1);
VAR4QQ:=SMA(MAX(CLOSE-VAR3QQ,0),6,1)/SMA(ABS(CLOSE-VAR3QQ),6,1)*100;
SM:=IF(CROSS(80,VAR4QQ),100,0);
卖11:IF((SM AND (SA OR ST)),120,0),COLORCCCC33,LINETHICK2;
DRAWTEXT( 卖11>0,110,'卖'),COLORCCCC33;
XX2:=(MA(CLOSE,80)-MA(CLOSE,13)/3);
SQX:=MA((CLOSE-XX2)/XX2,10)*0.01;
买3:IF(CROSS(SQX,0) AND LOW/REF(HIGH,1)<1.012,60,0), STICK,COLORWHITE,LINETHICK2;
稳赚:IF(COUNT(SQX>REF(SQX,1),3)=3 AND COUNT(SQX<0,10)=10 AND REF(SQX,3)=LLV(SQX,10),60,0),COLOR9999FF;
买4: IF(REF(SQX,2)=LLV(SQX,20) AND REF(SQX,2)<0.071 AND REF(SQX,2)<REF(SQX,1) AND NOT(REF(LOW,1)>REF(HIGH,2) AND LOW>REF(HIGH,1)) AND CLOSE>REF(CLOSE,1),60,0),COLORFF00FF,LINETHICK2;
DRAWTEXT( 买3>0,40 ,' 买3'),COLORWHITE;
DRAWTEXT( 稳赚>0,40 ,'稳赚'),COLOR9999FF;

飞狐极品稳赚指标公式

 

相关文章