在线检测未来函数

飞狐微分MACD指标公式

来源:Internet,编辑:股旁网,2014-05-29

DIF12:=(EMA(CLOSE,12)-EMA(CLOSE,26))/((EMA(CLOSE,12)+EMA(CLOSE,26))/2)*1000;
DEA12:=EMA(DIF12,9);
相对MACD:2*(DIF12-DEA12),COLORSTICK,COLORRED;
KDIF12:=3*(DIF12-DEA12);{KDIF12:=2*(DIF12-DEA12)};
KDEA12:=SMA(KDIF12,5,2);
买卖力道:=2*(KDIF12-KDEA12),COLORLIRED,LINETHICK1;
相对DIF:=DIF12,COLORMAGENTA,LINETHICK2;
相对DEA:=DEA12,COLORGREEN,LINETHICK2;
微分DIF:KDIF12,COLORYELLOW,LINETHICK1;
微分DEA:=KDEA12,COLORLIGRAY,LINETHICK1;
STICKLINE(相对MACD<REF(相对MACD,1)AND 相对MACD>0,0,相对MACD,0,0 ),COLOR00BBFF;
STICKLINE(相对MACD>=REF(相对MACD,1)AND 相对MACD>0,0,相对MACD,0,0 ),COLOR0011BB;
STICKLINE(相对MACD>REF(相对MACD,1)AND 相对MACD<0,0,相对MACD,0,0),COLORBB11BB;
STICKLINE(相对MACD<=REF(相对MACD,1)AND 相对MACD<0,0,相对MACD,0,0),COLORFFBB11;
WR反向:(0-微分DIF)-100,COLORRED;
极近:IF(微分DIF-WR反向<=10,-150,-200),COLOR00FF00;
VAR4:=MA(CLOSE,5);
VAR5:=MA(CLOSE,10);
VAR6:=MA(CLOSE,30);
VAR7:=MA(CLOSE,60);
VAR8:=EMA(COST(85),7);
VAR9:=EMA(COST(15),7);
VARA:=(SUM(((CLOSE * VOL) * 10),4) / SUM((VOL * 200),4));
VARB:=(INTPART((VARA * 10)) / 10);
VARC:=(SUM(((CLOSE * VOL) * 10),7) / SUM((VOL * 200),7));
VARD:=(INTPART((VARC * 10)) / 10);
VARE:=(SUM(((CLOSE * VOL) * 10),28) / SUM((VOL * 200),28));
VARF:=(INTPART((VARE * 10)) / 10);
短线趋势:=(EMA(CLOSE,5) - EMA(CLOSE,10)),COLORMAGENTA,LINETHICK2;
中线趋势:=EMA(短线趋势,9),COLORMAGENTA,LINETHICK3;
VAR10:=((0 - ((10 * (HHV(CLOSE,5) - CLOSE)) / (HHV(CLOSE,5) - LLV(LOW,5)))) + 10);
VAR11:=((0 - ((10 * (HHV(CLOSE,10) - CLOSE)) / (HHV(CLOSE,10) - LLV(LOW,10)))) + 10);
VAR12:=((0 - ((10 * (HHV(CLOSE,20) - CLOSE)) / (HHV(CLOSE,20) - LLV(LOW,20)))) + 10);
VAR13:=((0 - ((10 * (HHV(CLOSE,30) - CLOSE)) / (HHV(CLOSE,30) - LLV(LOW,30)))) + 10);
VAR14:=REF(中线趋势,1);
VAR15:=中线趋势;
VAR16:=(VAR15 - VAR14);
VAR17:=REF(短线趋势,1);
VAR18:=短线趋势;
VAR19:=(VAR18 - VAR17);
VAR1A:=OPEN;
VAR1B:=CLOSE;
庄家吸筹:IF((((((((VAR1A <= VAR4) AND (VAR1A <= VAR5)) AND (VAR1A <= VAR6)) AND (VAR1B >= VAR4)) AND (VAR1B >= VARF)) AND (VAR16 > 0)) AND (VAR19 > 0)),-50,-100),LINETHICK2,COLOR66FF00;

飞狐微分MACD指标公式

 

相关文章