在线检测未来函数

通达信至简KDJ指标公式

来源:Internet,编辑:股旁网,2014-05-29

RSV1:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
K1:=SMA(RSV1,5,1);
D1:=SMA(K1,5,1);
J1:=3*K1-2*D1;
AA1:=EMA(J1,5);
AA2:=REF(AA1,1);
STICKLINE(AA1>AA2,AA1,AA2,3,0),COLORLIMAGENTA;
STICKLINE(AA1>AA2,AA1,AA2,2,0),COLORLIGRAY;
STICKLINE(AA1>AA2,AA1,AA2,1,0),COLORCYAN;
STICKLINE(AA1<=AA2,AA1,AA2,3,0),COLOR006600;
STICKLINE(AA1<=AA2,AA1,AA2,2,0),COLOR00BB00;
STICKLINE(AA1<=AA2,AA1,AA2,1,0),COLOR00CC00;
STICKLINE(C>0,AA1,AA2,0,0),COLORYELLOW;
RSV2:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K2:=SMA(RSV2,3,1);
D2:=SMA(K2,3,1);
J2:=3*K2-2*D2;
BB1:=EMA(J2,5);
BB2:=REF(BB1,1);
STICKLINE(BB1>BB2,BB1,BB2,2.8,0),COLORMAGENTA;
STICKLINE(BB1>BB2,BB1,BB2,2,0),COLOR0000C5;
STICKLINE(BB1>BB2,BB1,BB2,1,0),COLOR0000E5;
STICKLINE(BB1<=BB2,BB1,BB2,2.8,0),COLOR353500;
STICKLINE(BB1<=BB2,BB1,BB2,2,0),COLOR757500;
STICKLINE(BB1<=BB2,BB1,BB2,1,0),COLORLIBLUE;
STICKLINE(C>0,BB1,BB2,0,0),COLORGREEN;
DD:=AA1>AA2 AND BB1>BB2;
注意买入:=DD AND NOT(REF(DD,1)) AND (AA1<50 OR BB1<50) ;
DRAWICON(注意买入,-5,1);
注意卖出:=REF(DD,1)=1 AND NOT(DD),LINETHICK0;
DRAWICON(注意卖出,105,2);
{KDJ月金}
月K:="KDJ.K#MONTH"(9,3,3);
月J:="KDJ.J#MONTH"(9,3,3);
{KDJ周金}
周K:="KDJ.K#WEEK"(9,3,3);
周J:="KDJ.J#WEEK"(9,3,3);
{KDJ日金}
日K:="KDJ.K#DAY"(9,3,3);
日J:="KDJ.J#DAY"(9,3,3);
月死叉:STICKLINE(月J<月K,-20,-30,4,0),COLORBLUE;
金叉:STICKLINE(月J>月K,-20,-30,4,0),COLORRED;
周死叉:STICKLINE(周J<周K,-20,-10,4,0),COLORGREEN;
周金叉:STICKLINE(周J>周K,0,-10,4,0),COLORFF00FF;
{下面四句是在指标上提示颜色含义,顺便说明下周月KJ所在位置}
{【深蓝月死叉K】:REFDATE(月K,DATE),COLORBLUE;
【大红月金叉J】:REFDATE(月J,DATE),COLORRED;
【草绿周死叉K】:REFDATE(周K,DATE),COLORGREEN;
【粉红周金叉J】:REFDATE(周J,DATE),COLORFF00FF;};

通达信至简KDJ指标公式

 

相关文章