在线检测未来函数

大智慧DMI趋势指标公式

来源:Internet,编辑:股旁网,2014-05-27

nx:=9;
ATR := SMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),Nx,1);
HD := HIGH-REF(HIGH,1);
LD := REF(LOW,1)-LOW;
DMP:= SMA(IF(HD>0 AND HD>LD,HD,0),Nx,1);
DMM:= SMA(IF(LD>0 AND LD>HD,LD,0),Nx,1);
多方: DMP*100/ATR,linethick3;
空方: DMM*100/ATR,linethick3;
趋势线: SMA(ABS(空方-多方)/(空方+多方)*100,Nx,1);
10;20;40;60;

大智慧DMI趋势指标公式

 

相关文章