在线检测未来函数

通达信5200短期均线主图指标公式

来源:Internet,编辑:股旁网,2014-05-27

M5:MA(CLOSE,5);
M10:MA(CLOSE,10);
M20:MA(CLOSE,20);
M55:MA(CLOSE,55),COLOR006400;
M5上:IF(M5>=REF(M5,1),M5,DRAWNULL),COLORRED,LINETHICK2;
M5下:IF(M5<REF(M5,1),M5,DRAWNULL),COLORFF6000,LINETHICK2;
M10上:IF(M10>=REF(M10,1),M10,DRAWNULL),COLORRED;
M10下:IF(M10<REF(M10,1),M10,DRAWNULL),COLORFF6000;
M20上:IF(M20>=REF(M20,1),M20,DRAWNULL),COLORRED;
M20下:IF(M20<REF(M20,1),M20,DRAWNULL),COLORFF6000;
M55上:IF(M55>=REF(M55,1),M55,DRAWNULL),COLORRED;
M55下:IF(M55<REF(M55,1),M55,DRAWNULL),COLOR006400;
M110:MA(CLOSE,110),COLORFF6000;
M110上:IF(M110>=REF(M110,1),M110,DRAWNULL),COLORRED,LINETHICK2;
M110下:IF(M110<REF(M110,1),M110,DRAWNULL),COLORFF6000,LINETHICK2;
M200:MA(CLOSE,200),COLORGREEN;
M200上:IF(M200>=REF(M200,1),M200,DRAWNULL),COLORRED,LINETHICK2;
M200下:IF(M200<REF(M200,1),M200,DRAWNULL),COLORGREEN,LINETHICK2;
DRAWICON(CROSS(M110,M200),L*0.96,25);
{涨停(含ST)标色:黄柱}
ST:=NAMELIKE('ST')||NAMELIKE('*ST')||NAMELIKE('SST');
C1:=REF(C,1);
ST涨停:=IF(1.05*C1-C<0.005,1,0)&&ST;
非ST涨停:=IF(1.1*C1-C<0.005,1,0);
涨停:=ST涨停||非ST涨停;
STICKLINE(涨停,O,C,2.8,0),COLOR00FFFF;
STICKLINE(涨停,H,L,0,0),COLOR00FFFF;
{跌停(含ST)标色:绿柱}
ST跌停:=IF(C-0.95*C1<0.005,1,0)&&ST;
非ST跌停:=IF(C-0.9*C1<0.005,1,0);
跌停:=ST跌停||非ST跌停;
STICKLINE(跌停,O,C,2.8,0),COLORGREEN;
STICKLINE(跌停,H,L,0,1),COLORGREEN;
{非ST涨幅>4%标色:黄柱}
半涨1:=IF((C-C1)*100/C1>=(4-0.01*100/C1),1,0);
半涨2:=IF((C-C1)*100/C1<(9-0.01*100/C1),1,0);
JRS:=半涨1&&半涨2&&NOT(ST);
STICKLINE(JRS,O,C,2.8,0),COLOR00FFFF;
STICKLINE(JRS,H,L,0,0),COLOR00FFFF;
假阴线:=C<O AND C>REF(C,1) AND REF(C,1)>REF(O,1);
STICKLINE(假阴线,O,C,3.1,0),COLORCD00CD;
所属板块:=STRCAT('所属板块: ',STRCAT(STRCAT(STRCAT('[行业]-',HYBLOCK),STRCAT(' [地域]-',DYBLOCK)),STRCAT(' [概念]-',GNBLOCK)));
DRAWTEXT_FIX(ISLASTBAR,0.005,0.020,0,所属板块),COLORGREEN;
DRAWTEXT_FIX(1,0.005,0.080,0,EXTERNSTR(0,1))COLORCD00CD;

通达信5200短期均线主图指标公式

 

相关文章