在线检测未来函数

通达信裸K主图指标公式

来源:Internet,编辑:股旁网,2014-06-10

所属板块:=STRCAT('【所属板块】',STRCAT(STRCAT(STRCAT(' [行业]—',HYBLOCK),STRCAT(' [地域]—',DYBLOCK)),STRCAT(' [概念]—',GNBLOCK)));
总股本:=STRCAT(STRCAT(' 总股本:',CON2STR(TOTALCAPITAL/1000000,2)),'亿');
流通盘:=STRCAT(STRCAT(' 流通盘:',CON2STR(CAPITAL/1000000,2)),'亿');
全流通:=STRCAT(STRCAT(' 全流通:',CON2STR(CAPITAL/TOTALCAPITAL*100,2)),'%');
市值:=STRCAT(STRCAT(' 流通市值:',CON2STR((CAPITAL/1000000)*C,2)),'亿');
上市日期:=STRCAT(' 上市日期: ',CON2STR(HHV((BARSCOUNT(C)=0)*(DATE+19000000),0),0));
股本市值:=STRCAT('【股本市值】',STRCAT(STRCAT(STRCAT(STRCAT(总股本,流通盘),全流通),市值),上市日期));
DRAWTEXT_FIX(ISLASTBAR,0.005,0.01,0,所属板块),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR,0.005,0.10,0,股本市值),COLORYELLOW;
HHV(H,480),COLORFFFFFF,POINTDOT; {原文链接:HTTP://WWW.55188.COM/THREAD-5541712-1-1.HTML}
涨幅:=5;
倍量:=1.5;
单阳:=C>O*(1+阳涨幅/100) AND VOL>REF(VOL,1)*阳倍量;
DRAWTEXT(CURRBARSCOUNT<100 AND 单阳,L*0.98,'阳'),COLOR00FFFF;
高不破价:=REF(C,BARSLAST(单阳));
中不破价:=REF((C+L)/2,BARSLAST(单阳));
低不破价:=REF(L,BARSLAST(单阳));
单阳不破:=CURRBARSCOUNT<100 AND BARSLAST(单阳)<11 AND (LLV(L,BARSLAST(单阳))>低不破价 OR LLV(L,BARSLAST(单阳))=低不破价);
STICKLINE(单阳不破,低不破价-低不破价*0.003,低不破价,4,0),COLORYELLOW,LINETHICK1;
DRAWTEXT(BARSLAST(单阳)=1 AND 单阳不破,低不破价*0.98,'1'),COLORGREEN;
DRAWTEXT(BARSLAST(单阳)=2 AND 单阳不破,低不破价*0.98,'2'),COLORGREEN;
DRAWTEXT(BARSLAST(单阳)=3 AND 单阳不破,低不破价*0.98,'3'),COLORGREEN;
DRAWTEXT(BARSLAST(单阳)=4 AND 单阳不破,低不破价*0.98,'4'),COLORGREEN;
DRAWTEXT(BARSLAST(单阳)=5 AND 单阳不破,低不破价*0.98,'5'),COLORGREEN;
DRAWTEXT(BARSLAST(单阳)=6 AND 单阳不破,低不破价*0.98,'6'),COLORGREEN;
DRAWTEXT(BARSLAST(单阳)=7 AND 单阳不破,低不破价*0.98,'7'),COLORGREEN;
DRAWTEXT(BARSLAST(单阳)=8 AND 单阳不破,低不破价*0.98,'8'),COLORGREEN;
DRAWTEXT(BARSLAST(单阳)=9 AND 单阳不破,低不破价*0.98,'9'),COLORGREEN;
QA1:=REF(CLOSE,3)=HHV(CLOSE,2*3+1);
QB1:=BACKSET(QA1,3+1);
QC1:=FILTER(QB1,3) AND CLOSE=HHV(CLOSE,3+1);
QD1:=BARSLAST(QC1);
QE1:=IF(QC1,CURRBARSCOUNT,0);
QF1:=IF(QD1,REF(QE1,QD1),QE1);
QG1:=CONST(QF1);
次水平线:DRAWLINE(CURRBARSCOUNT=QG1,CLOSE,ISLASTBAR,REF
(CLOSE,QG1-1),1),COLORYELLOW;
AA:=REF(C,1);
大阳线:=IF((C-AA)*100/AA>=5,1,0);
涨停:=IF((C-AA)*100/AA>=(10-0.05*100/AA),1,0);
STICKLINE(大阳线,O,C,-1,0),COLORMAGENTA;
STICKLINE(大阳线,H,L,0,0),COLORMAGENTA;
STICKLINE(涨停,O,C,-1,0),COLOR00AEFF;
STICKLINE(涨停,H,L,0,0),COLOR00AEFF;
TY:=L;
A1:=REF(TY,10)=HHV(TY,2*10+1); B5:=FILTER(A1,10); C5:=BACKSET(B5,10+1); HD:=FILTER(C5,10);
A2:=REF(TY,10)=LLV(TY,2*10+1); B6:=FILTER(A2,10); C6:=BACKSET(B6,10+1); LD:=FILTER(C6,10);
前期低位:REF(L,BARSLAST(LD)),COLOR00FF00,POINTDOT;
STICKLINE(L,前期低位,前期低位,8,0),COLORRED;
TZ:=H;
A3:=REF(TY,10)=HHV(TY,2*10+1); B7:=FILTER(A1,10); C7:=BACKSET(B5,10+1); MD:=FILTER(C5,10);
A4:=REF(TY,10)=LLV(TY,2*10+1); B8:=FILTER(A2,10); C8:=BACKSET(B6,10+1); ND:=FILTER(C6,10);
前期高位:REF(H,BARSLAST(MD)),COLOR00FF00,POINTDOT;
STICKLINE(H,前期高位,前期高位,8,0),COLORYELLOW;

通达信裸K主图指标公式

 

相关文章