在线检测未来函数

飞狐强弱判官主图指标公式

来源:Internet,编辑:股旁网,2014-06-11

N1:=5;N2:=10;N3:=20;N4:=30;P:=2;M:=20;N:=250;M1:=55;
MA1:EMA(CLOSE,N1);
MA2:EMA(CLOSE,N2);
MA3:EMA(CLOSE,N3);
MA4:EMA(CLOSE,N4);
TJ1:=CROSS(MA1,MA2) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018
OR CROSS(MA1,MA4) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018
OR CROSS(MA2,MA3) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018
OR CROSS(MA1,MA3) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018;
TJ2:=(MAX(MA1,MAX(MA2,MA3))-MIN(MA1,MIN(MA2,MA3)))/
MIN(MA1,MIN(MA2,MA3))*100<=P;
XG:=TJ1 AND TJ2;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
DIFF:= EMA(CLOSE,12) - EMA(CLOSE,26);
DEA :=EMA(DIFF,9);
MACD:=2*(DIFF-DEA);
做多:=IF(K>D AND MACD>0 AND V>1,2,0),COLORRED;
做空:=IF(K<D AND MACD<0 AND V>1,-2,0),COLOR00FF00;
强洗:=IF(MACD>0 AND K<D AND V>1,1,0),COLOR0099FF;
弱升:=IF(MACD<0 AND K>D AND V>1,-1,0),COLORFFFF00;
STICKLINE(做多,L,H,0,0),COLORRED;
STICKLINE(做多 AND C<O,L,H,0,0),COLORFFFF00;
STICKLINE(做多 AND C>=O,C,O,8,1),COLORRED;
STICKLINE(做多 AND C<O,C,O,8,0),COLOR990099;
STICKLINE(做多 AND C<O,C,O,4,0),COLORCC00CC;
STICKLINE(做多 AND C<O,C,O,2,0),COLORFF00FF;
STICKLINE(做多 AND C>=O,C,O,8,0),COLOR000099;
STICKLINE(做多 AND C>=O,C,O,4,0),COLOR0000BB;
STICKLINE(做多 AND C>=O,C,O,2,0),COLOR0000DD;
STICKLINE(做多 AND C>=O,C,O,1,0),COLOR0000FF;
STICKLINE(做空 AND C>=O,L,H,0.1,0),COLOR0000FF;
STICKLINE(做空 AND C>=O,C,O,8,1),COLOR00FF00;
STICKLINE(做空 AND C<O,C,O,8,0),COLOR009900;
STICKLINE(做空 AND C<O,C,O,4,0),COLOR00CC00;
STICKLINE(做空 AND C<O,C,O,1,0),COLOR00FF00;
STICKLINE(强洗 AND C>=O,L,H,0.1,0),COLOR0000FF;
STICKLINE(强洗 AND C>=O,C,O,8,1),COLORFFFFFF;
STICKLINE(强洗 AND C<O,C,O,8,0),COLOR999999;
STICKLINE(强洗 AND C<O,C,O,4,0),COLORCCCCCC;
STICKLINE(强洗 AND C<O,C,O,1,0),COLORFFFFFF;
STICKLINE(弱升 AND C>=O,L,H,0,0),COLOR0000FF;
STICKLINE(弱升 AND C>=O,C,O,8,1),COLOR00FFFF;
STICKLINE(弱升 AND C<O,C,O,8,0),COLOR009999;
STICKLINE(弱升 AND C<O,C,O,4,0),COLOR00CCCC;
STICKLINE(弱升 AND C<O,C,O,1,0),COLOR00FFFF;
STICKLINE(FILTER(TJ1,3),C,O,8,0),COLOR0000FF;
DRAWICON(FILTER(XG,3),L*0.97,1);
GET:=ZIG(3,3),COLORYELLOW;
PL5:=ZIG(3,5);
EN1:=ZIG(3,5)>REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)<=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)<=REF(ZIG(3,5),3);
EX1:=ZIG(3,5)<REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)>=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)>=REF(ZIG(3,5),3);
PL10:=ZIG(3,10);
EN2:=ZIG(3,10)>REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)<=REF(ZIG(3,10),2) AND REF(ZIG(3,10),2)<=REF(ZIG(3,10),3);
EX2:=ZIG(3,10)<REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)>=REF(ZIG(3,10),2) AND REF(ZIG(3,10),2)>=REF(ZIG(3,10),3);
PL20:=ZIG(3,20);
EN3:=ZIG(3,20)>REF(ZIG(3,20),1) AND REF(ZIG(3,20),1)<=REF(ZIG(3,20),2) AND REF(ZIG(3,20),2)<=REF(ZIG(3,20),3);
EX3:=ZIG(3,20)<REF(ZIG(3,20),1) AND REF(ZIG(3,20),1)>=REF(ZIG(3,20),2) AND REF(ZIG(3,20),2)>=REF(ZIG(3,20),3);
PL40:=ZIG(3,40);
走强1:=BARSLAST(PL5<REF(PL5,1));
走弱1:=BARSLAST(PL5>REF(PL5,1));
走强2:=BARSLAST(PL10<REF(PL10,1));
走弱2:=BARSLAST(PL10>REF(PL10,1));
走强3:=BARSLAST(PL20<REF(PL20,1));
走弱3:=BARSLAST(PL20>REF(PL20,1));
ZTJZ5:=IF(PL10>REF(PL10,1),COUNT(EN1,走强2),0);
ZTJD5:=IF(PL10>REF(PL10,1),COUNT(EX1,走强2),0);
DTJZ5:=IF(PL10<REF(PL10,1),COUNT(EN1,走弱2),0);
DTJD5:=IF(PL10<REF(PL10,1),COUNT(EX1,走弱2),0);
ZTJZ10:=IF(PL20>REF(PL20,1),COUNT(EN2,走强3),0);
ZTJD10:=IF(PL20>REF(PL20,1),COUNT(EX2,走强3),0);
DTJZ10:=IF(PL20<REF(PL20,1),COUNT(EN2,走弱3),0);
DTJD10:=IF(PL20<REF(PL20,1),COUNT(EX2,走弱3),0);
DRAWTEXT(EN1 AND DTJZ5=1,L*0.98,'(A)'),COLORFFFF00;
DRAWTEXT(EX1 AND DTJD5=2,H*1.02,'(B)'),COLORFF00FF;
DRAWTEXT(EN2 AND ZTJZ5=1,L*0.98,'(C)'),COLOR0000FF;
DRAWTEXT(EX1 AND PL10>REF(PL10,1) AND ZTJD5=1,H*1.02,'⑴'),COLOR0000FF;
DRAWTEXT(EN1 AND PL10>REF(PL10,1) AND ZTJZ5=2,L*0.98,'⑵'),COLOR0000FF;
DRAWTEXT(EX1 AND PL10>REF(PL10,1) AND ZTJZ5=2,H*1.02,'⑶'),COLOR0000FF;
DRAWTEXT(EN1 AND PL10>REF(PL10,1) AND ZTJZ5=3,L*0.98,'⑷'),COLOR0000FF;
DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=1,H*1.02,'⑸'),COLOR0000FF;
DRAWTEXT(EN2 AND DTJZ10=1,L*0.93,'Ⅰ'),COLORFF00FF;
DRAWTEXT(EX2 AND DTJD10=2,H*1.05,'Ⅱ'),COLORFFFF00;
DRAWTEXT(EN3 AND ZTJZ10=1,L*0.93,'Ⅲ'),COLOR0000FF;
DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=1,H*1.03,'①'),LINETHICK3,COLOR00FFFF;
DRAWTEXT(EN2 AND PL20>REF(PL20,1) AND ZTJZ10=2,L*0.95,'②'),LINETHICK3,COLOR00FFFF;
DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=2 OR (ZTJD10=0 OR ZTJD10=2)
AND EX2,H*1.03,'③'),LINETHICK3,COLOR00FFFF;
DRAWTEXT(EN2 AND PL20>REF(PL20,1) AND ZTJZ10=3,L*0.95,'④'),
LINETHICK3,COLOR00FFFF;
HR:=HHV(HIGH,M1);
HRY:=LLV(LOW,M1);
HRY11:=HR*HRY;
HRY33:SQRT(HRY11),COLORGREEN,LINETHICK2;PARTLINE(C>HRY33 AND
HRY33 >=REF(HRY33 ,1), HRY33),LINETHICK2,COLORRED;

飞狐强弱判官主图指标公式

 

相关文章