在线检测未来函数

通达信量悟金BOLL主图指标公式

来源:Internet,编辑:股旁网,2014-06-14

N:=14;
BOLL:MA(CLOSE,N);
UPPER:BOLL+2*STD(CLOSE,N),LINETHICK2;
LOWER:BOLL-2*STD(CLOSE,N),LINETHICK2;
ENTERLONG:CROSS(CLOSE,LOWER);
EXITLONG:CROSS(CLOSE,UPPER);
HIGH5:REF(HIGH,BARSLAST(V=HHV(V,5))),COLORYELLOW,LINETHICK1,DOTLINE;
LOW5:REF(LOW,BARSLAST(V=HHV(V,5))),COLORYELLOW,LINETHICK1,DOTLINE;
C5:REF(C,BARSLAST(V=HHV(VOL,5))),COLORYELLOW,LINETHICK1;
XC: V>=REF(V*1.88,2) AND V>=MA(V,5)*1.68 ,NODRAW;
STICKLINE(XC,O,C,1,0),COLORGRAY;
持仓:IF(CLOSE>=SAR(4,5,20),SAR(4,5,20),
DRAWNULL),CIRCLEDOT,COLORRED,{COLOR9955FF};
_空仓:IF(H<=SAR(4,5,20),SAR(4,5,20),
DRAWNULL),CIRCLEDOT,COLORBLUE,{COLORDDFF00};
V34:REF(LOW,BARSLAST(V=LLV(VOL,34))),COLORBROWN,LINETHICK2,DOTLINE;
V34H:REF(H,BARSLAST(V=LLV(VOL,34))),COLORBROWN,LINETHICK1,DOTLINE;
V34C:REF(C,BARSLAST(V=LLV(VOL,34))),COLORBROWN,LINETHICK1;
AA0:=SUMBARS(VOL,CAPITAL),NODRAW;
地量1:IF(CAPITAL=0,AMOUNT=LLV(AMOUNT,34),VOL<MA(VOL,AA0)/3),NODRAW;
STICKLINE(地量1,OPEN,CLOSE,1,0),COLORBROWN;
V3:MA(V,34),NODRAW;
DRAWTEXT (VOL>MA(VOL,5)*2 AND V>V3*3 AND C<REF(C,1)*1.05,H,'天量'),COLORYELLOW;
C2:=REF(C,1),NODRAW;
涨停:=REF(C,1)*1.1-C<0.01 AND H=C,NODRAW;
STICKLINE(涨停,OPEN,CLOSE,0001,0),COLORYELLOW;
STICKLINE(涨停,H,L,0,0),COLORRED;
跌停:=IF((C2-C)*100/C2>=(10-0.01*100/C2) AND L=C,1,0),NODRAW;
STICKLINE(跌停,OPEN,CLOSE,1,0),COLORBLUE;
RSV:=(CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10))*100;
K:=SMA(RSV,5,1);
D:=SMA(K,5,1);
J:=3*K-2*D;
X:=REF(J,1)<10 AND H>REF(H,1) AND C>REF(C,1) AND C>REF(O,1) AND L>REF(L,1);
X0:=REF(J,1)>99 AND H>REF(H,1) AND C>REF(C,1) AND C>REF(O,1) AND L>REF(L,1);
K0:=REF(K,1)>83 AND H>REF(H,1) AND C>REF(C,1) AND C>REF(O,1) AND L>REF(L,1);
K1:=REF(K,1)<11 AND H>REF(H,1) AND C>REF(C,1) AND C>REF(O,1) AND L>REF(L,1);
STICKLINE(X,L ,L,20,0),COLOR008888;
STICKLINE(X,C ,O,1,0),COLORFF00FF;
STICKLINE(X0,O ,C,1,0),COLORWHITE;
STICKLINE(K0,O ,C,1,0),COLOR1880FF;
STICKLINE(K1,C ,O,2,2),COLOR00CCFF;
VAR9:=CLOSE-REF(CLOSE,5),NODRAW;
VARA:=EMA(EMA(VAR9,5),5)/EMA(EMA(ABS(VAR9),5),5),NODRAW;
VARC:=EMA(EMA(VAR9,10),10)/EMA(EMA(ABS(VAR9),20),20),NODRAW;
卖出:=IF(VARA>0 AND CROSS(VARC,VARA),90,100);
DRAWICON(卖出<0,H+0.05,2); 买线:=EMA(CLOSE,2),NODRAW;
卖线:=EMA(SLOPE(CLOSE,11)*10+CLOSE,22),NODRAW;
B1:IF(CROSS(买线,卖线),L-0.05,DRAWNULL),CROSSDOT,LINETHICK3,COLORMAGENTA;
B2:IF(CROSS(卖线,买线),H+0.05,DRAWNULL),CROSSDOT,LINETHICK3,COLORGRAY;
S1:IF(CROSS(20,RSI)*10,H+0.05,DRAWNULL),CROSSDOT,LINETHICK3,COLORYELLOW;
VC:=((CLOSE-MA(CLOSE,5))/MA(CLOSE,5)*100+(CLOSE-MA(CLOSE,20))/MA(CLOSE,20)*100+(CLOSE-MA (CLOSE,32))/MA(CLOSE,32)*100)/3,NODRAW;
S2:=IF(VC>20 AND FILTER(VC< REF(VC,1),5),H+0.05,DRAWNULL),CIRCLEDOT,LINETHICK3,COLORGREEN;
A0:=(L+H+C*2)/4;
A1:EMA(A0,3)COLORBLUE,LINETHICK2;
A2:=EMA(A0,10)COLORLIBLUE,LINETHICK2;
A1X:=(A1-REF(A1,1))/REF(A1,1)*100,NODRAW;
A2X:=(A2-REF(A2,1))/REF(A2,1)*100,NODRAW;
看多:IF(A1X>=0 AND BARSLAST(CROSS(A1X,0))>0,REF((C+O)/2,BARSLAST(CROSS(A1X,0))),DRAWNULL),COLORMAGENTA{,LINETHICK2};
逃顶:IF(A1X<0 AND BARSLAST(CROSS(0,A1X))>0,REF((C+O)/2,BARSLAST(CROSS(0,A1X))),DRAWNULL),COLORCYAN,{LINETHICK2};
买入持股:IF(A1X>=0,A1,DRAWNULL)COLORRED,LINETHICK2;
卖出空仓:IF(A1X<0 AND A2X<0,A1,DRAWNULL)COLORGREEN,LINETHICK2;
VAR2:=LLV(LOW,10),NODRAW;
VAR3:=HHV(HIGH,21),NODRAW;
动力线:= EMA((CLOSE-VAR2)/(VAR3-VAR2)*4,4),NODRAW;
换手率:100*VOL/(FINANCE(7)/100),VOLSTICK,NODRAW,COLORGRAY;
DRAWICON( 动力线<0.23,LLV(L,10)-0.06,13);
DRAWICON(动力线>3.23 AND 换手率>10,HHV(H,10)+0.1,14),NODRAW;
换手:VOL/CAPITAL*100,VOLSTICK,NODRAW;
百日低换手:LLV(换手,100)=换手,NODRAW,COLORGREEN;
DRAWICON(百日低换手,L*0.991,23);
DRAWICON(换手>3,H*1.12,19),NODRAW;
DRAWICON(换手>10,H*1.06,21),NODRAW;
STICKLINE(换手>=5,O,C,0.08,0),COLORGREEN,NODRAW;
最低:=TROUGHBARS(L,5,1);{调整之字幅度找到低位起点}
低价:=REF(L,BARSLAST(最低=0));
低价_:DRAWLINE(最低=0,L,ISLASTBAR,低价,0),COLORBROWN;
{通达信文字指标}
所属板块:=STRCAT('所属板块: ',STRCAT(STRCAT(STRCAT('[行业]-',HYBLOCK),STRCAT(' [地域]-',DYBLOCK)),STRCAT(' [概念]-',GNBLOCK)));
总股本:=STRCAT(STRCAT('总股本: ',CON2STR(TOTALCAPITAL/1000000,2)),'亿');
流通盘:=STRCAT(STRCAT(' 流通盘: ',CON2STR(CAPITAL/1000000,2)),'亿');
全流通:=STRCAT(' 全流通: ',CON2STR((CAPITAL/1000000)/(TOTALCAPITAL/1000000),2));
市值:=STRCAT(STRCAT(' 流通市值: ',CON2STR((CAPITAL/1000000)*C,2)),'亿');
上市天数:=STRCAT(' 上市天数: ',CON2STR(FINANCE(42),0));
{上市日期:=STRCAT(' 上市日期: ',CON2STR(HHV((BARSCOUNT(C)=0)*(DATE+19000000),0),0));}
股本市值:=STRCAT('股本市值: ',STRCAT(STRCAT(STRCAT(STRCAT(总股本,流通盘),全流通),市值),
上市天数));
DRAWTEXT_FIX(ISLASTBAR,0.005,0,0,所属板块),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR,0.005,0.06,0,股本市值),COLORGRAY;

通达信量悟金BOLL主图指标公式

 

相关文章