在线检测未来函数

通达信金牛选股指标公式

来源:Internet,编辑:股旁网,2014-06-17

{放量突破上轨}
中:=(MA(C,3)+MA(C,6)+MA(C,12)+MA(C,24))/4;
上:=BBI+3*STD(BBI,10);
下:=BBI-3*STD(BBI,10);
安全:=MA(C,30);
TJ1:=下*1.05>中 AND 中*1.05>上 AND 中>=REF(中,1) AND REF(中,1)>=REF(中,2);
TJ2:=LLV(REF(VOL,1),60);
VAR91:=REF(V,1)+REF(V,2)+REF(V,3)+REF(V,4)+REF(V,5);
VAR92:=VAR91/5;
LB:=V/VAR92;
TJ3:=LB>2 OR VOL/REF(VOL,1)>2;
TJ4:=C<LLV(LOW,250)*2;
XG1:=TJ1 AND TJ3 AND TJ4;
{超跌}
黄底:=(SMA(HIGH,19,3) * 1);
XG2:=CLOSE/OPEN>1.04 AND CLOSE<黄底 AND CLOSE-REF(CLOSE,1)>0;
{布林收口}
M1:=3;M2:=5;M3:=8;M4:=13;M5:=15;M6:=20;
MA1:=MA(C,M1);MA2:=MA(C,M2);MA3:=MA(C,M3);MA4:=MA(C,M4);
MA5:=MA(C,M5);MA6:=MA(C,M6);
PBX1:=(EXPMA(CLOSE,M1)+MA(CLOSE,M1*2)+MA(CLOSE,M1*4))/3;
PBX2:=(EXPMA(CLOSE,M2)+MA(CLOSE,M2*2)+MA(CLOSE,M2*4))/3;
PBX3:=(EXPMA(CLOSE,M3)+MA(CLOSE,M3*2)+MA(CLOSE,M3*4))/3;
PBX4:=(EXPMA(CLOSE,M4)+MA(CLOSE,M4*2)+MA(CLOSE,M4*4))/3;
PBX5:=(EXPMA(CLOSE,M5)+MA(CLOSE,M5*2)+MA(CLOSE,M5*4))/3;
PBX6:=(EXPMA(CLOSE,M6)+MA(CLOSE,M6*2)+MA(CLOSE,M6*4))/3;
AAA:=MIN(MIN(MIN(MIN(MIN(PBX1,PBX2),PBX3),PBX4),PBX5),PBX6);
BBB:=MAX(MAX(MAX(MAX(MAX(PBX1,PBX2),PBX3),PBX4),PBX5),PBX6);
XG3:=O<AAA AND C>BBB;
XG:XG1 OR XG2 OR XG3;

通达信金牛选股指标公式

 

相关文章