在线检测未来函数

通达信瀚海主图指标公式

来源:Internet,编辑:股旁网,2014-06-17

P1:=5;
P2:=13;
P3:=34;
JJJ:=IF(DYNAINFO(8)>0.01,0.01*DYNAINFO(10)/DYNAINFO(8),DYNAINFO(3));
DDD:=(DYNAINFO(5)<0.01 || DYNAINFO(6)<0.01);
JJJT:=IF(DDD,1,(JJJ<(DYNAINFO(5)+0.01) && JJJ>(DYNAINFO(6)-0.01)));
CYC1:IF(JJJT,0.01*EMA(AMOUNT,P1)/EMA(VOL,P1),EMA((HIGH+LOW+CLOSE)/3,P1));
CYC2:IF(JJJT,0.01*EMA(AMOUNT,P2)/EMA(VOL,P2),EMA((HIGH+LOW+CLOSE)/3,P2));
CYC3:IF(JJJT,0.01*EMA(AMOUNT,P3)/EMA(VOL,P3),EMA((HIGH+LOW+CLOSE)/3,P3));
CYC∞:IF(JJJT,DMA(AMOUNT/(100*VOL),100*VOL/FINANCE(7)),EMA((HIGH+LOW+CLOSE)/3,120));
CC:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
DD:=DMA(CLOSE,CC);
上:(1+7/100)*DD,POINTDOT,COLORGRAY,LINETHICK4;
下:(1-7/100)*DD,POINTDOT,COLORGRAY,LINETHICK4;
中:(上+下)/2,POINTDOT,COLORF0F000,LINETHICK4;
T1:=MA(C,21)>REF(MA(C,21),1);
T2:=EXIST(C>REF(C,1)*1.093,21);
T3:=C<O AND C<REF(C,1) AND EVERY(MA(C,5)<REF(MA(C,5),1),3);
T5:=EVERY(V<REF(V,1),2) AND EVERY(V<MA(V,5),2);
T6:=MA(C,5)>MA(C,21);
XG:=T1 AND T2 AND T3 AND T5 AND T6;
DRAWTEXT(XG,L*0.99,'伏击'),COLOR00FF00;
DRAWICON(XG,L*0.9995,1);
A1:=ABS(((3.48*CLOSE+HIGH+LOW)/4-EMA(CLOSE,20))/EMA(CLOSE,20));
A2:=DMA(((2.15*CLOSE+LOW+HIGH)/4),A1);
金线:EMA(A2,200)*1.118,LINETHICK2,COLORYELLOW;
DF2:=(C-REF(C,1))/REF(C,1)*100>9;
金K线:=CROSS(C,金线) AND DF2;
DRAWTEXT(金K线,L*0.98,'↖金K线'),COLOR00FFFF;
STICKLINE(金K线,CLOSE,OPEN,3.2,0),COLOR0077FF;
STICKLINE(金K线,CLOSE,OPEN,2.5,0),COLOR0099FF;
STICKLINE(金K线,CLOSE,OPEN,1.9,0),COLOR00BBFF;
STICKLINE(金K线,CLOSE,OPEN,1.2,0),COLOR00DDFF;
STICKLINE(金K线,CLOSE,OPEN,0.3,0),COLOR00FFFF;
昨收:IF(CURRBARSCOUNT<20,CONST(REF(C,1)),DRAWNULL);
前3天收:IF(CURRBARSCOUNT<20,CONST(REF(C,3)),DRAWNULL);
前6天收:IF(CURRBARSCOUNT<20 AND CURRBARSCOUNT>3,CONST(REF(C,6)),DRAWNULL);
AA1:=MA((REF(H,1)+REF(H,3)+REF(H,6)+REF(H,9)+REF(H,12))/5,3);
AA2:IF(CURRBARSCOUNT<20,AA1,DRAWNULL),COLORRED;
STICKLINE(CURRBARSCOUNT<=19,昨收,AA2,0,-1),COLORRED;
DRAWKLINE(H,O,L,C);
均价线:=AMOUNT/V/100;
C2:=REF(C,1);
涨停:=IF(REF(C,1)*1.1-C<0.01 ,1,0);
STICKLINE(涨停,OPEN,CLOSE,4,0),COLORRED;
STICKLINE(涨停,OPEN,CLOSE,3,0),COLORRED;
STICKLINE(涨停,H,L,0,0),COLORRED;
B1:='';
DRAWTEXT(均价线 AND 涨停,均价线,B1),COLORGREEN;
B3:='';
DRAWTEXT((O+C)/2 AND 涨停,(O+C)/2,B3),COLORMAGENTA;
B2:='';
DRAWTEXT(涨停,L,B2),COLORGRAY;
MA13:=MA(C,13),COLORGRAY;
MA21:=MA(C,21),COLORWHITE;
支撑线:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4,LINETHICK2,COLORBLUE;
LC:=REF(CLOSE,1);
操作线:=SMA(MAX(CLOSE-LC,0),2,1)/SMA(ABS(CLOSE-LC),2,1)*100;
趋势线:=SMA(MAX(CLOSE-LC,0),14,1)/SMA(ABS(CLOSE-LC),14,1)*100;
震仓线:=45;
震仓线2:=50;
逃命线:=80;
抄底线:=20;
绝底线:=5;
PP2:=操作线<震仓线2 AND REF(操作线,1)>震仓线2 ;
PP:=操作线<震仓线 AND REF(操作线,1)>震仓线 ;
PP3:=操作线<抄底线 AND REF(操作线,1)>抄底线;
HH:=COUNT(涨停,13)>=1;
STICKLINE(PP2 AND HH,OPEN,CLOSE,0.8,0),COLORBLUE;
STICKLINE(PP AND HH,OPEN,CLOSE,0.8,0),COLORBLUE;
STICKLINE(PP3 AND HH,OPEN,CLOSE,0.8,0),COLORBLUE;
A:=SMA(L,4,3) ;
STICKLINE(A AND REF(PP,1) AND HH ,A*0.9999,A*0.9949,3,0),COLORGREEN;
DRAWICON(A AND REF(PP,1) AND HH,L*0.98,1);
STICKLINE(A AND REF(PP3,1) AND HH ,A*0.9999,A*0.9949,3,0);
DRAWICON(A AND REF(PP3,1) AND HH,L*0.98,1);
STICKLINE(涨停,OPEN,CLOSE,2,0),COLORRED;
STICKLINE(涨停,OPEN,CLOSE,1,0),COLORRED;
DRAWTEXT(涨停,L-0.1,'涨停'),COLORRED;
C3:=REF(C,1);
跌停:=IF((C3-C)*100/C3>=(10-0.01*100/C3),1,0);
STICKLINE(跌停,OPEN,CLOSE,2,0),COLORBLUE;
STICKLINE(跌停,OPEN,CLOSE,1,0),COLORBLUE;
DRAWTEXT(跌停,H+0.3,'跌停'),COLORBLUE;

通达信瀚海主图指标公式

 

相关文章