在线检测未来函数

通达信个股监控指标公式

来源:Internet,编辑:股旁网,2014-06-17

N:=13;
M:=9;
M1:=3;
STICKLINE(C>0,90,95,10,0),COLOR408000;
STICKLINE(C>0,10,5,10,0),COLOR408000;
HDY:=EMA(100*(C-LLV(LOW,34))/(HHV(H,34)-LLV(LOW,34)),3);
DRAWBAND(HDY,RGB(255,000,139),10,RGB(255,255,71));
STICKLINE(C>0,90,10,10,0),COLOR000000;
风险:HDY,COLORRED,LINETHICK1,DOTLINE;
警示:45,COLORLIMAGENTA,LINETHICK1,POINTDOT;
MVAR1:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
MVAR2:=SMA(MVAR1,M1,1);
卖线:SMA(MVAR2,M1,1),COLORBLUE;
MVAR3:=(HHV(HIGH,M)-CLOSE)/(HHV(HIGH,M)-LLV(LOW,M))*100;
MVAR4:=SMA(MVAR3,M1,1);
MVAR5:=SMA(MVAR4,M1,1);
高:=85;
低:=9;
买入:SMA(MVAR5,M1,1),COLORYELLOW;
必卖:SMA(卖线,M1,1),COLORGREEN;
DRAWTEXT(买入>76.5 AND CROSS(卖线,必卖),必卖*1.15,'进');
DRAWTEXT(买入>56 AND 买入<=76 AND CROSS(卖线,必卖),卖线,'留意');
DRAWTEXT(买入<45 AND 卖线>78 AND 必卖>78 AND CROSS(必卖,卖线),必卖,'跑'),COLORGREEN ;
DRAWTEXT(CROSS(买入,78.5),买入,'关注'),COLORRED;
DRAWTEXT(CROSS(买入,85),买入,'重点关注'),COLORWHITE;
VAR1111:=EMA(EMA(CLOSE,13),13);
VAR2222:=(VAR1111-REF(VAR1111,1))/REF(VAR1111,1)*1000;
VAR3333:=DYNAINFO(11);
VAR4444:=(EMA(CLOSE,8)-EMA(CLOSE,55))*10;
VAR5555:=EMA(VAR4444,3);
VAR6666:=(C-VAR3333)/VAR3333<-0.03;
VAR7777:=VAR2222>REF(VAR2222,1) AND VAR2222<-0.2;
VAR8888:=CROSS(VAR4444,VAR5555) AND VAR4444<-0.3;
主升:FILTER(VAR6666 AND VAR7777 AND VAR8888,13),COLORRED,LINETHICK1;
STICKLINE(主升,1.5,90,0.5,0),COLORRED;
DRAWTEXT(主升,85,'主升'),COLORRED;
AAX:=MA((2*CLOSE+HIGH+LOW)/4,5);
BB:=AAX*(200-102)/100;
XGG:=CROSS(C,BB);
RSV:=(C-LLV(L,60))/(HHV(H,9)-LLV(L,60))*100;
K:=SMA(RSV,9,1);
D:=SMA(K,9,1);
J:=3*K-2*D;
X:=LLV(J,2)=LLV(J,8);
抄底:(CROSS(J,REF(J+0.01,1)) AND X AND (J<12)) AND ((CROSS(C,MA(C,3))) AND (CROSS(J,REF(J+0.01,1)) AND X AND (J<12)) AND ((CROSS(J,REF(J+0.01,1))) AND X) AND XGG),COLOR00FFBB,STICK;
STICKLINE(抄底,0,85,0.5,0),COLORYELLOW;
DRAWTEXT(抄底,80,'抄底'),COLORYELLOW;
LVAR1:=(HIGH+LOW+CLOSE)/3;
LVAR2:=(LVAR1-MA(LVAR1,14))/(0.015*AVEDEV(LVAR1,14));
LVAR3:=(LVAR1-MA(LVAR1,70))/(0.015*AVEDEV(LVAR1,70));
LVAR5:=IF(LVAR2<=-150 AND LVAR2>-200 AND LVAR3<=-150 AND LVAR3>-200,10,0);
LVAR10:=SMA((CLOSE-LLV(LOW,14))/(HHV(HIGH,14)-LLV(LOW,14))*100,4,1);
LVAR11:=SMA((CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100,4,1);
LVAR12:=IF(BARSCOUNT(CLOSE)<70,-120,IF(LVAR3<=-200 AND LVAR2<=-150,15,LVAR5)-120);
LVAR13:=SMA((LVAR11-50)*2,3,1)+SMA((LVAR10-50)*2,3,1)/2;
黑马:CROSS(LVAR13,LVAR12),COLORMAGENTA;
STICKLINE(黑马,0,80,0.5,0),COLORMAGENTA;
DRAWTEXT(黑马,75,'黑马'),COLORMAGENTA;
WVAR1:=SUM(IF((C>REF(C,1)),V,IF((C<REF(C,1)),0-V,0)),0);
VAR2:=SUMBARS(V,CAPITAL);
VAR3:=(IF((C>LLV(C,VAR2)),1,0-1))*(IF((VAR2),1,0-1));
VAR4:=IF((VAR3=0-1),1,0);
VAR5:=(COUNT((VAR4=1),8)>3);
VAR6:=((SUM(AMOUNT,13))/(((AMOUNT)/(V))/(100)))/(100);
VAR7:=DMA((O+H+L+C)/(4),(V)/(VAR6));
VAR8:=(((C-VAR7)/(VAR7))*(100)<0-17);
VAR9:=((C-MIN((REF(C,5))*(0.83),(REF(C,21))*(0.72)))/(C)<0.05);
锁定:=VAR8 AND VAR9 AND VAR5;
上士精确:=(锁定>0) AND (REF(锁定,1)=0 );
上士抄底:=COUNT(上士精确,5) AND C>O;
打击:COUNT(上士抄底,5)=1 AND 上士抄底,COLORGREEN;
STICKLINE(上士抄底,0,75,0.5,0),COLORGREEN;
DRAWTEXT(上士抄底,70,'打击'),COLORGREEN;
PARA1:=(EMA(CLOSE,17)-EMA(CLOSE,26))*100;
PARA2:=EMA(PARA1,5);
MACDD:=2*(PARA1-PARA2);
拐点:CROSS(PARA1,PARA2) AND PARA2<=-6,COLORBLUE;
STICKLINE(拐点,0,70,0.5,0),COLORBLUE;
DRAWTEXT(拐点,65,'拐点'),COLORBLUE;
VAR1B:=EMA(CLOSE,3)-EMA(CLOSE,89);
VAR1C:=EMA(VAR1B,21);
VAR1D:=(VAR1B-VAR1C)*10;
VAR1F:=POW(VAR1D,3)*0.1+POW(VAR1D,2);
WG:=IF(VAR1D>0.015,VAR1F,0)/45;
短线:WG/REF(WG,1)>5 AND REF(WG,1)/REF(WG,2)>5,COLORLICYAN;
WGH:=WG/REF(WG,1)>5 AND REF(WG,1)/REF(WG,2)>5;
STICKLINE(WGH,1.5,65,0.5,0),COLORLICYAN;
DRAWTEXT(WGH,60,'短线'),COLORLICYAN;
VAR1:=HHV(HIGH,70);
DD:=VAR1*0.83;
DDC:=EXIST(DD/L>1.08,10);
A1:=COST(85);
A2:=COST(15);
A3:=A1-A2;
A4:=(A1+A2)/2;
DM:=A3/A4*100<15;
DMCX:=LAST(DM,15,1);
B1:=MA(C,13)<REF(MA(C,13),1);
SSRP:=MA(SSRP,1);
ZLBT:=DMCX AND SSRP/L>1.18 ;
TJ:=EXIST(ZLBT,2);
SJT:=C/REF(C,10);
DS:=SJT<=0.85;
深套:TJ AND DDC AND B1 AND DS,COLORWHITE;
STICKLINE(深套,1.5,60,0.5,0),COLORWHITE;
DRAWTEXT(深套,55,'深套'),COLORWHITE;
DMH:=SUM(IF(H>REF(H,1),H-REF(H,1),0),N);
DML:=SUM(IF(L>REF(L,1),0,REF(L,1)-L),N);
量:=DMH/(DMH+DML),COLORRED;
探底:量<0.08,COLORBROWN,LINETHICK2;
STICKLINE(探底,1.5,55,0.5,0),COLORBROWN;
DRAWTEXT(探底,50,'探底'),COLORBROWN;
TJA:=(CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*100;
九稳:CROSS(-27,TJA) AND COUNT(H=L,5)<1,COLORLIMAGENTA;
STICKLINE(九稳,1.5,50,0.5,0),COLORLIMAGENTA;
DRAWTEXT(九稳,45,'九稳'),COLORLIMAGENTA;
G1:=ABS(((3.48*CLOSE+HIGH+LOW)/4-EMA(CLOSE,20))/EMA(CLOSE,20));
G2:=DMA(((2.15*CLOSE+LOW+HIGH)/4),G1);
金线王:=EMA(G2,200)*1.118 ,LINETHICK2,COLORYELLOW;
DF2:=(C-REF(C,1))/REF(C,1)*100>9;
金K:CROSS(C,金线王) AND DF2,COLOR0479FB;
STICKLINE(金K,1.5,45,0.5,0),COLOR0479FB;
DRAWTEXT(金K,40,'金K'),COLOR0479FB;
FQ:=(3*CLOSE+LOW+OPEN+HIGH)/6;
QQ:=(20*FQ+19*REF(FQ,1)+18*REF(FQ,2)+17*REF(FQ,3)+16*REF(FQ,4)+15*REF(FQ,5)+14*REF(FQ,6) +13*REF(FQ,7)+12*REF(FQ,8)+11*REF(FQ,9)+10*REF(FQ,10)+9*REF(FQ,11)+8*REF(FQ,12) +7*REF(FQ,13)+6*REF(FQ,14)+5*REF(FQ,15)+4*REF(FQ,16)+3*REF(FQ,17)+2*REF(FQ,18)+ REF(FQ,20))/211;
DD0:=CROSS(QQ,EMA(EMA(EMA(QQ,2),2),2));
CC:=EMA(EMA(CLOSE,12)-EMA(CLOSE,26),9);
QQ1:=HHV(2*(EMA(CLOSE,12)-EMA(CLOSE,26)-CC),4)<0
AND 2*(EMA(CLOSE,12)-EMA(CLOSE,26)-CC)>REF(2*(EMA(CLOSE,12)-EMA(CLOSE,26)-CC),1)
AND REF(2*(EMA(CLOSE,12)-EMA(CLOSE,26)-CC),1)<REF(2*(EMA(CLOSE,12)-EMA(CLOSE,26)-CC),2)
AND REF(2*(EMA(CLOSE,12)-EMA(CLOSE,26)-CC),2) <REF(2*(EMA(CLOSE,12)-EMA(CLOSE,26)-CC),3);
QQ2:=EMA(EMA(EMA(EMA(CLOSE,2),2),2),2);
DD1:=CROSS(QQ2,EMA(REF(QQ2,1),2)) AND C>O AND V>=MA(V,21) AND V> REF(V,1);
DD2:=DD1+QQ1+DD>=2 AND EMA(CLOSE,12)-EMA(CLOSE,26)>CC AND H/C<1.01 AND REF(MA(C,5),1)<MA(C,5) AND REF(MA(C,5),2)>REF(MA(C,5),1);
MACD:=(EMA(CLOSE,12)-EMA(CLOSE,26)-EMA(EMA(CLOSE,12)-EMA(CLOSE,26),9))*2;
RSV1:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K1:=SMA(RSV1,3,1);
D1:=SMA(K1,3,1);
CC1:=CROSS(K1,D1) AND MACD>0;
赚钱:DD2 AND REF(H/C<1.02,1) AND CC1,COLORFFFF00;
STICKLINE(赚钱,1.5,40,0.5,0),COLORFFFF00;
DRAWTEXT(赚钱,35,'赚钱'),COLORFFFF00;
换:=100*VOL/(FINANCE(7)/100);
EE2:=(REF(换,1)/240)*FROMOPEN;
EE3:=(3/240)*FROMOPEN;
ER5:=NOT(NAMELIKE('S') OR NAMELIKE('*S'))&&VOL>1&&DYNAINFO(39)>1;{去除ST和停牌股}
ER6:=BARSLASTCOUNT(FINANCE(7)=REF(FINANCE(7),1))>=60&&ER5; {去除除权股};
均:=0.01*AMOUNT/VOL;
W2:=BARSLAST(UPNDAY(EMA(C,360),5));
W5:=IF(均=LLV(均,W2)&&EMA(C,360)>EMA(C,180),L,DRAWNULL);
W6:=FILTERX(W5,W2);
周:=BARSLAST(W6);
KA:=周-9;
SD1:=周>=1&&周<=2&&CURRBARSCOUNT<=CONST(周+1)&&CURRBARSCOUNT>=CONST(KA+1)&&O<=C&&均>=REF(均,1)&&REF(均,1)<REF(均,2)&&换>EE2&&ER6;
SD2:=周>=1&&周<=2&&CURRBARSCOUNT<=CONST(周+1)&&CURRBARSCOUNT>=CONST(KA+1)&&O<=C&&均>=REF(均,1)&&REF(C,1)<REF(C,2)&&换>EE2&&ER6;
B:SD1 OR SD2,COLORC080FF;
STICKLINE(B,1.5,35,0.5,0),COLORC080FF;
DRAWTEXT(B,30,'B'),COLORC080FF;
均价线:=AMOUNT/V/100;
C2:=REF(C,1);
涨停:=IF(REF(C,1)*1.1-C<0.01 ,1,0);
MA13:=MA(C,13),COLORGRAY;
MA21:=MA(C,21),COLORWHITE;
支撑线:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
LC:=REF(CLOSE,1);
操作线:=SMA(MAX(CLOSE-LC,0),2,1)/SMA(ABS(CLOSE-LC),2,1)*100;
趋势线:=SMA(MAX(CLOSE-LC,0),14,1)/SMA(ABS(CLOSE-LC),14,1)*100;
震仓线:=45;
震仓线2:=50;
逃命线:=80;
抄底线:=20;
绝底线:=5;
PP2:=操作线<震仓线2 AND REF(操作线,1)>震仓线2 ;
PP:=操作线<震仓线 AND REF(操作线,1)>震仓线 ;
PP3:=操作线<抄底线 AND REF(操作线,1)>抄底线;
HH:=COUNT(涨停,13)>=1;
STICKLINE(PP2 AND HH,0,30,1,0),COLORRED;
STICKLINE(PP AND HH,0,30,1,0),COLORRED;
STICKLINE(PP3 AND HH,0,30,1,0),COLORRED;
DRAWTEXT(PP2 AND HH,8,'预警'),COLORRED;
DRAWTEXT(PP AND HH,8,'预警'),COLORRED;
DRAWTEXT(PP3 AND HH,8,'预警'),COLORRED;
A:=SMA(L,4,3);
绿买:=IF (((A AND REF(PP,1) AND HH) OR (A AND REF(PP3,1) AND HH)),1,0);
STICKLINE(A AND REF(PP,1) AND HH ,0,30,1,0),COLORGREEN;
DRAWICON(A AND REF(PP,1) AND HH,28,1);
STICKLINE(A AND REF(PP3,1) AND HH ,0,30,1,0)COLORGREEN;
DRAWICON(A AND REF(PP3,1) AND HH,28,1);

通达信个股监控指标公式

 

相关文章