在线检测未来函数

飞狐顶级顾王指标公式

来源:Internet,编辑:股旁网,2014-06-20

BN:=3;
牛:=3;
短线:=9;
中线:=9;
maxcyc:dma((c+o)/2,v/capital);
MAV:=(((CLOSE)*(2)+HIGH+LOW)/(4))*(10);
SK:=EMA(MAV,13)-EMA(MAV,34);
SD:=EMA(SK,5);
B:=((2)*(SK-SD))*(5.5);
拉升资金:IF((IF((B>=0),B,(-18))>120),120,IF((B>=0) AND (DATE<=1080531),B,(-18))),Linethick2,CoLorFF00FF;
VAR96:=((CLOSE-LLV(LOW,28))/(HHV(HIGH,28)-LLV(LOW,28)))*(100);
VAR97:=SMA(VAR96,4,1);
VAR98:=SMA(VAR97,2,1);
VAR99:=DMA(((AMOUNT)/(VOL))/(100),(VOL)/(CAPITAL));
VAR100:=LOW;
VAR101:=REF(LOW,1);
VAR102:=((SMA(ABS(VAR100-VAR101),3,1))/(SMA(MAX(VAR100-VAR101,0),牛,1)))*(100);
VAR103:=MA(IF(((CLOSE)*(1.68)<=MAXCYC),(VAR102)*(10),(VAR102)/(10)),牛);
VAR104:=LLV(LOW,30);
VAR105:=HHV(VAR103,30);
魔王:=MA(IF((LOW<=VAR104),(VAR103+(VAR105)*(2))/(2),0),牛);
牛魔王:IF(魔王>10000,100,0),Linethick2,CoLor00FFFF;
VAR106:=MA(CLOSE,5);
VAR107:=MA(CLOSE,10);
VAR108:=MA(CLOSE,30);
VAR109:=(SUM(((CLOSE)*(VOL))*(100),4))/(SUM((VOL)*(100),4));
VAR110:=(SUM(((CLOSE)*(VOL))*(100),7))/(SUM((VOL)*(100),7));
VAR111:=(SUM(((CLOSE)*(VOL))*(100),28))/(SUM((VOL)*(100),28));
VAR112:=(INTPART((VAR111)*(100)))/(100);
短线趋势:=EMA(CLOSE,5)-EMA(CLOSE,10);
中线趋势:=EMA(短线趋势,中线);
VAR113:=REF(中线趋势,1);
VAR114:=中线趋势;
VAR115:=VAR114-VAR113;
VAR116:=REF(短线趋势,1);
VAR119:=短线趋势;
VAR120:=VAR119-VAR116;
VAR117:=OPEN;
VAR118:=CLOSE;
小牛魔王:IF((VAR117<=VAR106) AND (VAR117<=VAR107) AND (VAR117<=VAR108) AND (VAR118>=VAR106) AND (VAR118>=VAR112) AND (VAR115>0) AND (VAR120>0) ,80,0),Linethick2,CoLorFFFFFF;
主力建仓:IF((VAR98<8.5) AND (VAR97<11),120,(-18)),Linethick2,CoLor0000FF;
VAR84:=((CLOSE-MA(CLOSE,13))/(MA(CLOSE,13)))*(100);
VAR85:=100-ABS(VAR84);
VAR86:=(3)*(SMA(((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75)))*(100),20,1))-(2)*(SMA(SMA(((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75)))*(100),20,1),15,1));
VAR87:=(3)*(SMA(((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75)))*(100),20,1))-(2)*(SMA(SMA(((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75)))*(100),20,1),15,1));
VAR88:=100-VAR87;
VAR89:=100-VAR86;
VAR92:=MA(((100)*(CLOSE-LLV(CLOSE,34)))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
VAR93:=100-(3)*(SMA(((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75)))*(100),20,1))+(2)*(SMA(SMA(((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75)))*(100),20,1),15,1));
VAR94:=100-(3)*(SMA(((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75)))*(100),20,1))+(2)*(SMA(SMA(((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75)))*(100),20,1),15,1));
VAR95:=(VAR93<REF(VAR94,1)) AND (VOL>REF(VOL,1)) AND (CLOSE>REF(CLOSE,1));
A11:=(3)*(SMA(((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55)))*(100),5,1))-(2)*(SMA(((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55)))*(100),5,1));
黑马线:=EMA(A11,5);
A12:=((黑马线-REF(黑马线,1))/(REF(黑马线,1)))*(100);
A4:=((CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21)))*(100);
趋势线3:=MA((3)*(SMA(A4,6,1))-(2)*(SMA(SMA(A4,5,1),5,1)),2);
N:=3;
VAR1:=REF((LOW+OPEN+CLOSE+HIGH)/(4),1);
VAR2:=(SMA(ABS(LOW-VAR1),13,1))/(SMA(MAX(LOW-VAR1,0),10,1));
VAR3:=EMA(VAR2,10);
VAR4:=LLV(LOW,33);
VAR5:=EMA(IF((LOW<=VAR4),VAR3,0),5);
VAR6:=REF(CLOSE,1);
VAR7:=((SMA(MAX(CLOSE-VAR6,0),6,1))/(SMA(ABS(CLOSE-VAR6),6,1)))*(100);
VAR8:=(LLV(LOW,5)=LLV(LOW,45)) AND (CLOSE>=(OPEN)*(1.04));
VAR9:=(CLOSE>(REF(HIGH,1)+REF(LOW,1))/(2));
VAR10:=VAR8 AND VAR9;
VAR11:=((2)*(CLOSE)+HIGH+LOW)/(4);
VAR12:=LLV(LOW,13);
VAR13:=HHV(HIGH,13);
VAR14:=(LLV(LOW,1)=LLV(LOW,35)) AND (CLOSE>=(OPEN)*(1.04));
VAR15:=(CLOSE>(REF(HIGH,1)+REF(LOW,1))/(2));
VAR16:=EMA(((VAR11-VAR12)/(VAR13-VAR12))*(100),13);
VAR17:=(((CLOSE-MA(CLOSE,6))/(MA(CLOSE,6)))*(100)+((CLOSE-MA(CLOSE,24))/(MA(CLOSE,24)))*(100)+((CLOSE-MA(CLOSE,32))/(MA(CLOSE,32)))*(100))/(3);
VAR19:=MA(CLOSE,13);
VAR20:=100-ABS(((CLOSE-VAR19)/(VAR19))*(100));
VAR21:=LLV(LOW,75);
VAR22:=HHV(HIGH,75);
VAR23:=(VAR22-VAR21)/(100);
VAR24:=SMA((CLOSE-VAR21)/(VAR23),20,1);
VAR25:=SMA((OPEN-VAR21)/(VAR23),20,1);
VAR26:=(3)*(VAR24)-(2)*(SMA(VAR24,15,1));
VAR27:=MA(HHV(HIGH,485),17);
VAR28:=MA(HHV(HIGH,222),17);
VAR29:=MA(HHV(HIGH,96),17);
VAR30:=MA(LLV(LOW,485),17);
VAR31:=MA(LLV(LOW,222),17);
VAR32:=MA(LLV(LOW,96),17);
VAR33:=MA(((VAR30)*(0.96)+(VAR31)*(0.96)+(VAR32)*(0.96)+(VAR27)*(0.558)+(VAR28)*(0.558)+(VAR29)*(0.558))/(6),17);
VAR34:=MA(((VAR30)*(1.25)+(VAR31)*(1.23)+(VAR32)*(1.2)+(VAR27)*(0.55)+(VAR28)*(0.55)+(VAR29)*(0.65))/(6),17);
VAR35:=MA(((VAR30)*(1.3)+(VAR31)*(1.3)+(VAR32)*(1.3)+(VAR27)*(0.68)+(VAR28)*(0.68)+(VAR29)*(0.68))/(6),17);
VAR36:=LLV(LOW,30);
VAR37:=MA((((VAR33)*(3)+(VAR34)*(2)+VAR35)/(6))*(1.738),17);
VAR38:=VAR37;
VAR39:=LOW;
VAR40:=REF(LOW,1);
VAR41:=((SMA(ABS(VAR39-VAR40),3,1))/(SMA(MAX(VAR39-VAR40,0),N,1)))*(100);
VAR42:=MA(IF(((CLOSE)*(1.35)<=VAR38),(VAR41)*(10),(VAR41)/(10)),N);
VAR43:=HHV(VAR42,30);
VAR44:=1080531;
VAR45:=(3)*(VAR25)-(2)*(SMA(VAR25,15,1));
VAR46:=100-VAR45;
VAR47:=1;
VAR49:=(REF(LOW,1))*(0.9);
VAR50:=(LOW)*(0.9);
VAR51:=((VAR50)*(VOL)+(VAR49)*(CAPITAL-VOL))/(CAPITAL);
VAR52:=EMA(VAR51,30);
VAR53:=CLOSE-REF(CLOSE,1);
VAR54:=MAX(VAR53,0);
VAR55:=ABS(VAR53);
VAR56:=((SMA(VAR54,7,1))/(SMA(VAR55,7,1)))*(100);
VAR57:=((SMA(VAR54,13,1))/(SMA(VAR55,13,1)))*(100);
VAR58:=BARSCOUNT(CLOSE);
VAR59:=((SMA(MAX(VAR53,0),6,1))/(SMA(ABS(VAR53),6,1)))*(100);
VAR60:=(((-200))*(HHV(HIGH,60)-CLOSE))/(HHV(HIGH,60)-LLV(LOW,60))+100;
VAR61:=((CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15)))*(100);
VAR62:=SMA((SMA(VAR61,4,1)-50)*(2),3,1);
VAR63:=((INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14)))*(100);
VAR64:=SMA(VAR63,4,1);
VAR65:=SMA(VAR64,3,1);
VAR66:=((HHV(HIGH,30)-CLOSE)/(CLOSE))*(100);
VAR67:=(VAR59<=25) AND (VAR60<(-95)) AND (VAR66>20) AND (VAR62<(-30)) AND (VAR65<30) AND (VAR52-CLOSE>=(-0.25)) AND (VAR56<22) AND (VAR57<28) AND (VAR58>50);
VAR68:=(HIGH+LOW+CLOSE)/(3);
VAR69:=(VAR68-MA(VAR68,14))/((0.015)*(AVEDEV(VAR68,14)));
VAR70:=(VAR68-MA(VAR68,70))/((0.015)*(AVEDEV(VAR68,70)));
VAR71:=IF((VAR69>=150) AND (VAR69<200) AND (VAR70>=150) AND (VAR70<200),10,0);
VAR72:=IF((VAR69<=(-150)) AND (VAR69>(-200)) AND (VAR70<=(-150)) AND (VAR70>(-200)),(-10),VAR71);
VAR73:=((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100);
VAR74:=REVERSE(VAR73);
VAR75:=SMA(VAR73,3,1);
绝佳买点:=MA(IF((LOW<=VAR36),(VAR42+(VAR43)*(2))/(2),0),N);
跑:=FILTER((REF(黑马线,1)>90) AND (A12<0) ,7);
买线:=EMA(CLOSE,2);
卖线:=EMA((SLOPE(CLOSE,21))*(20)+CLOSE,42);
指數位置:=(3)*(SMA(((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100),5,1))-(2)*(SMA(SMA(((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100),5,1),3,1));
抄底:=CROSS(指數位置,10);
A1:=(VOL=HHV(VOL,120));
A2:=((CLOSE)/(OPEN)>1.05);
TJ:=A1 AND A2;
龙:=VAR10;
买4:=VAR14;
AA1:=(AMOUNT)/(VOL);
BB1:=(LOW<(AA1)*(0.9));
CC1:=(((CLOSE-REF(CLOSE,1))/(REF(CLOSE,1)))*(100)>1.2);
DD1:=(LOW<(MA(CLOSE,5))*(0.921));
EE1:=(VOL<(MA(VOL,5))*(1.5));
FF1:=BB1 AND CC1 AND DD1 AND EE1;
买3:=FILTER(FF1,3);
二十天最低跌幅:=(HHV(CLOSE,20))/(LLV(CLOSE,20));
RSV:=((CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9)))*(100);
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=(3)*(K)-(2)*(D);
X:=(LLV(J,2)=LLV(J,8));
买1:=CROSS(J,REF(J+0.01,1)) AND X AND (J<20) AND (二十天最低跌幅>=1.3);
长期底部:=LLV(HIGH,30);
上:=(SMA(LOW,5,2))*(0.96);
短期底部:=(LLV(HIGH,30))*(0.93);
LC:=REF(CLOSE,1);
RSI:=((SMA(MAX(CLOSE-LC,0),6,1))/(SMA(ABS(CLOSE-LC),6,1)))*(100);
大顶:=FILTER((VAR17>20) AND FILTER((VAR17<REF(VAR17,1)),5),5);
VAR76:=(OPEN+LOW+HIGH+CLOSE)/(4);
MAN:=(SMA(HIGH,21,2))*(1.05);
短底2:=EMA(VAR76,5);
支撑:=HHV(短底2,60);
VAR77:=((HHV(HIGH,36)-CLOSE)/(HHV(HIGH,36)-LLV(LOW,36)))*(100);
VAR78:=SMA(VAR77,5,1);
VAR79:=SMA(VAR78,8,1);
VAR80:=CROSS(VAR78,VAR79) AND (VAR79<5);
VAR81:=(CLOSE>LLV(CLOSE,60)+(0.3)*(LLV(CLOSE,60))) AND VAR80;
VAR82:=IF((CLOSE>1000),VAR80,VAR81);
黑马起步:=VAR82;
逃:=FILTER((HIGH>支撑) AND (CLOSE<支撑) AND ((CLOSE)/(OPEN)>0-1.06) AND (CLOSE<OPEN),5);
逃命:=(黑马起步>0);
选逃:=FILTER((((逃命 or 逃) or CROSS(84,RSI)) or 大顶),3) ;
WW:=1;
散户:=((SMA(VAR75,3,1))*(VAR47))*(WW);
新庄:=((SMA(散户,3,1))*(VAR47))*(WW);
高抛:=CROSS(新庄,散户) AND (新庄>75);
买:CROSS(买线,卖线) ,CoLor0000FF;
卖:CROSS(卖线,买线) ,CoLor008000;
大黑马:=CROSS(趋势线3,0) AND (黑马线<40);
大买:=FILTER((绝佳买点>30000),5);
大资金进场:=VAR95 AND (COUNT(VAR95,30)=1);
做空:=高抛+选逃+(卖=1)+跑;
选拉升股:=(买 AND (拉升资金>0) or (拉升资金>0) AND (COUNT(买,5)>=1) AND (COUNT(做空,BARSLAST(买))=0) AND (REF((拉升资金>0) AND (COUNT(买,5)>=1) AND (COUNT(做空,BARSLAST(买))=0),1)=0));
选潜力股:=(COUNT(做空,BARSLAST(买))=0) AND ((CLOSE)/(REF(CLOSE,BARSLAST(买)))<=1.08) AND ((主力建仓=120) or (拉升资金>0)) ;
选暴涨股:买 AND ((COUNT((主力建仓=120),BARSLAST(做空))>=3) or (COUNT(大黑马+大买+大资金进场,7)>=1)),CoLorFF0000;
选暴涨潜力:((CLOSE)/(REF(CLOSE,BARSLAST(选暴涨股)))<=1.1) AND (COUNT(做空,BARSLAST(选暴涨股))=0),CoLor000080;
选超级暴涨股:(选暴涨股 AND (COUNT((主力建仓=120),10)>=3) or 买 AND (COUNT(大黑马+大买+大资金进场,7)>=1) AND (COUNT(做空,BARSLAST(((大黑马 or 大买) or 大资金进场)))=0)),CoLor800080;
黄金暴涨股:买 AND (COUNT((主力建仓=120),BARSLAST(做空))>=3) AND (拉升资金>0) AND (COUNT(大黑马+大买+大资金进场,7)>=1) AND (COUNT(做空,BARSLAST(((大黑马 or 大买) or 大资金进场)))=0),CoLor00FFFF;
坚决买进:(((买 AND 选暴涨潜力 or 选暴涨股) or 选超级暴涨股) or 黄金暴涨股),CoLorFF00FF;
坚决买进潜力股:(坚决买进 or ((CLOSE)/(REF(CLOSE,BARSLAST(坚决买进)))<=1.1) AND (COUNT(做空,BARSLAST(坚决买进))<=1)) AND (COUNT(做空,BARSLAST(买))=0) AND (做空=0),CoLor00FF00;
黄金暴涨潜力股:(黄金暴涨股 or ((CLOSE)/(REF(CLOSE,BARSLAST(黄金暴涨股)))<=1.1) AND (COUNT(做空,BARSLAST(黄金暴涨股))=0)) AND (COUNT(做空,BARSLAST(买))=0) AND (做空=0),CoLorFFFFFF;
选底:FILTER((LOW<=上) AND (HIGH>=短期底部) AND (CLOSE>=长期底部) AND ((CLOSE)/(OPEN)>1.03),3) AND (DATE<=1080531),CoLorFFFF00;
稳赚10买:FILTER((买3 or 选底),3) AND (COUNT(买1+买4+龙,3)>0),CoLor0000FF;
持股阶段股:(COUNT(卖,BARSLAST(买))=0),CoLor008000;
STICKLINE(黄金暴涨潜力股,50,40,7,0),CoLorFF0000;
STICKLINE((买=1),0,50,7,0),CoLor102099;
STICKLINE((买=1),0,50,6,0),CoLor1020AA;
STICKLINE((买=1),0,50,5,0),CoLor1020BB;
STICKLINE((买=1),0,50,4,0),CoLor1020CC;
STICKLINE((买=1),0,50,3,0),CoLor1020DD;
STICKLINE((买=1),0,50,2,0),CoLor1020EE;
STICKLINE((买=1),0,50,1,0),CoLor1020FF;
STICKLINE((卖=1),50,100,7,0),CoLorFF7700;
STICKLINE((卖=1),50,100,6,0),CoLorFF8800;
STICKLINE((卖=1),50,100,5,0),CoLorFF9900;
STICKLINE((卖=1),50,100,4,0),CoLorFFAA00;
STICKLINE((卖=1),50,100,3,0),CoLorFFBB00;
STICKLINE((卖=1),50,100,2,0),CoLorFFCC00;
STICKLINE((卖=1),50,100,1,0),CoLorFFDD00;
STICKLINE(VAR95 AND (COUNT(VAR95,30)=1),50,85,5,0),CoLorFF0000;
STICKLINE(大黑马,50,90,5,0),CoLorFF0000;
STICKLINE(大买,50,30,3,0),CoLor0000FF;
STICKLINE(选逃,50,65,3,0),CoLorFF0000;
STICKLINE((选底=1),50,80,3,0),CoLor399C71;
STICKLINE((稳赚10买=1),50,65,3,0),CoLorFF0000;
STICKLINE(高抛,50,75,3,0),CoLorFF0000;
STICKLINE(跑,50,65,3,0),CoLorFF0000;
STICKLINE(坚决买进潜力股,50,58,6,0),CoLorFF0000;
STICKLINE(选持股阶段股,70,50,0.1,0),CoLor0000FF;
DRAWTEXT(选持股阶段股,75,'—'),CoLor0000FF;
DRAWTEXT(坚决买进,13,'坚决买'),CoLor00FFFF;
DRAWTEXT(选拉升股,40,'▲'),CoLor00FFFF;
DRAWTEXT(选暴涨股,50,'★'),CoLor00FFFF;
DRAWTEXT(选超级暴涨股,60,'●'),CoLor00FFFF;
DRAWTEXT(黄金暴涨股,73,'■'),CoLor00FFFF;
DRAWTEXT(VAR95 AND (COUNT(VAR95,30)=1),110,'大资金'),CoLorFFFFFF;
DRAWTEXT(VAR95 AND (COUNT(VAR95,30)=1),100,'进场'),CoLorFFFFFF;
DRAWTEXT(跑,70,'跑'),CoLor008000;
DRAWTEXT(大黑马,105,'大黑马'),CoLorFFFFFF;
DRAWTEXT(CROSS(新庄,散户) AND (新庄>75),90,'抛'),CoLor008000;
DRAWTEXT((稳赚10买=1),80,'赚10'),CoLorFFFFFF;
DRAWTEXT((稳赚10买=1),67,'%买'),CoLorFFFFFF;
DRAWTEXT(IF((选底=1),100,0),92,'底'),CoLorFFFFFF;
DRAWTEXT(选逃,80,'逃'),CoLor008000;
DRAWTEXT(大买,30,'大买'),CoLorFFFFFF;
DRAWTEXT((买=1),(-2),'买'),CoLor0000FF;
DRAWTEXT((卖=1),117,'卖'),CoLor00FFFF;

飞狐顶级顾王指标公式

 

相关文章