在线检测未来函数

通达信波段顶底集成指标公式

来源:Internet,编辑:股旁网,2014-06-21

{顶底波段,买底}
VAR2:=LLV(LOW,10);
VAR3:=HHV(HIGH,25);
阶段卖出: 3.2,COLORYELLOW;
3.5,COLOR0088FF;
顶部清仓: 3.5,COLORGREEN,LINETHICK1;
动力线:= EMA((CLOSE-VAR2)/(VAR3-VAR2)*4,4);
STICKLINE(动力线>REF(动力线,1) ,动力线 ,REF(动力线,1),3 ,1),COLORRED; STICKLINE(动力线<=REF(动力线,1) ,动力线 ,REF(动力线,1),3 ,1),COLOR00FF00;
底部:0.2,COLORRED,LINETHICK1;
关注:0.5,COLORYELLOW;
DRAWICON( FILTER(CROSS(动力线,关注),20),动力线+0.02 ,1);
DRAWICON( FILTER(CROSS(顶部清仓,动力线),20),动力线+0.02,2);
DRAWICON( FILTER(CROSS(动力线,底部),20),动力线+0.02 ,1);
DRAWICON( FILTER(CROSS(阶段卖出,动力线),20),动力线+0.02,2);
DRAWICON( FILTER(CROSS(动力线,关注),20),动力线+0.02 ,1);
DRAWTEXT(CROSS(动力线,关注),关注,'买底'),COLORWHITE;
{回调买}
VAR1:=100*EMA(EMA((C-REF(C,1)),6),6)/EMA(EMA(ABS((C-REF(C,1))),6),6);
回调买:LLV(VAR1,2)=LLV(VAR1,7) AND COUNT(VAR1<0,2) AND CROSS(VAR1,MA(VAR1,2));
DRAWTEXT(回调买,0.8,'回调买'),COLORFFFFFF;
{中线趋势}
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
A1:=2*((EMA(CLOSE,2)-EMA(CLOSE,89))- EMA((EMA(CLOSE,2)-EMA(CLOSE,89)),30))*10;
A2:=2*((EMA(CLOSE,2)-EMA(CLOSE,150))-EMA((EMA(CLOSE,2)-EMA(CLOSE,150)),100));
A3:=(POW(A1,3)*0.1+POW(A1,2))/45+(POW(A2,3)*0.1+POW(A2,1))*5,COLORRED;
A4:=CROSS(C,EMA(C,14)) AND EMA(C,14)>REF(EMA(C,14),2);
AA:=MAX(MAX(MAX(MA(C,5),MA(C,10)),MAX(MA(C,30),MA(C,60))),MA(C,120));
AB:=MIN(MIN(MIN(MA(C,5),MA(C,10)),MIN(MA(C,30),MA(C,60))),MA(C,120));
AC:=O<=AB AND C>=AA ;
中线上升趋势:=A4 AND CROSS(A3,EMA(A3,5)) AND J>30 AND AC;
STICKLINE(中线上升趋势=1,0,1,0.3,0),COLOR0099FF;
DRAWTEXT((A4 AND CROSS(A3,EMA(A3,5)) AND J>30 AND AC),1.7,'中线上升趋势'),COLOR0099FF;
{致命出击}
VARR1:=EMA(HHV(HIGH,500),21);
VARR2:=EMA(HHV(HIGH,250),21);
VARR3:=EMA(HHV(HIGH,90),21);
VARR4:=EMA(LLV(LOW,500),21);
VARR5:=EMA(LLV(LOW,250),21);
VARR6:=EMA(LLV(LOW,90),21);
VARR7:=EMA((VARR4*0.96+VARR5*0.96+VARR6*0.96+VARR1*0.558+VARR2*0.558+VARR3*0.558)/6,21);
VARR8:=EMA((VARR4*1.25+VARR5*1.23+VARR6*1.2+VARR1*0.55+VARR2*0.55+VARR3*0.65)/6,21);
VARR9:=EMA((VARR4*1.3+VARR5*1.3+VARR6*1.3+VARR1*0.68+VARR2*0.68+VARR3*0.68)/6,21);
VARRA:=EMA((VARR7*3+VARR8*2+VARR9)/6*1.738,21);
VARRB:=REF(LOW,1);
VARRC:=SMA(ABS(LOW-VARRB),3,1)/SMA(MAX(LOW-VARRB,0),3,1)*100;
VARRD:=EMA(IF(CLOSE*1.35<=VARRA,VARRC*10,VARRC/10),3);
VARRE:=LLV(LOW,30);
VARRF:=HHV(VARRD,30);
VARR10:=IF(MA(CLOSE,58),1,0);
SS:=EMA(IF(LOW<=VARRE,(VARRD+VARRF*2)/2,0),3)/618*VARR10;
TJ:=(REF(SS,2)<REF(SS,1)AND SS>REF(SS,1))*SS;
买条件:=(REF(SS,2)<REF(SS,1)AND SS>REF(SS,1))*SS,COLORYELLOW,LINETHICK2;
致命出击:(REF(TJ,1)>0 AND 买条件=0),COLORLIGREEN;
DRAWTEXT(致命出击,0.8,'致命出击'),COLORLIGREEN;
{到位}
RN:(LLV(LOW,5)*HHV(HIGH,5))/C/C,COLOR000000;
STICKLINE(CROSS(1.1,RN),1,1.1,1.2,0), COLORYELLOW;
STICKLINE(CROSS(1.2,RN),1,1.3,1.2,0),COLORRED;
STICKLINE(RN>=1.2,1,1.19,3,0), COLORLIRED;
DRAWTEXT(CROSS(1.1,RN),1.17,'到位'),COLORYELLOW;
{炒底高手}
AC1:=AMOUNT/(VOL);
YY:=MA(AC1,13);
LLL:=(C-YY)/YY*100;
MIDC := MA(CLOSE,22);
UPPERC:= MIDC + 2*STD(C,22);
LOWERC:= MIDC - 2*STD(C,22);
BBA:=(C-LOWERC)/(UPPERC-LOWERC);
LIFENGCYC:=(REF(LLL,1)<-15 AND REF(BBA,1)<0 AND LLL>REF(LLL,1));
炒底高手:LIFENGCYC>0,COLORFF0000;
DRAWTEXT(炒底高手,1.2,'炒底高手'),COLORFF0000;
{主力拉升前挖坑动作}
VAR11:=MA(HHV(HIGH,485),17);
VAR22:=MA(HHV(HIGH,222),17);
VAR33:=MA(HHV(HIGH,96),17);
VAR44:=MA(LLV(LOW,485),17);
VAR55:=MA(LLV(LOW,222),17);
VAR66:=MA(LLV(LOW,96),17);
VAR77:=MA((VAR44*0.96+VAR55*0.96+VAR66*0.96+VAR11*0.558+VAR22*0.558+VAR33*0.558)/6,17);
VAR88:=MA((VAR44*1.25+VAR55*1.23+VAR66*1.2+VAR11*0.55+VAR22*0.55+VAR33*0.65)/6,17);
VAR99:=MA((VAR44*1.3+VAR55*1.3+VAR66*1.3+VAR11*0.68+VAR22*0.68+VAR33*0.68)/6,17);
TJJ:=MA(IF(LOW<=LLV(LOW,30),(MA(IF(CLOSE*1.35<=1,
SMA(ABS(L-REF(LOW,1)),3,1)/SMA(MAX(L-REF(LOW,1),0),3,1)*100*10,
SMA(ABS(L-REF(LOW,1)),3,1)/SMA(MAX(L-REF(LOW,1),0),3,1)*100/10),3)+HHV(MA(IF(CLOSE*1.35<=1,
SMA(ABS(L-REF(LOW,1)),3,1)/SMA(MAX(L-REF(LOW,1),0),3,1)*100*10,
SMA(ABS(L-REF(LOW,1)),3,1)/SMA(MAX(L-REF(LOW,1),0),3,1)*100/10),3),30)*2)/2,0),3);
挖坑:REF(TJJ,2)>REF(TJJ,3)AND TJJ<REF(TJJ,1);
DRAWTEXT(挖坑,1.9,'★拉前挖坑'),COLORFF00FF;
{拉升}
Q:=(3*CLOSE+LOW+OPEN+HIGH)/6;
QQ:=(20*Q+19*REF(Q,1)+18*REF(Q,2)+17*REF(Q,3)+16*REF(Q,4)+15*REF(Q,5)+14*REF(Q,6) +13*REF(Q,7)+12*REF(Q,8)+11*REF(Q,9)+10*REF(Q,10)+9*REF(Q,11)+8*REF(Q,12) +7*REF(Q,13)+6*REF(Q,14)+5*REF(Q,15)+4*REF(Q,16)+3*REF(Q,17)+2*REF(Q,18)+ REF(Q,20))/211;
DD:=CROSS(QQ,EMA(EMA(EMA(QQ,2),2),2));
CC:=EMA(EMA(CLOSE,12)-EMA(CLOSE,26),9);
QQ1:=HHV(2*(EMA(CLOSE,12)-EMA(CLOSE,26)-CC),4)<0
AND 2*(EMA(CLOSE,12)-EMA(CLOSE,26)-CC)>REF(2*(EMA(CLOSE,12)-EMA(CLOSE,26)-CC),1)
AND REF(2*(EMA(CLOSE,12)-EMA(CLOSE,26)-CC),1)<REF(2*(EMA(CLOSE,12)-EMA(CLOSE,26)-CC),2)
AND REF(2*(EMA(CLOSE,12)-EMA(CLOSE,26)-CC),2) <REF(2*(EMA(CLOSE,12)-EMA(CLOSE,26)-CC),3);
QQ2:=EMA(EMA(EMA(EMA(CLOSE,2),2),2),2);
DD1:=CROSS(QQ2,EMA(REF(QQ2,1),2)) AND C>O AND V>=MA(V,21) AND V> REF(V,1);
DD2:=DD1+QQ1+DD>=2 AND EMA(CLOSE,12)-EMA(CLOSE,26)>CC AND H/C<1.01 AND REF(MA(C,5),1)<MA(C,5) AND REF(MA(C,5),2)>REF(MA(C,5),1);
MACD1:=(EMA(CLOSE,12)-EMA(CLOSE,26)-EMA(EMA(CLOSE,12)-EMA(CLOSE,26),9))*2;
RSV1:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K1:=SMA(RSV1,3,1);
D1:=SMA(K1,3,1);
CC1:=CROSS(K1,D1) AND MACD1>0;
拉升:=DD2 AND REF(H/C<1.02,1) AND CC1;
STICKLINE(拉升=1,0,1,0.3,0),COLOR0099FF;
DRAWTEXT(拉升,1,'拉升'),COLOR0099FF;
{指标用法:不用人用指标效果不一样,此为抄底指标,出信号后如二天内未过信号当天的最高点。则可以先出来,一般九成第二天或第三天可以过信号当天的高点,还有很多机会可以抓到大波段。根据个股的盘面感觉来把握。};
{筹码V转}
DF2:=(C-REF(C,1))/REF(C,1)*100>5;
DF3:=(C-O)/O*100>4;
最底价:=COST(1);
底V型反转:=L<最底价 AND DF2;
底V型反转2:=CROSS(C,最底价) AND DF2;
底V型反转3:=L<最底价 AND DF3;
V型转向:底V型反转 OR 底V型反转2 OR 底V型反转3;
STICKLINE(V型转向=1,0,0.7,1,0),COLORGREEN;
STICKLINE(V型转向=1,0,0.5,2,0),COLORGREEN;
STICKLINE(V型转向=1,0,1,0.3,0),COLORWHITE;
DRAWTEXT(V型转向=1,0.4,' 筹码V转'),COLORWHITE;
DRAWICON(V型转向=1,1,1);
{找套买}
VAR14:=HHV(HIGH,70);
DD14:=VAR14*0.83;
DDC:=EXIST(DD14/L>1.08,10);
A11:=COST(85);
A21:=COST(15);
A31:=A11-A21;
A41:=(A11+A21)/2;
DM:=A31/A41*100<15;
DMCX:=LAST(DM,15,1);
B1:=MA(C,13)<REF(MA(C,13),1);
SSRP:=MA(SSRP,1);
ZLBT:= DMCX AND SSRP/L>1.18 ;
TJ1:=EXIST(ZLBT,2);
SJT:=C/REF(C,10);
DS:=SJT<=0.85;
找深套买:TJ1 AND DDC AND B1 AND DS,COLORWHITE;
STICKLINE(找深套买, 0,1,0.3,0),COLORWHITE;
DRAWTEXT(找深套买,0.8,' 找深套买'),COLORWHITE;
{抄底关注}
N:=13;
DMH:=SUM(IF(H>REF(H,1),H-REF(H,1),0),N);
DML:=SUM(IF(L>REF(L,1),0,REF(L,1)-L),N);
量:=DMH/(DMH+DML),COLORRED;
抄底关注:量<0.08,COLORFF0000,LINETHICK1;
DRAWTEXT(抄底关注,1.5,'抄底关注'),COLORFF6600;
{准确控盘}
买:=IF("KDJ.J"<0,10,0);
准确控盘:=CROSS(9.9,买);
VAR101:=(2*CLOSE+HIGH+LOW)/4;
VAR201:=LLV(LOW,5);
VAR301:=HHV(HIGH,5);
VAR401:=EMA((VAR101-VAR201)/(VAR301-VAR201)*100,5);
MA1:=MA(VAR401,2);
AA1:=STICKLINE(VAR401>MA1,VAR401,MA1,3,1),COLORRED;
BBB:=STICKLINE(VAR401>MA1 AND REF(VAR401,1)<30,VAR401,MA1,3,1),COLORRED;
{股旁网 www.gupang.com}
STICKLINE(准确控盘, 0,1,0.2,0),COLOR00FFFF;
DRAWTEXT(准确控盘,0.1,' 准确控盘'),COLOR00FFFF;
{多空对比精准买点}
短期:=100*(C-LLV(L,5))/(HHV(C,5)-LLV(L,5)),COLORWHITE;
中期:=100*(C-LLV(L,10))/(HHV(C,10)-LLV(L,10)),COLORYELLOW;
中长期:=100*(C-LLV(L,20))/(HHV(C,20)-LLV(L,20)),COLORMAGENTA;
长期:=100*(C-LLV(L,30))/(HHV(C,30)-LLV(L,30)),COLORRED,LINETHICK2;
HDY:=EMA (100*(C-LLV(LOW,34))/(HHV(H,34)-LLV(LOW,34)),3);
DDD:=短期<2 AND 中期<2 AND 中长期<2 AND 长期<2,COLORRED;
多空精准:=CROSS(C,MA(C,5)) AND COUNT(DDD,3);
精准买点:C/REF(C,1)>1.015 AND L/REF(C,1)<0.985
AND O/REF(C,1)<0.99 AND H/REF(C,1)>1.016
AND REF(C<O,1) AND REF(C/REF(C,1)<0.975,1)
AND COUNT(DDD,2) AND COUNT(HDY<10,2) AND CAPITAL/1000000<10.01,COLORRED;
STICKLINE(多空精准, 0,1,0.2,0),COLORFF6699;
DRAWTEXT(多空精准,1.2,' 多空精准'),COLORFF6699;
{抄底买点}
VAR1001:=REF(CLOSE,1);
VAR2002:=SMA(MAX(CLOSE-VAR1001,0),7,1)/SMA(ABS(CLOSE-VAR1001),7,1)*100;
SS1:=FILTER(REF(VAR2002,1)<20 AND VAR2002>REF(VAR2002,1),5);
SM01:=MA((2*C+H+L)/4,5);
SM02:=SM01*(200-102)/100;
SM03:=(1-7/100)*DMA(C,ABS((2*C+H+L)/4-MA(C,20))/MA(C,20));
SM04:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
SM05:=3*SMA(SM04,3,1)-2*SMA(SMA(SM04,3,1),3,1);
SM06:=((H+L+C)/3-MA((H+L+C)/3,14))/(0.015*AVEDEV((H+L+C)/3,14));
SM07:=SM02<SM03&&SM05>REF(SM05,1)&&REF(SM05,1)<REF(SM05,2)&&SM06<-100
&&SM06>REF(SM06,1);
AAA:=STICKLINE(SM07,0,0.5,2,0),COLORYELLOW;
买点:=SM07,COLORRED,LINETHICK3;
选股:=SS1 AND 买点;
STICKLINE(选股, 0,1,0.2,0),COLOR33FF00;
DRAWTEXT(选股,1.2,' 抄底买点'),COLOR33FF00;
V1:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
V2:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
V3:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
V4:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
V5:=(V2+2*V3+3*V4)/7;
V6:=MA(V5,1);
底部2:=STICKLINE(V6<=-8,0.40,0,10,0),COLORYELLOW;
{买入:IF(V6<-8,0.30,0),LINETHICK2,COLORRED;}
{最佳买点2_白加红}
A101:=REF(CLOSE,1);
A201:=SMA(MAX(CLOSE-A101,0),7,1)/SMA(ABS(CLOSE-A101),7,1)*100;
BIAS1:=(C-MA(C,6))/MA(C,6)*100;
BIAS2:=(C-MA(C,12))/MA(C,12)*100;
BIAS3:=(C-MA(C,24))/MA(C,24)*100;
BIAS:=(BIAS1+2*BIAS2+3*BIAS3)/6;
乖离:=MA(BIAS,3);
STICKLINE(CROSS(BIAS,乖离) AND 乖离<-9.5,1,0,0.2,0),COLORRED;
DRAWTEXT((CROSS(BIAS,乖离) AND 乖离<-9.5),1.5,'最佳买点'),COLORRED;
{判官MACD}
DIF判官:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA判官:=EMA(DIF判官,9),COLORYELLOW;
A1判官:=BARSLAST(REF(CROSS(DIF判官,DEA判官),1));
背离:=REF(CLOSE,A1判官+1)>CLOSE AND DIF判官>REF(DIF判官,A1判官+1) AND CROSS(DIF判官,DEA判官);
判官MACD:=FILTER(COUNT(底背离,20) AND CROSS(C,MA(C,20)),5) AND COUNT(C>MA(C,250),23)>=1;
STICKLINE(判官MACD, 0,1,0.2,0),COLORCC99FF;
DRAWTEXT(判官MACD,0.1,' 判官MACD'),COLORCC99FF;

通达信波段顶底集成指标公式

 

相关文章