在线检测未来函数

通达信大盘顶底指标公式

来源:Internet,编辑:股旁网,2014-06-23

N:=34;
M:=3;
28,COLORFFFFFF;
STICKLINE(C>0,0,2,5,0),COLOR00008A;
STICKLINE(C>0,2,5,5,0),COLOR85008A;
STICKLINE(C>0,5,10,5,0),COLOR657600;
STICKLINE(C>0,10,21.5,5,0),COLOR690079;
STICKLINE(C>0,21.5,28,5,0),COLOR79B715;
VAR1:=EMA(100*(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N)),M)/4,COLORFFFF00,LINETHICK2;
VAR2:IF(VAR1>23.16,VAR1,0),COLOR00FFFF,LINETHICK1;
BB:IF(VAR1<2,6,0),COLOR00FFFF,LINETHICK4;
DD:IF(VAR1>21.5,25.5,28),COLOR0000FF,LINETHICK4;
AA:IF(VAR1>23.16,24.5,28),COLORRED,LINETHICK4;
DRAWBAND(BB,RGB(190,0,100),0,RGB(0,0,0));
DRAWBAND(VAR2,RGB(250,250,0),0,RGB(0,0,0));
DRAWBAND(28,RGB(210,210,210),DD,RGB(0,0,0));
DRAWBAND(28,RGB(250,250,0),AA,RGB(0,0,0));
STICKLINE(C>0,2,2,2,0),COLORFF00FF;
STICKLINE(C>0,5,5,2,0),COLOR00FFFF;
STICKLINE(C>0,23.16,23.16,2,0),COLORFF0000;
顶底线:VAR1,,COLORFFFF00,LINETHICK2;
DRAWICON(CROSS(顶底线,2),2,23);
DRAWICON(CROSS(顶底线,5),5,13);
DRAWICON(CROSS(21.5,顶底线),21.5,14);
DRAWICON(CROSS(23.16,顶底线),23.16,15);
DRAWTEXT(CURRBARSCOUNT=38,1,'底部区'),COLOR00FFFF;
DRAWTEXT(CURRBARSCOUNT=38,3.5,'介入区'),COLOR00FFFF;
DRAWTEXT(CURRBARSCOUNT=38,7.5,'加仓区'),COLOR00FFFF;
DRAWTEXT(CURRBARSCOUNT=38,16,'安全区'),COLOR00FFFF;
DRAWTEXT(CURRBARSCOUNT=38,22,'风险区'),COLOR0000FF;
DRAWTEXT(CURRBARSCOUNT=38,25.5,'逃顶区'),COLORFF00FF;

通达信大盘顶底指标公式

 

相关文章