在线检测未来函数

大智慧木兰主图指标公式

来源:Internet,编辑:股旁网,2014-06-26

a1:=CLOSE = (HHV(CLOSE,13));
a2:=BARSLAST((FILTER((CROSS(0.8,a1)),2))) + 1;
高点:REF(CLOSE,a2),POINTDOT,colorMagenta;
a3:=CLOSE = (LLV(CLOSE,13));
a4:=BARSLAST((FILTER((CROSS(0.8,a3)),2))) + 1;
低点:REF(CLOSE,a4),POINTDOT,colorGreen;
MA5:MA(CLOSE,5),colorYellow;
MA10:MA(CLOSE,10),colorGreen;
MA20:MA(CLOSE,20),colorRed;
MA60:MA(CLOSE,60),colorMagenta;
a5:=EMA((WINNER(CLOSE) * 70),3);
a6:=EMA(((WINNER((CLOSE * 1.1)) - WINNER((CLOSE * 0.9))) * 80),3);
a7:=(a6 / (a5 + a6)) * 100;
a8:=(a5 / (a5 + a6)) * 100;
a9:=EMA(a8,89);
a10:=a8 < a9;
a11:=ALL(a10,5);
a12:=((REF(a7,1)) > 90) AND (a7 < 90);
a13:=ANY(a12,2);
a14:=(((CLOSE - (LLV(LOW,32))) / ((HHV(HIGH,32)) - (LLV(LOW,32)))) * 1.2) * CLOSE;
a15:=EMA(a14,3);
a16:=EMA(a14,5);
a17:=EMA(a14,7);
a18:=(a16 < a17) AND (a15 > (REF(a15,1)));
a19:=(((REF(CLOSE,1)) - (REF(CLOSE,2))) / (REF(CLOSE,2))) * 100;
a20:=RANGE(a19,-2,4);
a21:=((CLOSE - (REF(CLOSE,1))) / (REF(CLOSE,1))) * 100;
a22:=RANGE(a21,-2,4);
a23:=(ANY(a18,2)) AND (a20 AND a22);
a24:=(ALL(a18,2)) AND (a20 AND a22);
a25:=EMA((EMA(CLOSE,13)),13);
a26:=((a25 - (REF(a25,1))) / (REF(a25,1))) * 10000;
a27:=a26 < 0;
a28:=((a26 - (REF(a26,1))) < -1) AND (a26 > 0);
a29:=(a26 > (REF(a26,1))) AND (a26 > 0);
a30:=CROSS(a8,40);
DRAWTEXT(a30,LOW,'主力控盤'),colorRed;
a31:=(ALL(a27,11)) OR (ALL((a26 < 20),11));
a32:=((ALL(a28,11)) OR ((ALL((REF(a28,1)),11)) AND a29)) AND (ALL((a26 < 20),11));
a33:=(a11 OR a13) OR ((a8 > a9) AND (REF(a11,1)));
a34:=(a31 OR a32) OR ((a29 AND (REF(a31,1))) OR (a29 AND (REF(a32,1))));
a35:=a23 OR a24;
DRAWTEXT(((a33 AND a34) AND a35),(LOW - 0.2),'建仓起点'),colorWhite;
a36:=((INDEXC - (REF(INDEXC,1))) / (REF(INDEXC,1))) * 100;
a37:=(EMA((a21 - a36),20)) * 1000;
a38:=RANGE(a21,-3,3);
a39:=(((ALL((a37 < 0),3)) AND (ALL(a10,3))) AND (ALL(a29,3))) AND (ALL(a38,5));
DRAWTEXT(a39,LOW,'温柔建仓'),colorYellow;
a40:=100 * WINNER((CLOSE * 0.95));
a41:=((a40 > 50) AND (COST(85) < CLOSE)) AND (a26 > 0);
DRAWTEXT(a41,(HIGH + 0.8),'高度控盤'),colorYellow;
a42:=REF(a27,1);
a43:=(ALL(a42,4)) OR (ALL(((REF(a26,1)) < 20),6));
a44:=(ALL((REF(a28,1)),3)) AND ((REF(a26,1)) < 20);
a45:=a43 OR a44;
a46:=(((ANY(a41,2)) OR (ALL(a41,2))) OR (ANY(a29,2))) OR (ALL(a29,2));
a47:=a45 AND a46;
a48:=REF(a8,1);
a49:=REF(a9,1);
a50:=a48 < a49;
a51:=ALL(a50,5);
a52:=(a8 > a9) AND (a8 > a7);
a53:=(a8 > a9) OR a52;
a54:=a51 AND ((a10 OR (ANY(a53,2))) OR (ALL(a53,2)));
a55:=((REF(a37,1)) < 0) AND (ANY((a37 > 0),2));
a56:=SMA(a14,13,1);
a57:=SMA(a56,5.5,1.5);
a58:=(3 * a56) - (2 * a57);
a59:=(4 * a57) - (3 * a56);
a60:=a58 > a59;
a61:=(ANY(a18,3)) AND (ANY(a60,2));
a62:=((a54 AND a47) AND a61) AND a55;
DRAWTEXT(a62,LOW,'强势建仓'),colorRed;
a63:=((ANY(a41,2)) OR (ALL(a41,2))) AND (ALL((a26 > 20),4));
a64:=ALL(a41,4);
a65:=MA(a37,8);
a66:=(ALL(((REF(a37,1)) < 0),3)) AND (a37 > 0);
a67:=((ALL((((REF(a37,1)) > 0) AND ((REF(a37,1)) < a65)),3)) AND (a37 > a65)) AND (a37 > 0);
a68:=ALL((a8 > a9),5);
a69:=(a63 AND a66) AND (a8 > a9);
a70:=(a64 AND a67) AND a68;
a71:=a69 OR a70;
DRAWTEXT(a71,LOW,'试盘今买明跑'),colorRed;
a72:=((ANY(a41,2)) OR (ALL(a41,2))) AND (ALL((a26 > 20),5));
a73:=ALL(a41,5);
a74:=(ALL(((REF(a37,1)) < 0),3)) AND ((ANY((a37 > 0),2)) OR (ALL((a37 > 0),2)));
a75:=(ALL((((REF(a37,1)) > 0) AND ((REF(a37,1)) < a65)),3)) AND ((ANY(((a37 > a65) AND (a37 > 0)),2)) OR (ALL(((a37 > a65) AND (a37 > 0)),2)));
a76:=(ANY((a8 > a9),2)) OR (ALL((a8 > a9),2));

大智慧木兰主图指标公式

 

相关文章