在线检测未来函数

通达信红运指标公式

来源:Internet,编辑:股旁网,2014-06-26

N:=5;
LTA:=FINANCE(7)+300000000;
KL:FLOOR(LTA/10000000)/80,LINETHICK0;
DIF:=EMA(CLOSE,20)-EMA(CLOSE,5);
DEA:=EMA(DIF,10);
MACD:=300*(DIF-DEA)*2/EMA(C,30);
VARA:=EMA(REF(CLOSE,1),4);
青山:=(SMA(MAX(CLOSE-VARA,0),6,1)/SMA(ABS(CLOSE-VARA),6,1)*100);
绿水:=青山<3.5,COLORDBDBDB;
火红的:=FILTER(MACD<0 AND MACD>REF(MACD,1) AND 青山<20,5);
太阳:=CROSS(青山,90),COLOR008800;
STICKLINE(青山,0,12000*KL,4,0),COLORDD33DD;
DD:=IF(MACD>=0,MACD,DRAWNULL)*1.5;
STICKLINE(DD AND DD>REF(DD,1),0,DD*80*KL,4,0),COLOR0000FF;
STICKLINE(DD AND DD<REF(DD,1),0,DD*80*KL,3,1),COLOR0000FF;
(青山-25)*150*KL,COLOR5BE800,LINETHICK6;
STICKLINE((青山-25)*1.5>0,0,(青山-25)*150*KL,4,0),COLOR5BE000;
STICKLINE(青山,0,-5000*KL,4,0),COLORAA9900;
ZJ2:=V/((H-L)*2-ABS(C-O));
ZJ3:=IF(C>O,ZJ2*(H-L),IF(C<O,ZJ2*(H-O+(C-L)),V/2))+IF(C>O,0-ZJ2*(H-C+(O-L)),IF(C<O,0-ZJ2*(H-L),0-V/2));
攻击流量:=ZJ3/20/1.15;
ZJ5:=攻击流量*0.55+REF(攻击流量,1)*0.33+REF(攻击流量,2)*0.22;
日流量:=EMA(ZJ5,3);
STICKLINE(C>0 AND 日流量>=0,日流量,0,2,0),COLORFF38FF;
STICKLINE(C>0 AND 日流量<=0,日流量,0,2,0),COLORFA3300;
AR1:=LLV(LOW,10);
AR2:=HHV(H,25);
AR3:=EMA((C-AR1)/(AR2-AR1)*4,4);
红红的天:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)
-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)
-LLV(LOW,27))*100,5,1),3,1),LINETHICK0;
IF(CROSS(红红的天,2),7000*KL,-5000*KL),COLOR0000FF,LINETHICK3;
{IF(红红的天>10,-5000*KL,DRAWNULL),CIRCLEDOT,COLORGREEN;}
IF(红红的天<=10,-5000*KL,DRAWNULL),CIRCLEDOT,COLOR0000FF;
L1:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*200-60;
龙K:SMA(L1,3,1)*100*KL,COLOR0000FF,LINETHICK2;
凤D:SMA(龙K,3,1),COLORFFFFFF,LINETHICK2;
有心就有:IF(CROSS(红红的天,2),7000*KL,DRAWNULL),CROSSDOT,LINETHICK6,COLORFF77FF;
好运!:IF(CROSS(红红的天,2),7000*KL,DRAWNULL),POINTDOT,LINETHICK4,COLOR00CCFF;
STICKLINE(CROSS(龙K,凤D) AND 龙K<-20,-5000*KL,-2000*KL,3,0),COLOR009999;
STICKLINE(CROSS(龙K,凤D) AND 龙K<-20,-5000*KL,-2000*KL,2,0),COLOR00BBBB;
STICKLINE(CROSS(龙K,凤D) AND 龙K<-20,-5000*KL,-2000*KL,1,0),COLOR00DDDD;
STICKLINE(CROSS(龙K,凤D) AND 龙K<-20,-5000*KL,-2000*KL,0.3,0),COLOR00FFFF;
STICKLINE(CROSS(3.5,AR3),10000*KL,12000*KL,3,0), COLOR009900;
STICKLINE(CROSS(3.5,AR3),10000*KL,12000*KL,2,0), COLOR00BB00;
STICKLINE(CROSS(3.5,AR3),10000*KL,12000*KL,1,0), COLOR00DD00;
STICKLINE(CROSS(3.5,AR3),10000*KL,12000*KL,0.3,0), COLOR00FF00;
STICKLINE(CROSS(AR3,0.3),-5000*KL,-2000*KL,3,0),COLOR000099;
STICKLINE(CROSS(AR3,0.3),-5000*KL,-2000*KL,2,0),COLOR0000BB;
STICKLINE(CROSS(AR3,0.3),-5000*KL,-2000*KL,1,0),COLOR0000DD;
STICKLINE(CROSS(AR3,0.3),-5000*KL,-2000*KL,0.3,0),COLOR0000FF;
IF(CROSS(AR3,0.3),-1888*KL,DRAWNULL),CROSSDOT,COLORFF66FF,LINETHICK6;
DRAWTEXT(CROSS( 0,MACD)AND 青山>75 OR 太阳,9800*KL,'ヲ'),COLORDBDBDB;
DRAWTEXT(绿水,-3000*KL,'ャ'),COLORDBDBDB;
DRAWTEXT(绿水,-3000*KL,'︼'),COLOR688EC1;
DRAWBAND(龙K,RGB(255,255,0),凤D,RGB(0,0,220));

通达信红运指标公式

 

相关文章