在线检测未来函数

通达信愚公趋向指标公式

来源:Internet,编辑:股旁网,2014-06-27

N:=14;
M:=6;
TR1 := SUM(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),N);
HD := HIGH-REF(HIGH,1);
LD := REF(LOW,1)-LOW;
DMP:= SUM(IF(HD>0 AND HD>LD,HD,0),N);
DMM:= SUM(IF(LD>0 AND LD>HD,LD,0),N);
PDI: DMP*100/TR,COLORWHITE;
MDI: DMM*100/TR,COLORYELLOW;
ADX: MA(ABS(MDI-PDI)/(MDI+PDI)*100,M),COLORFF00FF;
ADXR:(ADX+REF(ADX,M))/2,COLOR00FF00;
金叉: CROSS(PDI,MDI);
DRAWTEXT(金叉,MDI,'★'),COLORRED;
死叉: CROSS(MDI,PDI);
DRAWTEXT(死叉,PDI,'☆'),COLOR00FF00;

通达信愚公趋向指标公式

 

相关文章