在线检测未来函数

通达信洞察先机指标公式

来源:Internet,编辑:股旁网,2014-06-27

DIF:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD:2*(DIF-DEA),COLORSTICK;
A4:=BARSLAST(REF(CROSS(DIF,DEA),1));
B1:=REF(C,A4+1)>C AND REF(DIF,A4+1)<DIF AND CROSS(DIF,DEA);
DRAWTEXT(FILTER(B1>0,5),DIF+0.2,'背离'),COLORYELLOW;
操盘:STICKLINE(MACD>=0 AND MACD>=REF(MACD,1),0,MACD,2,0),COLORRED{COLOR6058FF};
减仓:STICKLINE(MACD>=0 AND MACD< REF(MACD,1),0,MACD,2,0),COLORFF9900{COLOR6058FF};
反弹:STICKLINE(MACD<0 AND MACD>=REF(MACD,1),0,MACD,2,0),COLORYELLOW{COLORFFFF00};
寻底:STICKLINE(MACD<0 AND MACD< REF(MACD,1),0,MACD,2,0),COLORFFFF00;
{空仓:0,COLORWHITE;
IF(DIF<0,DIF,0),COLORYELLOW,LINETHICK1;
IF(DIF<0,0,DIF),COLORRED,LINETHICK1;
IF(DIF<DEA,DIF,DEA),COLORWHITE,LINETHICK1;
IF(DIF>DEA,DEA,DEA),COLORGREEN,LINETHICK1;}
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
周K:=MA("KDJ.K#WEEK"(9,3,3) ,5);
周D:=MA("KDJ.D#WEEK"(9,3,3) ,5);
周J:=MA("KDJ.J#WEEK"(9,3,3) ,5);
DRAWICON(K<20 AND CROSS(K,D),MACD,1);
周金:DRAWTEXT(CROSS("KDJ.K#WEEK"(9,3,3),"KDJ.D#WEEK"(9,3,3)) ,MACD,'▲'),COLORRED;
周死:DRAWTEXT(CROSS("KDJ.D#WEEK"(9,3,3),"KDJ.K#WEEK"(9,3,3)) ,MACD*1.5,'▼'),COLORGREEN;
月金:DRAWTEXT(CROSS("KDJ.K#MONTH"(9,3,3),"KDJ.D#MONTH"(9,3,3)) ,MACD,'▲'),COLORMAGENTA;
月死:DRAWTEXT(CROSS("KDJ.D#MONTH"(9,3,3),"KDJ.K#MONTH"(9,3,3)) ,MACD*1.5,'▼'),COLORYELLOW;
VAR1C:=(HIGH - MIN(OPEN,CLOSE));
VAR2C:=(CLOSE - OPEN);
VAR3C:=(MIN(OPEN,CLOSE) - LOW);
VAR4C:=(HIGH - LOW);
VAR5C:=((VOL * VAR1C) / VAR4C);
VAR6C:=((VOL * VAR2C) / VAR4C);
VAR7C:=((VOL * VAR3C) / VAR4C);
VAR8C:=((VAR5C - VAR6C) - VAR7C);
VAR4:=MA(CLOSE,5);
VAR5:=MA(CLOSE,10);
VAR6:=MA(CLOSE,30);
VAR7:=MA(CLOSE,60);
VAR8:=EMA(COST(85),7);
VAR9:=EMA(COST(15),7);
VARA:=(SUM(((CLOSE * VOL) * 10),4) / SUM((VOL * 200),4));
VARB:=(INTPART((VARA * 10)) / 10);
VARC:=(SUM(((CLOSE * VOL) * 10),7) / SUM((VOL * 200),7));
VARD:=(INTPART((VARC * 10)) / 10);
VARE:=(SUM(((CLOSE * VOL) * 10),28) / SUM((VOL * 200),28));
VARF:=(INTPART((VARE * 10)) / 10);
短线趋势:(EMA(CLOSE,5) - EMA(CLOSE,10)),COLORRED,LINETHICK1;
中线趋势:EMA(短线趋势,9),COLORMAGENTA,LINETHICK2;
VAR10:=((0 - ((10 * (HHV(CLOSE,5) - CLOSE)) / (HHV(CLOSE,5) - LLV(LOW,5)))) + 10);
VAR11:=((0 - ((10 * (HHV(CLOSE,10) - CLOSE)) / (HHV(CLOSE,10) - LLV(LOW,10)))) + 10);
VAR12:=((0 - ((10 * (HHV(CLOSE,20) - CLOSE)) / (HHV(CLOSE,20) - LLV(LOW,20)))) + 10);
VAR13:=((0 - ((10 * (HHV(CLOSE,30) - CLOSE)) / (HHV(CLOSE,30) - LLV(LOW,30)))) + 10);
VAR14:=REF(中线趋势,1);
VAR15:=中线趋势;
VAR16:=(VAR15 - VAR14);
VAR17:=REF(短线趋势,1);
VAR18:=短线趋势;
VAR19:=(VAR18 - VAR17);
VAR1A:=OPEN;
VAR1B:=CLOSE;
庄家吸筹:IF((((((((VAR1A <= VAR4) AND (VAR1A <= VAR5)) AND (VAR1A <= VAR6)) AND (VAR1B >= VAR4)) AND (VAR1B >= VARF)) AND (VAR16 > 0)) AND (VAR19 > 0)),0.5,0),LINETHICK2,COLOR66FF00;
短线指标:IF(((((CROSS(短线趋势,中线趋势) AND (短线趋势 < 0)) AND (中线趋势 < (0 - 0.2))) AND (VAR11 > 45)) AND (VAR16 > 0)),0.3,0.1),COLOR66FF00;

通达信洞察先机指标公式

 

相关文章