在线检测未来函数

通达信KDJ超准买入指标公式

来源:Internet,编辑:股旁网,2014-07-01

UPPERL:= MA(HIGH,30)*(1+15/100);
UPPERS:= MA(HIGH,3)*(1+3/100);
LOWERS:= MA(LOW,3)*(1-3/100);
LOWERL:= MA(LOW,30)*(1-15/100);
买点:EMA(IF(L<= LLV(L,30),SMA(ABS(L-REF(L,1)),30,1)/SMA(MAX(L-REF(L,1),0),30,1),0),3)*10,STICK,COLORRED,LINETHICK2;
AA:=IF(UPPERS>UPPERL,90,100);
卖点:IF(AA=90,100,0),STICK,LINETHICK3,COLORGREEN;{COLORFF7700}
IF(AA=90,90,0),STICK,LINETHICK3,COLOR000000;
RSV:=(CLOSE-LLV(LOW,19))/(HHV(HIGH,19)-LLV(LOW,19))*100;
K:SMA(RSV,3,1),COLORWHITE;
D:SMA(K,3,1),COLORYELLOW;
J:3*K-2*D,COLORFF00FF;
IF(J>REF(J,1),J,DRAWNULL),COLORRED,LINETHICK2;
IF(J<REF(J,1),J,DRAWNULL)COLOR00BB00,LINETHICK1;
{BS信号}
VAR1:=(H+L+O+C*2)/5;
VAR2:=EMA(VAR1,21);
VAR3:=STD(VAR1,23);
VAR4:=EMA(VAR1,2);
VARA:=(VAR1-VAR2)*100/VAR3;
K1:=(EMA(VARA,23)+100)/2-3,COLOR00FFFF,LINETHICK1;
D1:=SMA(K1,3,1),COLORFFFF00,LINETHICK1;
J1:=4*K1-3*D1,COLORFF00FF,LINETHICK1;
DRAWICON(FILTER(J1>REF(J1,1)AND J1<REF(J1,3) AND J1<K1 AND VAR4>REF(VAR4,1)
AND K1>=REF(K1,1)AND J1<40 OR CROSS(J1,K1)AND CROSS(J1,D1)
AND J1<50 OR J1>REF(J1,1) AND J1<-20,7), J1*0.3,7);
DRAWICON(FILTER(J1<=REF(J1,1) AND J1>80,8) , J1*0.9,8);

通达信KDJ超准买入指标公式

 

相关文章