在线检测未来函数

同花顺风险评估指数指标公式

来源:Internet,编辑:股旁网,2014-07-03

个股收盘价:=CLOSE;
个股5日均价:=MA(CLOSE,5);
个股10日均价:=MA(CLOSE,10);
个股20日均价:=MA(CLOSE,20);
个股40日均价:=MA(CLOSE,40);
个股趋势1:=IF((个股收盘价 > 个股5日均价),10,(0 - 10));
个股趋势2:=IF((个股收盘价 > 个股10日均价),10,(0 - 10));
个股趋势3:=IF((个股收盘价 > 个股20日均价),10,(0 - 10));
个股趋势4:=IF((个股收盘价 > 个股40日均价),10,(0 - 10));
PW:=((VOL * (CLOSE - OPEN)) / (CLOSE + OPEN));
PW1:=EMA(((VOL * (CLOSE - OPEN)) / (CLOSE + OPEN)),38);
ME:=EMA(PW1,8);
ME1:=MA(ME,3);
ME2:=MA(ME,10);
个股能量:=IF((ME1 > ME2),10,(0 - 10));
DSLX:=(CLOSE / INDEXC);
DSLX1:=MA(DSLX,5);
DSLX2:=MA(DSLX,10);
DSLX3:=MA(DSLX,20);
DSLX4:=MA(DSLX,40);
个股强弱1:=IF((DSLX > DSLX1),5,(0 - 5));
个股强弱2:=IF((DSLX > DSLX2),5,(0 - 5));
个股强弱3:=IF((DSLX > DSLX3),5,(0 - 5));
个股强弱4:=IF((DSLX > DSLX4),5,(0 - 5));
大盘收盘价:=INDEXC;
大盘5日均价:=MA(INDEXC,5);
大盘10日均价:=MA(INDEXC,10);
大盘20日均价:=MA(INDEXC,20);
大盘40日均价:=MA(INDEXC,40);
大盘趋势1:=IF((大盘收盘价 > 大盘5日均价),5,(0 - 5));
大盘趋势2:=IF((大盘收盘价 > 大盘10日均价),5,(0 - 5));
大盘趋势3:=IF((大盘收盘价 > 大盘20日均价),5,(0 - 5));
大盘趋势4:=IF((大盘收盘价 > 大盘40日均价),5,(0 - 5));
DPW:=((INDEXL * (INDEXC - INDEXO)) / (INDEXC + INDEXO));
DPW1:=EMA(((VOL * (INDEXC - INDEXO)) / (INDEXC + INDEXO)),38);
DME:=EMA(PW1,8);
DME1:=MA(ME,3);
DME2:=MA(ME,10);
大盘能量:=IF((DME1 > DME2),10,(0 - 10));
指数1:MA((((((((((((((个股趋势1 + 个股趋势2) + 个股趋势3) + 个股趋势4) + 个股能量) + 个股强弱1) + 个股强弱2) + 个股强弱3) + 个股强弱4) + 大盘趋势1) + 大盘趋势2) + 大盘趋势3) + 大盘趋势4) + 大盘能量),5),,colorFFFFFF;
平滑1:MA(指数1,3),,colorFFFF;
低风险区:(0 - 75),,colorFF00;
高风险区:75,,colorFF;

同花顺风险评估指数指标公式

 

相关文章