在线检测未来函数

飞狐预测交叉价格指标公式

来源:Internet,编辑:股旁网,2014-07-05

input: N(9,2,100),M1(3,2,50),M2(3,2,50);
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:SMA(RSV,M1,1);
D:SMA(K,M2,1);
J:3*K-2*D;
交叉位:=((3*REF(D,1)-2*REF(K,1))*(HHV(H,9)-LLV(L,9))/100)+LLV(L,9);
n1:=sysparam(3); n2:=sysparam(2); n3:=(n1-n2)+1; hh:=hhv(J,n3); ll:=llv(J,n3);
zhh:=hh[n1]; zll:=ll[n1];
DRAWTEXT(BARPOS=SYSPARAM(3)&&交叉位<C,zhh,'预测死叉价: '+NUMTOSTR(交叉位,2)),ALIGN2,SHIFT3,PXDN10,ColorFF8E00;
DRAWTEXT(BARPOS=SYSPARAM(3)&&交叉位>C,zll,'预测金叉价: '+NUMTOSTR(交叉位,2)),ALIGN2,SHIFT3,PXUP10,ColorFF8EFF;

飞狐预测交叉价格指标公式

 

相关文章