在线检测未来函数

飞狐凤翔MACD指标公式

来源:Internet,编辑:股旁网,2014-07-06

DIFF8 := EMA(CLOSE,25) - EMA(CLOSE,65),POINTDOT,LINETHICK2;
DEA8 := EMA(DIFF8,45),POINTDOT,LINETHICK2;
MACD8 := 2*(DIFF8-DEA8), COLORSTICK;
FILLRGN(diff8>=dea8,diff8,dea8),Color006CCC;
FILLRGN(diff8<dea8,diff8,dea8)colorblue;
FILLRGN(diff8<ref(diff8,1) and macd8>0,diff8,dea8),Color003C76;
DIFF :=EMA(CLOSE,12) - EMA(CLOSE,26),coloryellow,linethick2;
DEA := EMA(DIFF,9)colorGREEN,linethick2;
MACD : 2*(DIFF-DEA), COLORSTICK,linethick1;
stickline(macd<ref(macd,1) and diff>dea,macd,0,1,0),Colorred;
stickline(macd>ref(macd,1) and diff>dea,macd,0,8,0),COLORRED;
stickline(macd>ref(macd,1) and diff>dea,macd,0,1,0),coloryellow;
stickline(DIFF>DEA and macd<ref(macd,1) ,macd,0,8,0),ColorE500DD;
stickline(DIFF>DEA and macd<ref(macd,1),macd,0,1,0),Coloryellow;
stickline(DIFF<DEA ,macd,0,8,0),Color005B0C;
stickline(DIFF<DEA ,macd,0,1,0),Color848284;
stickline(DIFF<DEA and macd>ref(macd,1) ,macd,0,8,0),Color7BA600;
stickline(DIFF<DEA and macd>ref(macd,1),macd,0,1,0),Color;
DIFFs : EMA(CLOSE,5) - EMA(CLOSE,12)colorwhite,linethick1;
DEAs : EMA(DIFFs,4)colorgreen,linethick1;
MACDs := 2*(DIFFs-DEAs), COLORSTICK,linethick1;
drawicon(cross(dea8,diff8),dea8,3);
drawicon(cross(diff8,dea8),dea8,1);
DRAWTEXT(cross(diff,dea) and macd8>0 and diffs>deas,dea,'--卧槽马')color;
{猎豹出击}
a2:=(CLOSE/REF(CLOSE,1)-1)*100;
a3:=AMOUNT/FINANCE(7)/1000;
{a2/a3;}
a4:=INDEXC/ref(indexc,1);
drawtext(a2/a4>9.5,DIFF8,'--猎豹出击82'),coloryellow;
{猎鹰出击}
出击:=((C-O)/REF(C,1)),colormagenta;
drawtext(cross(出击,0.09) or 出击>0.09,dea8,'--猎鹰出击75')coloryellow;

飞狐凤翔MACD指标公式

 

相关文章