在线检测未来函数

大智慧强势突破指标公式

来源:Internet,编辑:股旁网,2014-07-06

MA5:=MA(CLOSE,5);
MA10:=MA(CLOSE,10);
MA20:=MA(CLOSE,20);
A1:=IF(C>=MA5,1,-1);
A2:=IF(C>=MA10,1,-1);
A3:=IF(C>=MA20,1,-1);
A4:=IF(MA5>=REF(MA5,1),1,-1);
A5:=IF(MA10>=REF(MA10,1),1,-1);
A6:=IF(MA20>=REF(MA20,1),1,-1);
趋势:(A1+A2+A3+A4+A5+A6)/6*100,Color00FF00;
主升浪:趋势>=50,COLOR0000FF,POINTDOT,LINETHICK0;
↓:趋势<50,COLORFFFFFF,POINTDOT,LINETHICK0;
周期:IF(主升浪,BARSLAST(CROSS(主升浪,0.1))+1,0),COLORFF00FF,POINTDOT,LINETHICK0;
临界:IF(CROSS(98,趋势),1,0),COLOR00FF00,POINTDOT,LINETHICK0;
WKQY:=BARSLAST(CROSS(50,趋势))<MIN(BARSLAST(CROSS(趋势,1)),BARSLAST(CROSS(趋势,-1)));
挖坑:BETWEEN(趋势,-1,50) and WKQY,COLOR00FFFF,POINTDOT,LINETHICK0;
{以下设置副图显示方式}
FILLRGN(50,趋势,主升浪,RGB(250,0,0)),LAYER7;
FILLRGN(50,趋势,挖坑,RGB(250,250,0)),LAYER7;
STICKLINE(主升浪,周期*0.8,周期*0.95,6,0),COLOR0000FF;
STICKLINE(主升浪,周期*1.05,周期*1.2,6,0),COLOR0000FF;
STICKLINE(主升浪 AND C<REF(C,1),周期*0.9,周期*1.1,6,1),COLORFFFFFF;
VERTLINE(CROSS(主升浪,0.1),2),COLOR0000FF,LINETHICK3;
DRAWTEXT(临界,100,'S☆'),COLOR00FF00,ALIGN1;
0,COLORFFFFFF;50,COLOR00FFFF,DOTLINE;

大智慧强势突破指标公式

 

相关文章