在线检测未来函数

通达信突破多空量指标公式

来源:Internet,编辑:股旁网,2014-07-06

万手:VOL/10000,LINETHICK0;
虚拟:IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL/10000*240/FROMOPEN,DRAWNULL),NODRAW;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,虚拟,0,-1,-1),COLOR00C0C0;
量:VOL/10000,NODRAW,COLORWHITE;
STICKLINE(量<=HHV(量,144)*0.2,0,量,2,0),COLORGRAY;
STICKLINE(量>=HHV(量,144),0,量,2,0),COLORGREEN;
STICKLINE(量>HHV(量,144)*0.2 AND 量<HHV(量,144) AND C>REF(C,1) AND (量/REF(量,1)<1.5 OR 量/REF(量,1)>3.6),0,量,2,1),COLORRED;
STICKLINE(量>HHV(量,144)*0.2 AND 量<HHV(量,144) AND C<=REF(C,1) AND (量/REF(量,1)<1.5 OR 量/REF(量,1)>3.6),0,量,2,1),COLORCYAN;
STICKLINE(量<=HHV(量,144)*0.2 AND 量/REF(量,1)>=1.5 AND 量/REF(量,1)<=3.6,REF(量,1),量,2,0),COLORYELLOW;
STICKLINE(量>HHV(量,144)*0.2 AND 量<HHV(量,144) AND 量/REF(量,1)>=1.5 AND 量/REF(量,1)<=3.6,0,量,2,0),COLORYELLOW;
AA:=VOL/10000/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
主买:IF(CLOSE>OPEN,AA*(HIGH-LOW),IF(CLOSE<OPEN,AA*((HIGH-OPEN)+(CLOSE-LOW)),VOL/10000/2)),NODRAW,COLORRED;
主卖:IF(CLOSE>OPEN,0-AA*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0-AA*(HIGH-LOW),0-VOL/10000/2)),NODRAW,COLORGREEN;
净买:=主买+主卖;
净流:主买+主卖,NODRAW,COLORCYAN;
STICKLINE(C>REF(C,1),0,主买,1,0),COLORRED;
STICKLINE(C<=REF(C,1),0,主买,1,0),COLORGREEN;
净买周:EMA(净买,4),COLOR0000FF,LINETHICK3;
净买月:EMA(净买,20),COLORFF80FF,LINETHICK3;
{E5:EMA(量,5),COLORCYAN;
E21:EMA(量,21),COLORGREEN;
E144:EMA(量,144),COLORMAGENTA;}
量比:VOL/10000/REF(VOL/10000,1),NODRAW,COLORCYAN;
主买占比:主买/量*100,NODRAW,COLOR336699;
DRAWTEXT_FIX(CURRBARSCOUNT=59,0.005,0,0,'地量:小于144天最大成交量的20%,灰色柱'),COLOR808080;
DRAWTEXT_FIX(CURRBARSCOUNT=59,0.005,0.08,0,'倍量:今天的成交量大于昨天成交量的1.5倍,并且小于3.6倍,黄色柱'),COLOR00FFFF;
DRAWTEXT_FIX(CURRBARSCOUNT=59,0.005,0.16,0,'既是地量,又是倍量,下半截是灰色柱,上半截是黄色柱'),COLOR408080;
DRAWTEXT_FIX(CURRBARSCOUNT=59,0.005,0.24,0,'天量:144天的最大量,绿色柱'),COLOR80FF00;
DRAWTEXT_FIX(CURRBARSCOUNT=59,0.005,0.32,0,'平量:既不是地量,又不是天量,又不是倍量.涨,红色空心柱,跌,蓝色空心柱'),COLOR0000FF;
DRAWTEXT(CROSS(净买周,净买月),0,0'突破'),COLORYELLOW;

通达信突破多空量指标公式

 

相关文章