在线检测未来函数

同花顺背离吧指标公式

来源:Internet,编辑:股旁网,2014-07-09

底:-50;
顶:50;
TR := SUM(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),14);
HD := HIGH-REF(HIGH,1);
LD := REF(LOW,1)-LOW;
PDM:= SUM(IF(HD>0 AND HD>LD,HD,0),14);
MDM:= SUM(IF(LD>0 AND LD>HD,LD,0),14);
PDI:= PDM*100/TR;
MDI:= MDM*100/TR;
A1:=BARSLAST(REF(CROSS("macd.diff"(12,26,9),"macd.dea"(12,26,9)),1));
B1:=REF(C,A1+1)>C AND REF("macd.diff"(12,26,9),A1+1)<"macd.diff"(12,26,9) AND CROSS("macd.diff"(12,26,9),"macd.dea"(12,26,9));
A2:=BARSLAST(REF(CROSS("kdj.k"(9,3,3),"kdj.d"(9,3,3)),1));
B2:=REF(C,A2+1)>C AND REF("kdj.k"(9,3,3),A2+1)<"kdj.k"(9,3,3) AND CROSS("kdj.k"(9,3,3),"kdj.d"(9,3,3));
A3:=BARSLAST(REF(CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24)),1));
B3:=REF(C,A3+1)>C AND REF("RSI.RSI1"(6,12,24),A3+1)<"RSI.RSI1"(6,12,24) AND CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24));
C1:=BARSLAST(REF(CROSS("macd.dea"(12,26,9),"macd.diff"(12,26,9)),1));
D1:=REF(C,C1+1)<C AND REF("macd.diff"(12,26,9),C1+1)>"macd.diff"(12,26,9) AND CROSS("macd.dea"(12,26,9),"macd.diff"(12,26,9));
C2:=BARSLAST(REF(CROSS("kdj.d"(9,3,3),"kdj.k"(9,3,3)),1));
D2:=REF(C,C2+1)<C AND REF("kdj.k"(9,3,3),C2+1)>"kdj.k"(9,3,3) AND CROSS("kdj.d"(9,3,3),"kdj.k"(9,3,3));
C3:=BARSLAST(REF(CROSS("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24)),1));
D3:=REF(C,C3+1)<C AND REF("RSI.RSI1"(6,12,24),C3+1)>"RSI.RSI1"(6,12,24) AND CROSS("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24));
C4:=BARSLAST(REF(CROSS(mdi,pdi),1));
D4:=REF(C,C+1)<C AND REF(mdi,C4+1)>mdi AND CROSS(mdi,pdi);
A4:=BARSLAST(REF(CROSS(PDI,MDI),1));
B4:=REF(C,A4+1)>C AND REF(pdi,A4+1)<pdi AND CROSS(pdi,mdi);
DMI底背:IF(B4>0,-50,0),COLOR0099FF,POINTDOT;
DRAWTEXT(DMI底背,-5,'DMI底背'),color0099FF;
DMI顶背:IF(D4>0,50,0),colorblue,POINTDOT;
DRAWTEXT(DMI顶背,15,'DMI顶背'),colorblue;
MACD底背:IF(B1>0,-50,0),colorred,POINTDOT;
DRAWTEXT(MACD底背,-15,'MACD底背'),colorred;
KDJ底背:IF(B2>0,-50,0),colorff00ff,POINTDOT;
DRAWTEXT(KDJ底背,-25,'KDJ底背'),COLORff00ff;
RSI底背:IF(B3>0,-50,0),coloryellow,POINTDOT;
DRAWTEXT(RSI底背,-35,'RSI底背'),coloryellow;
MACD顶背:IF(D1>0,50,0),color00ff00,POINTDOT;
DRAWTEXT(MACD顶背,25,'MACD顶背'),COLOR00ff00;
KDJ顶背:IF(D2>0,50,0),colorffcc66,POINTDOT;
DRAWTEXT(KDJ顶背,35,'KDJ顶背'),COLORffcc66;
RSI顶背:IF(D3>0,50,0),colorffffff,POINTDOT;
DRAWTEXT(RSI顶背,45,'RSI顶背'),COLORffffff;
STICKLINE(B1>0,-50,0,2,0),colorred;
STICKLINE(B2>0,-50,0,2,0),colorff00ff;
STICKLINE(B3>0,-50,0,2,0),coloryellow;
STICKLINE(d1>0,50,0,2,0),color00ff00;
STICKLINE(d2>0,50,0,2,0),colorffcc66;
STICKLINE(d3>0,50,0,2,0),colorwhite;
STICKLINE(B4>0,-50,0,2,0),color0099ff;
STICKLINE(D4>0,50,0,2,0),colorblue;

同花顺背离吧指标公式

 

相关文章