在线检测未来函数

大智慧优化阴阳主图指标公式

来源:Internet,编辑:股旁网,2014-07-07

A1:=1;
MID:EMA(CLOSE,17)*A1,LINETHICK1,colorFFFFFF;
UPPER:MID+2*STD(CLOSE,17),LINETHICK1;
LOWER:MID-2*STD(CLOSE,17),LINETHICK1,colorFFFF80;
UPPERO:MID+3*STD(CLOSE,17),LINETHICK1;
LOWERO:MID-3*STD(CLOSE,17),LINETHICK1,colorFFFF80;
DRAWICON(CROSS(LOW,LOWERO),LOW,1),ALIGN0;
DRAWICON(CROSS(HIGH,UPPERO),HIGH,2),ALIGN2;
DRAWTEXT(CROSS(LOWERO,LOW),LOW-0.01,''),ALIGN1;
DRAWTEXT(CROSS(LOWERO,LOW),LOW-0.01,''),ALIGN1;
LOCK:=IF(CURRENTDATE<1160101,1,0);
{VAR1:MD(CLOSE,20);
PARTLINE(VAR1>REF(VAR1,2),VAR1),LINETHICK2,colorFF00FF;}
{PARTLINE(VAR1=REF(VAR1,2),VAR1),LINETHICK2,colorFF0000;}
{PARTLINE(VAR1<REF(VAR1,2),VAR1),LINETHICK2;}
M1:=MA(CLOSE,5);
M2:=MA(CLOSE,10);
M3:=MA(CLOSE,20);
M4:=MA(CLOSE,60);
M5:=MA(CLOSE,120);
PM3:=MA(CLOSE,30);
DRAWICON(M1>M2
AND M2>M3 AND M2>M4 AND M2>M5 AND M2>PM3 AND REF(M1,1)<M1 AND
REF(M2,1)<M2 AND REF(M3,1)<M3 AND
REF(PM3,1)<PM3,OPEN,12);
{BB:=BARPOS=SYSPARAM(1);
VARIABLE:WDAY[7]='星期六';
WDAY[1]:='星期日';
WDAY[2]:='星期一';
WDAY[3]:='星期二';
WDAY[4]:='星期三';
WDAY[5]:='星期四';
WDAY[6]:='星期五';
FY:=YEAR;
FM:=MONTH;
FD:=DAY;
WD:=WEEKDAY;
P:=SYSPARAM(1);
STR1:='今天是:'+NUMTOSTR(FY[P],0)+'年'+NUMTOSTR(FM[P],0)+'月'+NUMTOSTR(FD[P],0)+'日,
'+WDAY[WD[P]+1];
EXPLAIN(BARPOS=P,STR1),colorFF;
EXPLAIN(1,STKLABEL+STKNAME+'\n所属板块:'+BLKNAME),colorFFFF80;
EXPLAIN(CLOSE>0,'〓
K 线形态分析 〓 '),colorFFFFFF;}
{大智慧K线自动解盘
:}
早晨之星:=REF(CLOSE,2)/REF(OPEN,2)<0.95 AND REF(OPEN,1)<REF(CLOSE,2) AND
ABS(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<0.03 AND CLOSE/OPEN>1.05 AND
CLOSE>REF(CLOSE,2);
黄昏之星:=REF(CLOSE,2)/REF(OPEN,2)>1.03 AND
REF(OPEN,1)>REF(CLOSE,2) AND
ABS(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<0.02 AND CLOSE/OPEN<0.97 AND
CLOSE<REF(CLOSE,2);
长十字:=CLOSE=OPEN AND HIGH/LOW
>1.03;
垂死十字:=CLOSE=OPEN AND CLOSE=LOW AND
CLOSE<>HIGH;
早晨十字星:=REF(CLOSE,2)/REF(OPEN,2)<0.95 AND
REF(OPEN,1)<REF(CLOSE,2) AND REF(OPEN,1)=REF(CLOSE,1) AND CLOSE/OPEN>1.05
AND CLOSE>REF(CLOSE,2);
黄昏十字星:=REF(CLOSE,2)/REF(OPEN,2)>1.05 AND
REF(OPEN,1)>REF(CLOSE,2) AND REF(OPEN,1)=REF(CLOSE,1) AND CLOSE/OPEN<0.95
AND CLOSE<REF(CLOSE,2);
射击之星:=MIN(OPEN,CLOSE)=LOW AND
HIGH-LOW>3*(MAX(OPEN,CLOSE)-LOW) AND
CLOSE>MA(CLOSE,5);
倒转锤头:=MIN(OPEN,CLOSE)=LOW AND
HIGH-LOW>3*(MAX(OPEN,CLOSE)-LOW) AND CLOSE<MA(CLOSE,5);
锤头:=HIGH =
MAX(OPEN,CLOSE) AND HIGH-LOW>3*(HIGH-MIN(OPEN,CLOSE)) AND
CLOSE<MA(CLOSE,5);
吊颈:=HIGH = MAX(OPEN,CLOSE) AND
HIGH-LOW>3*(HIGH-MIN(OPEN,CLOSE)) AND
CLOSE>MA(CLOSE,5);
穿头破脚:=(REF(CLOSE,1)/REF(OPEN,1)>1.03 AND
CLOSE/OPEN<0.96 AND CLOSE<REF(OPEN,1) AND OPEN>REF(CLOSE,1)) OR
(REF(CLOSE,1)/REF(OPEN,1)<0.97 AND CLOSE/OPEN>1.04 AND
CLOSE>REF(OPEN,1) AND
OPEN<REF(CLOSE,1));
乌云盖顶:=REF(CLOSE,1)/REF(OPEN,1)>1.03 AND
CLOSE/OPEN<0.97 AND OPEN>REF(CLOSE,1) AND
CLOSE<REF(CLOSE,1);
曙光初现:=REF(CLOSE,1)/REF(OPEN,1)<0.97 AND
CLOSE/OPEN>1.03 AND OPEN<REF(CLOSE,1) AND
CLOSE>REF(CLOSE,1);
身怀六甲:=ABS(REF(CLOSE,1)-REF(OPEN,1))/REF(CLOSE,1)>0.04
AND ABS(CLOSE-OPEN)/CLOSE<0.005 AND
MAX(CLOSE,OPEN)<MAX(REF(CLOSE,1),REF(OPEN,1)) AND
MIN(CLOSE,OPEN)>MIN(REF(CLOSE,1),REF(OPEN,1));
十字胎:=ABS(REF(CLOSE,1)-REF(OPEN,1))/REF(CLOSE,1)>0.04
AND CLOSE=OPEN AND CLOSE < MAX(REF(CLOSE,1),REF(OPEN,1)) AND CLOSE >
MIN(REF(CLOSE,1),REF(OPEN,1));
平顶:=ABS(HIGH-REF(HIGH,1))/HIGH<0.001;
平底:=(ABS(LOW-REF(LOW,1))/LOW<0.001
and abs(ref(low,1)-ref(low,2))/ref(low,1)<=0.001);
大阳烛:=CLOSE/OPEN>1.05
AND HIGH/LOW<CLOSE/OPEN+0.018;
三个白武士:=REF(CLOSE,2)>REF(OPEN,2) AND
REF(CLOSE,1)>REF(OPEN,1) AND CLOSE>OPEN AND REF(CLOSE,1)>REF(CLOSE,2)
AND CLOSE>REF(CLOSE,1);
双飞乌鸦:=REF(CLOSE,1)<REF(OPEN,1) AND
CLOSE<OPEN AND CLOSE/OPEN<0.98;
孕育线:=REF(CLOSE,2)>REF(OPEN,2) AND
(REF(CLOSE,2)-REF(OPEN,2))/REF(OPEN,2)>=2/100 AND
REF(OPEN,1)>=REF(CLOSE,1) AND
(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<=2/100 AND
REF(OPEN,1)<=REF(CLOSE,2) AND REF(CLOSE,1)>=REF(OPEN,2) AND C>=OPEN AND
(CLOSE-OPEN)/OPEN>=2/100 AND CLOSE>=REF(OPEN,1) AND OPEN<=REF(CLOSE,1)
AND
(MAX(CLOSE,REF(C,2))-MIN(CLOSE,REF(CLOSE,2)))/MIN(CLOSE,REF(CLOSE,2))<=1/100;
多方炮:=REF(CLOSE,2)>REF(OPEN,2)
AND REF(CLOSE,1)<REF(OPEN,1) AND CLOSE>OPEN;
出水芙蓉:=(OPEN<EMA(C,20)
OR OPEN<EMA(C,40) OR OPEN<EMA(C,60)) AND
(C>MAX(EMA(C,20),MAX(EMA(C,40),EMA(C,60)))) AND (V/MA(V,30)>1.2 AND
C/REF(C,1)>1.049);
上升三部曲:=REF(CLOSE,4)/REF(OPEN,4)>1.03 AND
REF(CLOSE,3)<REF(OPEN,3) AND REF(CLOSE,2)<REF(OPEN,2) AND
REF(CLOSE,1)<REF(OPEN,1) AND REF(LOW,4)<REF(LOW,3) AND
REF(LOW,4)<REF(LOW,2) AND REF(LOW,4)<REF(LOW,1) AND
REF(HIGH,4)>REF(HIGH,3) AND REF(HIGH,4)>REF(HIGH,2) AND
REF(HIGH,4)>REF(HIGH,1) AND CLOSE/OPEN>1.03 AND
CLOSE>REF(CLOSE,4);
下跌三部曲:= REF(CLOSE,4)/REF(OPEN,4)<0.97 AND
REF(CLOSE,3)>REF(OPEN,3) AND REF(CLOSE,2)>REF(OPEN,2) AND
REF(CLOSE,1)>REF(OPEN,1) AND REF(LOW,4)<REF(LOW,3) AND
REF(LOW,4)<REF(LOW,2) AND REF(LOW,4)<REF(LOW,1) AND
REF(HIGH,4)>REF(HIGH,3) AND REF(HIGH,4)>REF(HIGH,2) AND
REF(HIGH,4)>REF(HIGH,1) AND CLOSE/OPEN<0.97 AND
CLOSE<REF(CLOSE,4);
跳空缺口:=HIGH<REF(LOW,1) OR
LOW>REF(HIGH,1);
三只乌鸦:=REF(CLOSE,2)<REF(OPEN,2) AND
REF(CLOSE,1)<REF(OPEN,1) AND CLOSE<OPEN AND REF(CLOSE,1)<REF(CLOSE,2)
AND CLOSE<REF(CLOSE,1);
光脚阴线:=LOW=CLOSE AND
HIGH<>LOW;
光头阳线:=HIGH=CLOSE AND
HIGH<>LOW;
分离:=OPEN=REF(OPEN,1) AND
(CLOSE-OPEN)*(REF(CLOSE,1)-REF(OPEN,1))<0;
长下影:=(MIN(CLOSE,OPEN)-LOW)/(HIGH-LOW)>0.667;
长上影:=(HIGH-MAX(CLOSE,OPEN))/(HIGH-LOW)>0.667;
十字星:=CLOSE=OPEN
AND HIGH<>LOW;
大阴烛:=OPEN/CLOSE > 1.05 AND HIGH/LOW <
OPEN/CLOSE+0.018;
好友反攻:=(REF(CLOSE,1)<REF(OPEN,1) AND CLOSE>OPEN AND
ABS(CLOSE-REF(CLOSE,1))/CLOSE<0.002) OR (REF(CLOSE,1)>REF(OPEN,1) AND
CLOSE<OPEN AND
ABS(CLOSE-REF(CLOSE,1))/CLOSE<0.002);
倾盆大雨:=REF(C,1)/REF(O,1)>=1.03 AND
O<REF(C,1) AND O>REF(O,1) AND C<REF(O,1);
if DISPSTATUS=2 then
begin;
var1000:='.';
if 倾盆大雨 then var1000:=var1000+'★倾盆大雨,见顶信号;';
if
大阴烛 then var1000:=var1000+'★大阴烛,后市向淡,发生逆转;';
if 好友反攻 then
var1000:=var1000+'★好友反攻,底部反转;';
if 跳空缺口 then
var1000:=var1000+'★跳空缺口,注意向上还是向下跳空;';
if 光脚阴线 then
var1000:=var1000+'★光脚阴线,下跌信号;';
IF 光头阳线 then
var1000:=var1000+'★光头阳线,后市看涨;';
IF 三只乌鸦 then
var1000:=var1000+'★三只乌鸦,可能见顶回落;';
IF 分离 then
var1000:=var1000+'★分离,注意看涨分离和看跌分离;';
IF 长下影 then
var1000:=var1000+'★长下影,持续下跌后出现,有可能止跌回升;在升势末期出现,须多加留意;';
IF 长上影 then
var1000:=var1000+'★长上影,表明行情上档压力沉重,升势受阻;';
IF 下跌三部曲 then
var1000:=var1000+'★下跌三部曲,下跌信号;';
IF 上升三部曲 then
var1000:=var1000+'★上升三部曲,上涨信号;';
IF 早晨之星 then
var1000:=var1000+'★早晨之星,见底回升;';
IF 黄昏之星 then
var1000:=var1000+'★黄昏之星,见顶回落;';
IF 十字星 then
var1000:=var1000+'★十字星,有转向意味,注意股价位置在顶部还是底部;';
IF 长十字 then
var1000:=var1000+'★长十字,注意在顶部还是底部;';
IF 垂死十字 then
var1000:=var1000+'★垂死十字,下跌信号;';
IF 早晨十字星 then
var1000:=var1000+'★早晨十字星,上涨信号,见底回升;';
IF 黄昏十字星 then
var1000:=var1000+'★黄昏十字星,下跌信号,见顶回落;';
IF 射击之星 then
var1000:=var1000+'★射击之星,可能见顶回落,可靠性低;';
IF 倒转锤头 then
var1000:=var1000+'★倒转锤头,可能见底回升;';
IF 锤头 then
var1000:=var1000+'★锤头,可能见底回升,如有量配合,信号强烈;';
IF 吊颈 then
var1000:=var1000+'★吊颈,上升行情中见顶回落,顶部出现,见顶信号;';
IF 平顶 then
var1000:=var1000+'★平顶,温和的反转;';
IF 穿头破脚 then
var1000:=var1000+'★穿头破脚,顶部出现,见顶回落信号;';
IF 乌云盖顶 then
var1000:=var1000+'★乌云盖顶,见顶回落信号;';
IF 曙光初现 then
var1000:=var1000+'★曙光初现,后市见底回升;';
IF 身怀六甲 then
var1000:=var1000+'★身怀六甲,出现在底部,是见底回升信号;出现在顶部,是见顶回落信号;';
IF 十字胎 then
var1000:=var1000+'★十字胎;';
IF 平底 then var1000:=var1000+'★平底,温和的反转;';
IF 大阳烛
then var1000:=var1000+'★大阳烛,看涨;';
IF 三个白武士 then
var1000:=var1000+'★三个白武士,每日收盘价上移,表示可能见底回升;';
IF 双飞乌鸦 then
var1000:=var1000+'★双飞乌鸦,行情将见顶回落;';
IF 孕育线 then
var1000:=var1000+'★孕育线,注意股价位置;';
IF 多方炮 then
var1000:=var1000+'★多方炮,在底部出现有上涨意味,在中间出现有可能是上涨中继,顶部出现是复合见顶信号;';
IF 出水芙蓉 then
var1000:=var1000+'★出水芙蓉,见底回升;';
end;
TIPTEXT(DISPSTATUS=2,0,var1000);
A001:=CLOSE-REF(CLOSE,6);
A002:=MA(A001,6);
A003:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
A004:=SMA(A003,3,1);
A005:=SMA(A004,3,1);
A006:=EMA(3*A004-2*A005,2);
A007:=(HIGH+LOW+CLOSE)/3;
A008:=(A007-MA(A007,14))/(0.015*AVEDEV(A007,14))/2;
A009:=(A008+EMA((-100*(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14))+100)/100,3)*200-100)/2;
A010:=A009-REF(A009,14);
A011:=A009-REF(A009,26);
A012:=(A009+A010+A011)/3;
KKM:=EMA(A012,4);
A013:=HHV(HIGH,34);
A014:=(2*CLOSE+HIGH+LOW)/4;
A015:=LLV(LOW,34);
A016:=EMA((A014-A015)/(A013-A015)*100,13);
A017:=EMA(0.667*REF(A016,1)+0.333*A016,2);
KKMD:=A016-A017>1
AND A016<30 AND A017<30;
KKML:=A016-A017<0 AND A016>80 AND
A017>80 AND
REF(A016-A017,1)>0;
KKMQ:=COUNT(A016-A017>0,2)=2;
KKAL:=A016-A017<0;
{生命线:=MA(CLOSE,20);
取舍线:=MA(CLOSE,10);
EXPLAINICON(KKMD,4);
EXPLAINICON(KKAL,1);
EXPLAIN(KKMD,'最佳买入时机');
EXPLAIN(KKML,'最佳卖出时机');
EXPLAIN(KKMQ,'持仓区');
EXPLAIN(KKAL,'空仓区');
EXPLAIN(CLOSE/REF(CLOSE,1)>INDEXC/REF(INDEXC,1),'该股强于大盘');
EXPLAIN(CLOSE/REF(CLOSE,1),'该股强于大盘');
EXPLAIN(CROSS(MA(CLOSE,5),MA(CLOSE,10)),'可出手');
EXPLAIN(CROSS(MA(CLOSE,10),MA(CLOSE,5)),'收手了');
EXPLAIN(KKM>EMA(KKM,4)
AND KKM>REF(KKM,1),'快速介入');
EXPLAIN(KKM>EMA(KKM,4) AND
KKM<REF(KKM,1),'休息观望~');
EXPLAIN(KKM<EMA(KKM,4) AND
KKM>REF(KKM,1),'有防御能力');
EXPLAIN(KKM<EMA(KKM,4) AND
KKM<REF(KKM,1),'风险较大');
R:=REF(CLOSE,1)/CLOSE;
QY:=VOL;
QTT:=QY*R;
TL:=FILTER(VOL=HHV(VOL,20),20);
DL:=FILTER(VOL=LLV(VOL,20),20);
XD:=FILTER(LOW=LLV(LOW,20),20);
XG:=FILTER(HIGH=HHV(HIGH,20),20);
AQ标准攻击量:=QTT*1.15;
HQ危险成交量:=QTT*1.5;
LQ防守量:=QTT*0.75;
AHQ平均高量:=(AQ标准攻击量+HQ危险成交量)/2;
ALQ平均低量:=(AQ标准攻击量+LQ防守量)/2;
市场实际量能:=QY;
EXPLAINEX(HQ危险成交量,'解盘:次日攻击危险量=',HQ危险成交量,0,0),colorFF;
EXPLAINEX(AQ标准攻击量,'解盘:次日攻击标准量=',AQ标准攻击量,0,0),coloryellow;
EXPLAINEX(LQ防守量,'解盘:次日攻击防守量=',LQ防守量,0,0),colorFF00;
EXPLAINEX(TL,'解盘:今日为20日最大量=',VOL,0,0),colorFF;
EXPLAINEX(DL,'解盘:今日为20日最小量=',VOL,0,0),colorFF00;
EXPLAINEX(XD,'解盘:今日为20日最低价格=',LOW,2,0),colorFF00;
EXPLAINEX(XG,'解盘:今日为20日最高价格=',LOW,2,0),colorFF;
PT:=REF(HIGH,1)-REF(LOW,1);
CDP:=(HIGH+LOW+2*CLOSE)/4;
AH:=CDP+PT;
AL:=CDP-PT;
NH敏感阻力:=2*CDP-LOW;
NL:=2*CDP-HIGH;
EXPLAINEX(AH,'解盘:次日重大阻力价位=',AH,2,0),colorFF00;
EXPLAINEX(NH敏感阻力,'解盘:次日敏感阻力区域=',NH敏感阻力,2,0),colorFFFF;
EXPLAINEX(CDP,'解盘:次日关键均衡价位=',CDP,2,0),colorFFFFFF;
EXPLAINEX(NL,'解盘:次日重要支撑区域=',NL,2,0),colorFFFF80;
EXPLAINEX(AL,'解盘:次日关键支撑价位=',AL,2,0),colorFF;
EXPLAINICON(CLOSE>0,'szczxh'),ALIGN1;
VAR0:=REF(CLOSE,1)-REF(OPEN,1);
VAR1:=REF(OPEN,1);
VAR2:=CLOSE>=VAR1*1.05;
VAR3:=CLOSE>=2*VAR0/3*VAR1
AND
CLOSE<=VAR1*1.05;
VAR4:=CLOSE<VAR0*2/3*VAR1;
EXPLAINEX(VAR2,'解盘:个股目前态势:超级强势。涨幅
%f
%',(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100,1,0),colorFF00FF;
EXPLAINEX(VAR3,'解盘:个股目前态势:强势。涨幅
%f
%',(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100,1,0),colorFF;
EXPLAINEX(VAR4,'解盘:个股目前态势:弱势。涨幅
%f
%',(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100,1,0),colorFF00;
B1:=(CLOSE-MA(CLOSE,30))/MA(CLOSE,30)*100<-12;
B3:=(CLOSE-MA(CLOSE,30))/MA(CLOSE,30)*100>15;
B:=(CLOSE-MA(CLOSE,30))/MA(CLOSE,30)*100;
EXPLAINEX(B<-18
AND
CLOSE/OPEN>1.06,'解盘:抢反弹!负乖离偏大,小单进场。此刻30日乖离率=',B,2,1),colorFF;
EXPLAINEX(B>40
AND
CLOSE/REF(CLOSE,1)<1.08,'解盘:高抛!正乖离偏大,按照短线技术系统高抛:',B,2,0),colorFF00;
EXPLAINEX(NOT(B<-18
AND CLOSE/OPEN>1.06) OR NOT(B>40 AND
CLOSE/REF(CLOSE,1)<1.08),'解盘:此刻30日乖离率=',B,2,0),colorFFFF;}
{阳线上下影}
STICKLINE(CLOSE>=OPEN,C,H,0,0),
colorRED;
STICKLINE(CLOSE>=OPEN,O,L,0,0),
colorRED;
{阴线上下影}
STICKLINE(CLOSE<OPEN,O,H,0,0),
Color00EC00;
STICKLINE(CLOSE<OPEN,C,L,0,0),
Color00EC00;
{阳K线}
STICKLINE(CLOSE>=OPEN,C,O,8,0),Color0000A1;
STICKLINE(CLOSE>=OPEN,C,O,6,0),Color0000B5;
STICKLINE(CLOSE>=OPEN,C,O,5,0),Color0000C5;
STICKLINE(CLOSE>=OPEN,C,O,4,0),Color0000D4;
STICKLINE(CLOSE>=OPEN,C,O,2.5,0),Color0000EC;
STICKLINE(CLOSE>=OPEN,C,O,1,0),Color0000FF;
{阴K线}
STICKLINE(CLOSE<OPEN,C,O,8,0),Color009000;
STICKLINE(CLOSE<OPEN,C,O,7,0),Color00B400;
STICKLINE(CLOSE<OPEN,C,O,5,0),Color00C700;
STICKLINE(CLOSE<OPEN,C,O,3,0),Color00DB00;
STICKLINE(CLOSE<OPEN,C,O,1,0),Color00EC00;
LC:=REF(CLOSE,1);
RSI:=((SMA(MAX(CLOSE
- LC,0),6,1))/(SMA(ABS(CLOSE -
LC),6,1)))*(100);
DRAWTEXT(CROSS(82,RSI),HIGH,' 顶'),COlorffcc66;
DRAWTEXT(CROSS(63,RSI),HIGH,' 卖'),COlorffcc66;
Y1:=REF(EMA(DMA((((HIGH + LOW) + (CLOSE * 2)) /
4.15),0.9),3),1);
DRAWtext(CROSS(CLOSE,Y1),LOW,'买'),Coloryellow;

大智慧优化阴阳主图指标公式

 

相关文章