在线检测未来函数

飞狐阳光力道指标公式

来源:Internet,编辑:股旁网,2014-07-11

N:=4;
P:=25;
LOCK:=IF(CURRENTDATE<1290901,1,0);
龙凤吉祥Z:=(CLOSE-MA(CLOSE,25))/MA(CLOSE,25)*100;
【海平面】:=IF(龙凤吉祥Z<=0,龙凤吉祥Z,18);
A:=SUM((2*(CLOSE-CLOSE*0.2)+OPEN-OPEN*0.2+HIGH-HIGH*0.2+LOW-LOW*0.2)/5*VOL,8)/SUM(VOL,8);
B:=LLV(A,N);
多空线:=A;
EA:=LLV(LOW,P);
新长征之路1A:=EMA(多空线,4.5)*LOCK;
新长征之路5A:=EMA(多空线,14.5)*LOCK;
新长征之路12A:=EMA(多空线,89)*LOCK;
新长征之路1:=EMA(多空线,4.5)*LOCK;
新长征之路5:=EMA(多空线,14.5);
新长征之路12:=EMA(多空线,89);
MACD新概念10:=-(新长征之路12-新长征之路1)*B/新长征之路1;
MACD新概念7:=-(新长征之路12-新长征之路5)*EA/新长征之路5;
個W:=EMA(MACD新概念7,3);
十W:=EMA(MACD新概念7,5);
百W:=EMA(MACD新概念7,7);
千W:=EMA(MACD新概念7,9);
PARTLINE(個W<REF(個W,1),個W),POINTDOT,color996633;
FILLRGN(十W>百W,十W,百W),colorBB;
FILLRGN(個W>十W,個W,十W),colorCC;
MACD新概念9A:=(新长征之路12A-新长征之路1A)*EA/新长征之路1A;
MACD新概念11A:=(新长征之路12A-新长征之路5A)*EA/新长征之路5A;
個1:=EMA(MACD新概念11A,3);
十1:=EMA(MACD新概念11A,5);
百1:=EMA(MACD新概念11A,7);
千1:=EMA(MACD新概念11A,7);
PARTLINE(個1>REF(個1,1),個1),POINTDOT,colorFFAA11;
FILLRGN(十1<百1,十1,百1),colorFF99FF;
FILLRGN(個1<十1,個1,十1),colorFF55FF;
天:-(新长征之路12-新长征之路1)*EA/新长征之路1,LINETHICK0,colorFF;
意:(新长征之路12A-新长征之路1A)*EA/新长征之路1A,LINETHICK0,colorFF00;
DRAWSL(BARPOS=SYSPARAM(1),意,0,天-1,1),POINTDOT,LINETHICK1,colorFF0000;
DRAWSL(BARPOS=SYSPARAM(1),天,0,天-1,1),POINTDOT,LINETHICK1,colorFF;
SA:=SUM(CROSS(【海平面】,個1),0);
SSAA:=SA[DATACOUNT]-SA+1;
拐点标识器:=BARSSINCE(BACKSET(SSAA=1,個1));
EA:=BARSSINCE(BACKSET(SSAA=MACD新概念9A,個1));
VERTLINE(拐点标识器=0),POINTDOT,colorFFFF00;
VERTLINE(EA=1);
STICKLINE(【海平面】>0,0*0.005,0*0.15,3,0.1),colorFFFF;
STICKLINE(【海平面】>0,0*0.015,0*0.075,3,0.1),colorFF;
STICKLINE(【海平面】<0,0*0.005,0*0.315,3,0.1),colorFFFF00;
DRAWSL(SYSPARAM(6)<=天[SYSPARAM(1)] AND BARPOS=SYSPARAM(1),天,0,0,0),colorFF;
STICKLINE(天<0,天*0.005,天-天*0.15,3,0.1),POINTDOT,color996633;
STICKLINE(天<個W,天-個W*0.005,天-個W*0.15,3,0.1),colorFF00;
STICKLINE(天>個W,天-個W*0.005,天-個W*0.15,3,0.1),colorCCFF;
STICKLINE(意>個1,個1*0.005,個1*0.15,3,0.1),POINTDOT,colorFFFFFF;
STICKLINE(意<個1,意-個1*0.005,意-個1*0.15,3,0.1),colorFF;
STICKLINE(意>0,個W*0.005,意*0.15,3,0.1),POINTDOT,colorFF00;
STICKLINE(意>個1,意-個1*0.005,意-個1*0.15,3,0.1),colorBBBBBB;
DRAWTEXT(SYSPARAM(1)=BARPOS AND 意 AND 意>個1 AND 個1>0,意,'=趋势服从='),ALIGN0,PXUP28,colorFF0000;
DRAWTEXT(SYSPARAM(1)=BARPOS AND 天 AND 天>0.04 AND 個W>十W,天,'=服从趋势='),ALIGN0,PXUP25,colorFF;
DRAWTEXT(SYSPARAM(1)=BARPOS AND 意 AND 意<0.04 AND 個1<十1,意,'=知天明意='),ALIGN2,PXUP25,colorFFFF;
DRAWTEXT(SYSPARAM(1)=BARPOS AND 意 AND 意>個1 AND 個1>十1,意,'=知天明意=\n=轮回因缘='),ALIGN1,PXDN10,colorFFA900;
DRAWTEXT(SYSPARAM(1)=BARPOS AND 意 AND 意<個1 AND 十1<個1,意,'=天明='),ALIGN1,PXDN10,colorFFA9DD;
DRAWTEXT(SYSPARAM(1)=BARPOS AND 意 AND 意>0 AND 個1>十1,個W,'=服从安排=\n=因果注定='),ALIGN1,PXDN10,colorFFFFFF;
DRAWTEXT(BARPOS=SYSPARAM(2),0,' \n知天'),ALIGN4,PXDN3,colorCCFF;
DRAWTEXT(BARPOS=SYSPARAM(2),0,' \n \n明意'),ALIGN4,PXDN6,colorBB;
DRAWTEXT(BARPOS=SYSPARAM(2),0,' \n \n \n服从'),ALIGN4,PXDN9,colorFF00;
DRAWTEXT(BARPOS=SYSPARAM(2),0,' \n \n \n \n安排'),ALIGN4,PXDN12,colorFFA900;

飞狐阳光力道指标公式

 

相关文章