在线检测未来函数

飞狐光芒空间主图指标公式

来源:Internet,编辑:股旁网,2014-07-18

AC:=C;
AH:=H;
AL:=L;
AO:=O;
STICKLINE(AC>=AO,AH,AC,1,0),colorblue;
STICKLINE(AC>=AO,Ao,Al,1,0),colorblue;
STICKLINE(AC>=AO,AO,Ac,8,1),colorblue;
STICKLINE(AC<=AO,AO,Ac,8,0),colorblue;
STICKLINE(AC<=AO,Ah,Ao,1,0),colorblue;
STICKLINE(AC<=AO,AO,Al,1,0),colorblue;
Var2:=EMA(SLOPE(EMA(CLOSE,20),10)*34+CLOSE,30);
Var3:=EMA(Var2,3);
Var4:=EMA(Var3,3);
Var5:=EMA(Var4,3);
Var6:=EMA(Var5,3);
Va7:=EMA(Var6,3);
VAR7:=EMA(Va7,3);
VA8:=EMA(VAR7,3);
Var8:=EMA(VA8,3);
Var9:=EMA(Var8,3);
VarA:=BARSLAST(CROSS(CLOSE,Var9));
VarB:=BARSLAST(CROSS(Var9,CLOSE));
卷帘操作: STICKLINE(CLOSE>Var9 AND CLOSE>REF(CLOSE,VarA),REF(CLOSE,VarA),LOW*1,00,1),Color0000B0,linethick0;
强: STICKLINE(CLOSE<Var9 AND CLOSE<REF(CLOSE,VarB),REF(CLOSE,VarB),HIGH*1.00,0,1),Color00B000,linethick0;
势: STICKLINE(CLOSE>Var9 AND CLOSE<REF(CLOSE,VarA),REF(CLOSE,VarA),LOW*1.02,0,1),linethick0;
冷: STICKLINE(CLOSE>Var9 AND CLOSE<REF(CLOSE,VarA),REF(CLOSE,VarA),REF(CLOSE,VarA),6,1),COLORGREEN,linethick0;
沉: STICKLINE(CLOSE<Var9,REF(CLOSE,VarB),REF(CLOSE,VarB),16,0),ColorB3B3B3,linethick2;
Var10:STICKLINE(CLOSE>Var9,REF(CLOSE,VarA),REF(CLOSE,VarA),16,0),COLORBLUE,linethick2;
x5:HHV((REF(CLOSE,1)+REF(CLOSE,2)+REF(CLOSE,3)+REF(CLOSE,4))/4.00,5),COLORGREEN;
x10:HHV((REF(CLOSE,2)+REF(CLOSE,3)+REF(CLOSE,4)+REF(CLOSE,5))/4.00,10),COLORyellow;
x20:HHV((REF(CLOSE,3)+REF(CLOSE,4)+REF(CLOSE,5)+REF(CLOSE,6))/4,20),COLORMAGENTA;
DRAWTEXT(sysparam(2)=BARPOS,c,' '+BLKNAME),COLORccffcc,ALIGN4;//板块
次买:=O+(c-O)/2 ,LINETHICK2,POINTDOT,SHIFT1;
次卖:=C+(O-C)/2 ,COLORRED,POINTDOT,LINETHICK2,SHIFT1;
上涨空间预测:=C+((H-L)/2)*2 ,POINTDOT,LINETHICK2,SHIFT1;;
下跌空间预测:=c-((h-l)/2)*2 ,POINTDOT,LINETHICK2,SHIFT1;;
PARTLINE(次买 AND ISLASTBAR=1,次买),SHIFT1,pointdot,colorDDDDDD;
PARTLINE(上涨空间预测 AND ISLASTBAR=1,上涨空间预测),SHIFT1,pointdot,ColorDDDDDD;
PARTLINE(下跌空间预测 AND ISLASTBAR=1,下跌空间预测),SHIFT1,pointdot,colorDDDDDD;
次1:=C*2-ma(ref(C,3),3){ref(C,3)};
次2:=ref(C,1)*2-ma(ref(C,4),4){ref(C,4)};
次3:=ref(C,2)*2-ma(ref(C,5),5){ref(C,5)};
PARTLINE(C*2-ma(ref(C,3),3)AND ISLASTBAR=1,次1),shift3,coloryellow,linethick1,pointdot;
PARTLINE(ref(C,1)*2-ma(ref(C,4),4)AND ISLASTBAR=1,次2),shift2,coloryellow,linethick1,pointdot;
PARTLINE(ref(C,2)*2-ma(ref(C,5),5)AND ISLASTBAR=1,次3),shift1,coloryellow,linethick1,pointdot;
a1:=cost(95);
a2:=cost(5);
ly:=(a1-a2)*100/(a1+a2);
drawicon(ly>ref(ly,1), l*0.98,8)ALIGN5;
VAR3:=IF((CLOSE>REF(CLOSE,1)),88,0);
VAR4:=IF(((CLOSE)/(REF(CLOSE,1))>1.03) AND ((HIGH)/(CLOSE)<1.01) AND (VAR3>0),91,0);
DRAWTEXT((VAR4>90),(LOW)*(0.94999998),'★加仓'),Colorblue;
DRAWTEXT((VAR4>90),(LOW)*(0.99000001),'★'),Colorblue;
Var1:=(HIGH+LOW+OPEN+2*CLOSE)/5;
Var2:=REF(Var1,1);
Var3:=SMA(MAX(Var1-Var2,0),10,1)/SMA(ABS(Var1-Var2),10,1)*100;
HY3:=IF(COUNT(Var3<20,5)>=1 AND COUNT(Var1=LLV(Var1,10),10)>=1 AND CLOSE>=OPEN*1.038 AND VOL>MA(VOL,5)*1.2,1,0);
DRAWTEXT(hy3,LOW,'▲买入'),colorred;
Varr1:=SMA(MAX(CLOSE-REF(CLOSE,1),0),6,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),6,1)*100;
DRAWICON(CROSS(82,Varr1),HIGH,2);
DRAWTEXT(CROSS(82,Varr1),HIGH,'▲风险↓'),colorgreen;
EL1:=EMA(LOW,6);
EL2:=EMA(EMA(LOW,34)*1,02)-0.16;
DRAWICON(CROSS(EL1,EL2),EL1,10);
V1:=REF(C,1);
V2:=SMA(MAX(C-V1,0),6,1)/SMA(ABS(C-V1),6,1)*100;
DRAWICON(IF(CROSS(81,V2),1,0),h*1.01,11);
k:=(SYSPARAM(5)-SYSPARAM(4))/(SYSPARAM(2)-SYSPARAM(3));
a:=HHV(H,1);
n:=a/2;
DRAWSL(barpos=SYSPARAM(1),n,-20*k/120,0,0),LINEDOT,COLOR666600;
DRAWSL(barpos=SYSPARAM(1),n,-40*k/120,0,0),LINEDOT,COLOR666600;
DRAWSL(barpos=SYSPARAM(1),n,-70*k/120,0,0),LINEDOT,COLORMAGENTA;
DRAWSL(barpos=SYSPARAM(1),n,-150*k/120,0,0),LINEDOT,COLORMAGENTA;
DRAWSL(barpos=SYSPARAM(1),n,-350*k/120,0,0),LINEDOT,COLORMAGENTA;
DRAWSL(barpos=SYSPARAM(1),n,k/120,0,0),LINEDOT,COLORBLUE;
DRAWSL(barpos=SYSPARAM(1),n,20*k/120,0,0),LINEDOT,COLOR666600;
DRAWSL(barpos=SYSPARAM(1),n,40*k/120,0,0),LINEDOT,COLOR666600;
DRAWSL(barpos=SYSPARAM(1),n,70*k/120,0,0),LINEDOT,COLORMAGENTA;
DRAWSL(barpos=SYSPARAM(1),n,150*k/120,0,0),LINEDOT,COLORMAGENTA;
DRAWSL(barpos=SYSPARAM(1),n,350*k/120,0,0),LINEDOT,COLORMAGENTA;
DRAWSL(barpos=SYSPARAM(1),n,12000*k/-1,0,0),LINEDOT,COLORMAGENTA;
DRAWSL(barpos=SYSPARAM(1),n,12000*k/1,0,0),LINEDOT,COLORMAGENTA;
DRAWSL(barpos=SYSPARAM(1),n,-30*k/180,0,1),LINEDOT,COLOR666600;
DRAWSL(barpos=SYSPARAM(1),n,-60*k/180,0,1),LINEDOT,COLOR666600;
DRAWSL(barpos=SYSPARAM(1),n,-120*k/180,0,1),LINEDOT,COLORMAGENTA;
DRAWSL(barpos=SYSPARAM(1),n,-250*k/180,0,1),LINEDOT,COLORMAGENTA;
DRAWSL(barpos=SYSPARAM(1),n,-500*k/180,0,1),LINEDOT,COLORMAGENTA;
DRAWSL(barpos=SYSPARAM(1),n,30*k/180,0,1),LINEDOT,COLOR666600;
DRAWSL(barpos=SYSPARAM(1),n,60*k/180,0,1),LINEDOT,COLOR666600;
DRAWSL(barpos=SYSPARAM(1),n,120*k/180,0,1),LINEDOT,COLORMAGENTA;
DRAWSL(barpos=SYSPARAM(1),n,250*k/180,0,1),LINEDOT,COLORMAGENTA;
DRAWSL(barpos=SYSPARAM(1),n,500*k/180,0,1),LINEDOT,COLORMAGENTA;
DRAWSL(barpos=SYSPARAM(1),n,k/180,0,1),LINEDOT,COLORBLUE;
DRAWNUMBER(BARSCOUNT(C)=SYSPARAM(1),c,H,2),COLORCYAN,ALIGN1;
 

飞狐光芒空间主图指标公式

 

相关文章