在线检测未来函数

同花顺假阴真阳倍量柱指标公式

来源:Internet,编辑:股旁网,2014-07-20

DRAWTEXT_FIX(CURRBARSCOUNT=60,0.02,0.01,0,'====★flowers fairy Beautiful legend★===='),colorwhite;
DRAWTEXT_FIX(CURRBARSCOUNT=60,0.4,0.01,0,'====★☆QQ:1853609925☆花仙女★★===='),colorred;
n=10;
HSL0:=100*VOL/(FINANCE(7)/100),VOLSTICK;
HSL:100*VOL/(FINANCE(7)/100),VOLSTICK;
换手:100*VOL/(FINANCE(7)/100),NODRAW;
换手5日:MA(换手,5),NODRAW;
换手10日:MA(换手,10),NODRAW;
换手20日:MA(换手,20),NODRAW;
VOLUME:VOL,VOLSTICK;
g:COUNT(CLOSE>REF(CLOSE,1),2)=2 AND COUNT(VOL<REF(VOL,1),2)=2;
STICKLINE(g,0,V,1,0),colorgreen;
DRAWTEXT(g,VOL+3000,'降'),colorgreen;
M:=IF(N=1,IF(MOD(FROMOPEN,1)=0,1,
MOD(FROMOPEN,1)),IF(N=5,IF(MOD(FROMOPEN,5)=0,5,
MOD(FROMOPEN,5)),IF(N=15,IF(MOD(FROMOPEN,15)=0,15,
MOD(FROMOPEN,15)),IF(N=30,IF(MOD(FROMOPEN,30)=0,30,
MOD(FROMOPEN,30)),IF(N=60,IF(MOD(FROMOPEN,60)=0,60,
MOD(FROMOPEN,60)),IF(N=240,FROMOPEN,DRAWNULL))))));
虚量:IF(CURRBARSCOUNT=1,V*N/M,DRAWNULL),NODRAW,colorwhite;
启5:=MA(V,5),colorwhite,LINETHICK1;
洗35:=MA(V,35),coloryellow,LINETHICK1;
异135:=MA(V,135),colormagenta,LINETHICK1;
股价:VOL,VOLSTICK;
短3:XMA(XMA(股价,3),3),LINETHICK0,colorwhite;
短5:XMA(XMA(股价,5),5),LINETHICK0,colorwhite;
短6:XMA(XMA(股价,6),6),LINETHICK0,colorwhite;
短中2:(短3+短5+短6)/3,LINETHICK0,coloryellow;
短底2:短中2*0.7,LINETHICK0,colorwhite;
短7:XMA(XMA(股价,8),8),LINETHICK0,colorwhite;
短8:XMA(XMA(股价,10),10),LINETHICK0,colorwhite;
短9:XMA(XMA(股价,12),12),LINETHICK0,colorwhite;
短中3:(短7+短8+短9)/3,LINETHICK0,colorwhite;
短顶3:短中3*1.3,LINETHICK0,colorgreen;
短底3:短中3*0.7,LINETHICK0,colorgreen;
中1:XMA(XMA(股价,16),16),LINETHICK0,colorwhite;
中2:XMA(XMA(股价,19),19),LINETHICK0,colorwhite;
中3:XMA(XMA(股价,22),22),LINETHICK0,colorwhite;
中4:XMA(XMA(股价,25),25),LINETHICK0,colorwhite;
中5:XMA(XMA(股价,28),28),LINETHICK0,colorwhite;
中6:XMA(XMA(股价,31),31),LINETHICK0,colorwhite;
中中2:(中1+中2+中3+中4+中5+中6)/6,LINETHICK0,colorgreen;
中顶2:中中2*1.4,LINETHICK0,colorgreen;
中底2:中中2*0.6,LINETHICK0,colorgreen;
VOLUME:VOL,VOLSTICK;
g:COUNT(CLOSE>REF(CLOSE,1),2)=2 AND COUNT(VOL<REF(VOL,1),2)=2;
STICKLINE(g,0,V,1,0),colorgreen;
DRAWTEXT(g,VOL+6000,'降'),colorgreen;
预定黄金柱: DRAWICON(REF(V,2)>=REF(V,3)*1.99 AND REF(C,2)>REF(O,2) AND
REF(V,2)=HHV(V,3) AND C/REF(C,2) >=1.0995 AND REF(L,2)=LLV(L,3),V,1);
AA:=VOL>=REF(V,1)*1.91 AND C>REF(C,1);
STICKLINE(AA,0,V,3,0),coloryellow;
T:=DYNAINFO(8)>0;
VO:VOL=LLV(VOL,100) AND T;
地量柱:T AND VO,colorblue;
STICKLINE(地量柱,0,V,1,0),colorblue;
DRAWTEXT(地量柱,VOL+25000,'地'),colormagenta;
BLZ:=VOL>REF(V,1)*1.9;
BLZ1:=VOL<REF(LLV(VOL,13),1);
BLZ2:=VOL<REF(LLV(VOL,55),1);
STICKLINE(BLZ,0,V,1,0),coloryellow;
倍量柱:BLZ,coloryellow;
DRAWTEXT(倍量柱,VOL+20000,'倍'),coloryellow;
HJZ:=(3*C+H+L+O)/6;
HJZ2:=(8*HJZ+7*REF(HJZ,1)+6*REF(HJZ,2)+5*REF(HJZ,3)+4*REF(HJZ,4)+3*REF(HJZ,5)+2*REF(HJZ,6)+REF(HJZ,8))/36;
HJZ3:=VOL=HHV(VOL,10) AND VOL>2*REF(VOL,1) AND CLOSE>HJZ2 AND C>O;
黄金柱:FILTER(HJZ3,5),STICK,colorred,LINETHICK4;
STICKLINE(黄金柱,0,V,1,0),colorred;
DRAWTEXT(黄金柱,VOL+45000,'黄'),colorred;
价涨量缩:g,colorgreen;
FLZ:=V>REF(V,1)*0.98 AND V<REF(V,1)*1.02,LINETHICK0;
STICKLINE(FLZ,0,V,1,0),colormagenta;
DRAWTEXT(FLZ,VOL+4000,'平'),colormagenta;
平量柱:FLZ,colormagenta;
倍缩:V<=REF(V,1)*0.5,NODRAW,colorwhite;
STICKLINE(倍缩,0,V,1,0),colorwhite;
DRAWTEXT(倍缩,VOL+8000,'缩'),colorwhite;
短柱:=C/REF(C,1)<=0.96 AND V<HHV(V,30)/1.9;
DRAWTEXT(短柱 ,VOL+15000,'!短柱'),colorlicyan;
TJ:=C<O;
TJ1:=C>REF(C,1) AND TJ;
TJ2:=AMOUNT/V/100>REF(C,1) AND O>REF(C,1) AND NOT(TJ1) AND TJ;
STICKLINE(TJ1,VOL,0,-1,0),colormagenta;
STICKLINE(TJ2,VOL,0,-1,0),colorlired;
DRAWTEXT(TJ1,VOL+30000,'!假阴真阳'),colorred,LINETHICK9;
DRAWTEXT(TJ2,VOL+25000,'!假阴真阳'),coloryellow;

同花顺假阴真阳倍量柱指标公式

 

相关文章