在线检测未来函数

飞狐思思跟庄主图指标公式

来源:Internet,编辑:股旁网,2014-07-22

M:=21;
DRAWGBK(CLOSE=CLOSE,COLORRGB(1,100,125),COLORRGB(1,30,10),2);
drawtext(sysparam(2)=barpos,c,'\n买入标记:白柱\n小涨标记:绿柱\n暴涨标记:黄柱'),align4,colorwhite;
k2:=EMA(c,5),colorffff00;
k3:=EMA(c,10),colorffff00;
k5:=EMA(c,30),colorffff00;kk5:=EMA(indexc,30),colorffff00;
A10:=EMA(C,10);
k6:=2*(k2-k5);k7:=2*(k2-k3);k8:=2*(k7+k6),COLORRED;
VAR1:=(100 - ((90 * (HHV(HIGH,21) - CLOSE)) / (HHV(HIGH,21) - LLV(LOW,21))));
VAR2:=(100 - ((90 * (HHV(HIGH,21) - CLOSE)) / (HHV(HIGH,21) - LLV(LOW,21))));
VAR3:=(100 - MA(((100 * (HHV(HIGH,6) - CLOSE)) / (HHV(HIGH,6) - LLV(LOW,6))),34));
年:MA(CLOSE,26),COLORGREEN,linethick0;
箱底:LLV(MA((LOW),5),m),pointDOT,colorGREEN,linethick1;
长箱底:LLV(MA((LOW),5),60),pointDOT,linethick0;
长长箱底:LLV(MA((LOW),5),100),pointDOT,coloryellow,linethick0;
长长箱顶:HHV(MA((HIGH),6),120),pointDOT,linethick0;
长箱顶:HHV(MA((HIGH),6),60),colorred,linethick1;
箱顶:HHV(MA((HIGH),6),m),color00aaff,linethick1;
中间:(箱顶+箱底)/2,COLORCYAN,linethick3;
wx:EMA(c,5),colorwhite,linethick2;
STICKLINE(CROSS(wx,中间),中间-0.8,中间+0.8,8,0) ,colorwhite;
STICKLINE(CROSS(wx,长箱顶),长箱顶-0.8,长箱顶+0.8,10,0) ,coloryellow,linethick2;
STICKLINE(CROSS(wx,箱顶),箱顶-0.5,箱顶+0.5,10,0) ,colorgreen;
启动线:EMA(c,2),colormagenta,linethick2;
STICKLINE(wx<中间,wx,中间,0.01,1),COLORCYAN,POINTDOT;
STICKLINE(wx>中间,wx,中间,0.01,1),COLORMAGENTA,POINTDOT;
STICKLINE(CLOSE>OPEN or CLOSE=OPEN and CLOSE>REF(CLOSE,1),LOW,HIGH,0.1,0),colorred;
STICKLINE(CLOSE>OPEN or CLOSE=OPEN and CLOSE>REF(CLOSE,1),OPEN,CLOSE,7,0),colorred;
STICKLINE(CLOSE<OPEN or CLOSE=OPEN and CLOSE<=REF(CLOSE,1),LOW,HIGH,0.1,0),colorcyan;
STICKLINE(CLOSE<OPEN or CLOSE=OPEN and CLOSE<=REF(CLOSE,1),OPEN,CLOSE,7,0),colorcyan;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,0,0 ),COLOR00FF00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,8,0 ),COLOR008800;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,7,0 ),COLOR009900;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,6,0 ),COLOR00AA00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,5,0 ),COLOR00BB00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,4,0 ),COLOR00CC00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,3,0 ),COLOR00DD00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,2,0 ),COLOR00EE00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,1,0 ),COLOR00FF00;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,0,0) ,COLORFFBBFF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,8,0) ,COLORFF00FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,7,0) ,COLORFF22FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,6,0) ,COLORFF44FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,5,0) ,COLORFF66FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,4,0) ,COLORFF88FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,3,0) ,COLORFF99FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2,0) ,COLORFFAAFF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1,0) ,COLORFFBBFF;

飞狐思思跟庄主图指标公式

 

相关文章