在线检测未来函数

通达信超宏成交量指标公式

来源:Internet,编辑:股旁网,2014-07-24

DRAWGBK(C>0,RGB(48,48,8),RGB(48,48,8),0,'8',0);
VOLUME:VOL,NODRAW;
VA8:=IF(CLOSE>REF(CLOSE,1),VOL,-VOL);
OBV18:=SUM(IF(CLOSE=REF(CLOSE,1),0,VA8),0);
OBV28:=EMA(OBV18,3)-MA(OBV18,9);
OBV38:=EMA(IF(OBV28>0,OBV28,0),3);
MAC38:=MA(C,3);
QS:=OBV38>REF(OBV38,1) AND MAC38>REF(MAC38,1);
STICKLINE(QS,0,V,3.5,0),COLORYELLOW;
吸:=XLPL.NOTEXT吸,COLORLIRED,CIRCLEDOT,LINETHICK3,NODRAW;
拉:=XLPL.NOTEXT拉,COLORRED,CIRCLEDOT,LINETHICK3,NODRAW;
派:=XLPL.NOTEXT派,COLORGREEN,CIRCLEDOT,LINETHICK3,NODRAW;
落:=XLPL.NOTEXT落,COLORWHITE,CIRCLEDOT,LINETHICK3,NODRAW;
STICKLINE(吸,0,V,2,0),COLORMAGENTA;
STICKLINE(拉,0,V,2,0),COLORRED;
STICKLINE(派,0,V,2,0),COLORGREEN;
STICKLINE(落,0,V,2,0),COLORGRAY;
QSLS:=QS AND 拉 AND 拉!=派;
STICKLINE(QSLS,0,V,2,0),COLORRED;
{量能潮}
VA:=IF(CLOSE>REF(CLOSE,1),VOL,-VOL);
OBV1:=SUM(IF(CLOSE=REF(CLOSE,1),0,VA),0);
OBV2:=EMA(OBV1,3)-MA(OBV1,9);
OBV3:=EMA(IF(OBV2>0,OBV2,0),3);
MAC3:=MA(C,3);
量能潮:OBV3,NODRAW,COLORBROWN;
STICKLINE(OBV3>REF(OBV3,1) AND MAC3>REF(MAC3,1),0,OBV3,0.1,0),COLORBROWN;
{135均线}
V5:MA(VOL,5),COLORWHITE;
V35:MA(VOL,35);
V135:MA(VOL,135);
FL4:=V=HHV(V,250);
FL3:=V=HHV(V,120) AND V!=HHV(V,250);
FL2:=V=HHV(V,60) AND V!=HHV(V,120) AND V!=HHV(V,250);
FL1:=V=HHV(V,30) AND V!=HHV(V,60) AND V!=HHV(V,120) AND V!=HHV(V,250);
DRAWTEXT(FL4,V*1.18,'④'),COLORLIGRAY;
DRAWTEXT(FL3,V*1.18,'③'),COLORLIGRAY;
DRAWTEXT(FL2,V*1.18,'②'),COLORLIGRAY;
DRAWTEXT(FL1,V*1.18,'①'),COLORLIGRAY;

通达信超宏成交量指标公式

 

相关文章