在线检测未来函数

通达信组合分时指标公式

来源:Internet,编辑:股旁网,2014-07-25

N:=20;
M:=40;
DRAWGBK(C>0, RGB(0,10,10),RGB(48,0,0),0,'11',0);
VAR1:=((CLOSE - LLV(LOW,50))/(HHV(HIGH,50) - LLV(LOW,50)))*(100);
VAR2:=REVERSE(VAR1);
VAR3:=SMA(VAR1,6,1);
K:=SMA(VAR3,4,1);
D:=SMA(K,4,1);
STICKLINE((K >= D),K,D,6,0),COLOR0000A8;
STICKLINE((K >= D),K,D,5,0),COLOR0000C0;
STICKLINE((K >= D),K,D,4,0),COLOR0000E0;
STICKLINE((K >= D),K,D,3,0),COLOR0000F0;
STICKLINE((K >= D),K,D,2,0),COLOR0000D0;
STICKLINE((K >= D),K,D,1,0),COLOR8080FF;
STICKLINE((K <= D),K,D,6,0),COLOR008800;
STICKLINE((K <= D),K,D,5,0),COLOR009900;
STICKLINE((K <= D),K,D,4,0),COLOR00AA00;
STICKLINE((K <= D),K,D,3,0),COLOR00BB00;
STICKLINE((K <= D),K,D,2,0),COLOR00CC00;
STICKLINE((K <= D),K,D,1,0),COLOR00DD00;
顶:90;
底:10;
敢死队:= (EXPMA(CLOSE,500)-REF(EXPMA(CLOSE,500),1))/REF(EXPMA(CLOSE,500),1)*100, COLORSTICK;
主力:=EXPMA( (EXPMA(CLOSE,500)-REF(EXPMA(CLOSE,500),1))/REF(EXPMA(CLOSE,500),1)*100,120)-0.0004,LINETHICK2,COLORMAGENTA;
散户:=EXPMA( (EXPMA(CLOSE,500)-REF(EXPMA(CLOSE,500),1))/REF(EXPMA(CLOSE,500),1)*100,200),LINETHICK2,COLORGREEN;
DRAWICON(CROSS(EXPMA(敢死队,120)-0.0004,EXPMA(敢死队,200)),45,11);
DRAWTEXT(CROSS(EXPMA(敢死队,120)-0.0004,EXPMA(敢死队,200)),40,'敢死队'),COLORRED;
A11:=(DVOL/CLOSE)/2;
A21:=SUM(IF(A11>100 AND CLOSE>REF(CLOSE,1),A11,0),0);
A31:=SUM(IF(A11>100 AND CLOSE<REF(CLOSE,1),A11,0),0);
A41:=SUM(IF(A11<100 AND CLOSE>REF(CLOSE,1),A11,0),0);
A51:=SUM(IF(A11<100 AND CLOSE<REF(CLOSE,1),A11,0),0);
A61:=A21+A31+A41+A51;
机买:=(A21/A61)*100,LINETHICK2,COLORRED;
机卖:=(A31/A61)*100,LINETHICK2,COLORGREEN;
机买红:A21/100000,LINETHICK1, COLORRED;
机卖绿:A31/100000,LINETHICK1,COLORGREEN;
机净买粉:机买红-机卖绿;
散户买:=A41/10000,COLORMAGENTA;
散户卖:=A51/10000,COLORWHITE;
散净买:=散户买-散户卖;
DRAWTEXT(ISLASTBAR=1,机买红*0.9,''),LINETHICK2,COLORFF55FF;
DRAWTEXT(ISLASTBAR=1,机卖绿,''),LINETHICK2,COLORFFFF55;
DRAWTEXT(ISLASTBAR=1,散户买,''),LINETHICK2,COLOR5555FF;
DRAWTEXT(ISLASTBAR=1,散户卖,''),LINETHICK2,COLOR55FF55;
中线白:0.00,COLORWHITE;
DRAWICON(CROSS(机买,机卖),70,24);
DRAWTEXT(CROSS(机买,机卖),75,'机转多'),COLORRED;
机构买盘:=A21,LINETHICK3, COLORRED;
机构卖盘:=A31,LINETHICK3,COLORGREEN;
TH:=SUM(IF(CLOSE>REF(CLOSE,1),VOL,0),N);
TL:=SUM(IF(CLOSE<REF(CLOSE,1),VOL,0),N);
TQ:=SUM(IF(CLOSE=REF(CLOSE,1),VOL,0),N);
VR:=100*(TH*2+TQ)/(TL*2+TQ);
MAVR:=MA(VR,M);
B:=VR/MAVR;
XG:(机买/机卖>1.2 AND 散户买/散户卖<0.9)*50,LINETHICK2;
DRAWICON(XG=50,60,34);
BB:=机构买盘/机构卖盘;
BBB:=BB/REF(BB,1);
DRAWICON(BB/REF(BB,1)>1.05 AND BB>7 AND BBB/REF(BBB,1)>4,10,25);
DRAWICON(BB/REF(BB,1)>1.05 AND BB>7 AND BBB/REF(BBB,1)>4,20,26);
DRAWICON(BB/REF(BB,1)>1.05 AND BB>7 AND BBB/REF(BBB,1)>4,30,27);
DRAWICON(BB/REF(BB,1)>1.05 AND BB>7 AND BBB/REF(BBB,1)>4,40,28);
DRAWICON(BB/REF(BB,1)>1.05 AND BB>7 AND BBB/REF(BBB,1)>4,50,29);
DRAWICON(BB/REF(BB,1)>1.05 AND BB>7 AND BBB/REF(BBB,1)>4,60,1);
DRAWTEXT(BB/REF(BB,1)>1.05 AND BB>7 AND BBB/REF(BBB,1)>4,70,'买')COLORYELLOW;
DRAWTEXT(BB>120 AND BBB/REF(BBB,1)>4,80+BB,'全买')COLORYELLOW;
STICKLINE(BB>120 AND BBB/REF(BBB,1)>4,0,55,1,0)COLORRED;
A1:=SUM(IF(CLOSE>REF(CLOSE,1),VOL/CAPITAL*100,IF(CLOSE<REF(CLOSE,1),-VOL/CAPITAL*100,0)),0);
成交额:=V*C/100,NODRAW;{万元}
A2:=SUM((IF(((成交额/8>18) AND (CLOSE>(REF(CLOSE,1)))),成交额,0)),0);
A3:=SUM((IF(((成交额/8>18) AND (CLOSE<(REF(CLOSE,1)))),成交额,0)),0);
A4:=SUM((IF(((成交额/8<18) AND (CLOSE>(REF(CLOSE,1)))),成交额,0)),0);
A5:=SUM((IF(((成交额/8<18) AND (CLOSE<(REF(CLOSE,1)))),成交额,0)),0);
A6:=((A2+A3)+A4)+A5;
RATE:=A2/A6*100,COLORWHITE,LINETHICK1;
{换手限制}
VOLA:=SUM(VOL,4)/CAPITAL*100>0.22;
{开盘量限制}
HH1:=IF(CAPITAL>5000000 AND REF(V,3)/CAPITAL*100>0.45,0,1);
HH2:=IF(CAPITAL<5000000 AND CAPITAL>3000000 AND REF(V,3)/CAPITAL*100>0.6,0,1);
HH3:=IF(CAPITAL<3000000 AND CAPITAL>1000000 AND REF(V,3)/CAPITAL*100>0.75,0,1);
HH4:=IF(CAPITAL<1000000 AND REF(V,3)/CAPITAL*100>0.9,0,1);
SUMVOL:=HH1 AND HH2 AND HH3 AND HH4;
{开盘量幅限制}
MM3:=IF(REF(VOL,3)/REF(VOL,2)>3.5 OR (REF(VOL,3)/REF(VOL,2)>2.8
OR REF(V,3)/CAPITAL*100>0.09 AND REF(C,3)<DYNAINFO(4)),0,1);
MM4:=IF(REF(VOL,4)/REF(VOL,3)>3.5 OR (REF(VOL,4)/REF(VOL,3)>2.8 AND REF(C,4)<DYNAINFO(4)),0,1);
MM5:=IF(REF(VOL,5)/REF(VOL,4)>3.5 OR (REF(VOL,5)/REF(VOL,4)>2.8 AND REF(C,5)<DYNAINFO(4)),0,1);
NN3:=COUNT(RATE=100,3)=3 AND BARSCOUNT(FROMOPEN)=3 AND MM3;
NN4:=COUNT(RATE=100,3)=3 AND BARSCOUNT(FROMOPEN)=4 AND MM4;
NN5:=COUNT(RATE=100,3)=3 AND BARSCOUNT(FROMOPEN)=5 AND MM5;
{量形异常过滤}
量形限制:=IF(VOL/REF(HHV(VOL,3),1)>1.56 OR VOL/REF(VOL,1)>1.6 OR VOL/REF(VOL,1)<0.5 OR
REF(VOL,1)/REF(VOL,2)>1.8,0,1);
{综合限制}
NN:=(NN3 OR NN4 OR NN5) AND VOLA AND SUMVOL AND 量形限制;
DRAWICON(NN,90,1);
DRAWICON(NN,74,25);
DRAWICON(NN,58,26);
DRAWICON(NN,43,28);
DRAWICON(NN,27,29);
DRAWICON(NN,12,30);
100,LINETHICK0;
STICKLINE(BARSCOUNT(FROMOPEN)=0,100,0,1,1),COLORLIMAGENTA;
{STICKLINE(BARSCOUNT(FROMOPEN)=8,100,0,1,1),COLORLIMAGENTA;}
0,COLORYELLOW;
{DRAWTEXT_FIX(1,0.033,0.79,0,' 【伏击】'),COLORCYAN;}
{DRAWTEXT_FIX(1,0.033,0.65,0,' 【指数在EXPMA(7)上面可大胆狙击】'),COLORYELLOW;};
涨幅%:=DYNAINFO(14)*100,NODRAW;
SHOU:=IF(DATE<=1150520,1,0);
SHI:=BETWEEN((DCLOSE*SHOU)/(SUM(AMOUNT,BARSCOUNT((DCLOSE*SHOU)))/SUM(VOL*100,BARSCOUNT((DCLOSE*SHOU)))),1.05,0.95);
TOU:=IF(SHI=0,MA((DCLOSE*SHOU),BARSCOUNT((DCLOSE*SHOU))),(SUM(AMOUNT,BARSCOUNT((DCLOSE*SHOU)))/SUM(VOL*100,BARSCOUNT((DCLOSE*SHOU)))));
动力线:=EXPMA((DCLOSE/TOU),13),COLORFFFF00,LINETHICK1;
趋势线:=EXPMA((DCLOSE/TOU),88),COLOR0080FF,LINETHICK2;
NOTEXT1:=1.003,COLORLIGREEN,LINETHICK2;
NOTEXT2:=1.03,COLORLIRED,LINETHICK2;
IF(动力线>1.003,动力线,DRAWNULL),COLORMAGENTA;
IF(动力线>1.03,动力线,DRAWNULL),COLORRED;
DRAWICON(CROSS(动力线,1.03),15,13);
DRAWTEXT(CROSS(动力线,1.03),20,'板动力'),COLORYELLOW;
VAR18:=EMA(EMA(CLOSE,13),13);
控盘:=(VAR18-REF(VAR18,1))/REF(VAR18,1)*1000;
STICKLINE(控盘<0,控盘,0,1,1),COLOR00FF00;
STICKLINE(控盘>REF(控盘,1) AND 控盘<0,控盘,0,1,1),COLORFF00FF;
无庄控盘:=控盘<0;
STICKLINE(控盘>REF(控盘,1) AND 控盘>0,控盘,0,1,1),COLOR0000FF;
有庄控盘:=控盘>REF(控盘,1) AND 控盘>0;
VAR288:=100*WINNER(CLOSE*0.95);
STICKLINE(控盘<REF(控盘,1) AND 控盘>0,控盘,0,1,1),COLORFFFF00;
主力出货:=控盘<REF(控盘,1) AND 控盘>0;
STICKLINE(VAR288>50 AND COST(85)<CLOSE AND 控盘>0,控盘,0,1,1),COLOR00FFFF;
高度控盘: VAR288>50 AND COST(85)<CLOSE AND 控盘>0,COLOR00FFFF,LINETHICK2;
A10:=CROSS(控盘,0);
控盘B:FILTER(IF(A10,1,0),5)*0.5;
JJ:=DYNAINFO(11);
P:=55;S:=8;M1:=3;
财:(EMA(CLOSE,S)-EMA(CLOSE,P))*10,COLORRED,LINETHICK1;
神:EMA(财,M1),COLORGREEN,LINETHICK1;
DRAWBAND(财,RGB(255,0,0),神,RGB(0,100,50));
{股价与均线偏离买卖条件}
BTJ1:=(C-JJ)/JJ<-0.03;
BTJ11:=(C-JJ)/JJ<-0.03;
BTJ12:=LAST(JJ>=REF(JJ,1),5,1) AND (C-JJ)/JJ<0.005;
STJ1:=(C-JJ)/JJ>0.005;
{控盘买卖条件}
STJ01:=控盘<REF(控盘,1) AND 控盘>0.5;
STJ02:=控盘>0;
BTJ2:=控盘>REF(控盘,1) AND 控盘<-0.2;
BTJ22:=控盘>REF(控盘,1) AND 控盘<0 ;
{波段买卖条件}
BTJ3:=CROSS(财,神) AND 财<-0.3;
BTJ32:=CROSS(财,神) AND 财<-0.1;
STJ31:=CROSS(神,财);
STJ32:=CROSS(神,财) AND 财>1.618;
{以下为信号};
BTJ81:=FILTER(BTJ1 AND BTJ2 AND BTJ3,13);
BTJ811:=FILTER(BTJ11 AND BTJ2 AND BTJ3,13);
BTJ82:=FILTER(BTJ12 AND BTJ22 AND BTJ32,13);
STJ81:=FILTER(STJ1 AND STJ01 AND STJ31,13);
STJ82:=FILTER(STJ02 AND STJ32 ,13);
STJ83:=STJ81 AND STJ82;
DIFF: (EMA(CLOSE,8) - EMA(CLOSE,55))*10,COLORRED;
DEA: EMA(DIFF,3),COLORGREEN;
庄:= BTJ11 AND BTJ2 AND BTJ3;
有庄:FILTER(庄,55),COLORWHITE;
DRAWTEXT(BTJ811,40,'有庄'),COLORYELLOW;
价:=C;
大盘:=EMA(INDEXC,500)/EMA(C,500);
大盘参考线:INDEXC/大盘,COLORFFFF00;
VAR20:=(3*CLOSE+LOW+OPEN+HIGH)/6;
VAR21:=(20*VAR20+19*REF(VAR20,1)+18*REF(VAR20,2)+17*REF(VAR20,3)+16*REF(VAR20,4)+15*REF(VAR20,5)+14*REF(VAR20,6)+13*REF(VAR20,7)+12*REF(VAR20,8)+11*REF(VAR20,9)+10*REF(VAR20,10)+9*REF(VAR20,11)+8* REF(VAR20,12)+7*REF(VAR20,13)+6*REF(VAR20,14)+5*REF(VAR20,15)+4*REF(VAR20,16)+3*REF(VAR20,17)+2*REF(VAR20,18)+REF(VAR20,21))/210;
VAR22:=EMA(VAR21,15);
VAR23:=HHV(CLOSE,90);
VAR24:=LLV(CLOSE,90);
VAR25:=VAR23-VAR24;
VAR26:=EMA((CLOSE-VAR24)/VAR25-0.5,14);
ZLSP:=VAR26*20;
VAR27:=REF(HHV(CLOSE,66),2);
VAR28:=CROSS(CLOSE,VAR27) AND (HHV(CLOSE,110)/LLV(CLOSE,110)-1)*100<45 AND ZLSP<5.666;
VAR29:=LLV(ZLSP,35)<-8.9 AND CROSS(ZLSP,-7.815) AND ZLSP<-1.2;
VAR30:=10*FILTER(VAR29,41);
VAR31:=15*FILTER(VAR28,41)>10;
主力扫盘:VAR31*50,LINETHICK0;
DRAWTEXT(VAR31,60,'主力扫盘'),COLORYELLOW;
DRAWICON(主力扫盘=50,50,18);
GG:=BETWEEN(C/(SUM(AMOUNT,BARSCOUNT(C))/SUM(V*100,BARSCOUNT(C))),1.05,0.95);
ZZ:=IF(GG=0,MA(C,BARSCOUNT(C)),SUM(AMOUNT,BARSCOUNT(C))/SUM(V*100,BARSCOUNT
(C)));
AA:IF(PERIOD<1,POW(C/ZZ,3)*100,0),COLOR00FFFF;
100,COLORRED;
BB8:=EXPMA(AA,20),COLORFFFFFF;
{STICKLINE(BB>REF(BB,1),100,103,1,1),COLOR0000AA;
STICKLINE(BB>REF(BB,1) AND EXPMA(AA,20)>EXPMA(AA,120),100,103,1,0),COLOR0033FF;
STICKLINE(BB<REF(BB,1),100,97,1,1),COLORFF0000;
STICKLINE(BB<REF(BB,1) AND EXPMA(AA,20)<EXPMA(AA,120),100,97,1,0),COLORFF8800;}
DRAWICON((AA-BB8<=-6 OR (AA<89 AND AA-BB8<=-2)) AND C=LLV(C,30),78,26);
DRAWICON(AA-BB8<-4 AND AA<=92 AND C=LLV(C,30),80,1);
STICKLINE(AA-BB8<-4 AND AA<=92 AND C=LLV(C,30),10,75,1,1),COLOR0000AA;
DRAWICON(AA-BB8>4 AND AA>=108 AND C=HHV(C,30),104,2);
{VAR1A:=EMA(HHV(HIGH,500),21);
VAR2A:=EMA(HHV(HIGH,250),21);
VAR3A:=EMA(HHV(HIGH,90),21);
VAR4A:=EMA(LLV(LOW,500),21);
VAR5A:=EMA(LLV(LOW,250),21);
VAR6A:=EMA(LLV(LOW,90),21);
VAR7A:=EMA((VAR4A*0.96+VAR5A*0.96+VAR6A*0.96+VAR1A*0.558+VAR2A*0.558+VAR3A*0.558)/6,21);
VAR8A:=EMA((VAR4A*1.25+VAR5A*1.23+VAR6A*1.2+VAR1A*0.55+VAR2A*0.55+VAR3A*0.65)/6,21);
VAR9A:=EMA((VAR4A*1.3+VAR5A*1.3+VAR6A*1.3+VAR1A*0.68+VAR2A*0.68+VAR3A*0.68)/6,21);
VARA:=EMA((VAR7A*3+VAR8A*2+VAR9A)/6*1.738,21);
VARB:=REF(LOW,1);
VARC:=SMA(ABS(LOW-VARB),3,1)/SMA(MAX(LOW-VARB,0),3,1)*100;
VARD:=EMA(IF(CLOSE*1.35<=VARA,VARC*10,VARC/10),3);
VARE:=LLV(LOW,30);
VARF:=HHV(VARD,30);
VAR10:=IF(MA(CLOSE,58),1,0);
神炎:EMA(IF(LOW<=VARE,(VARD+VARF*2)/2,0),3)/618*VAR10,COLORYELLOW;
{邪炎:STICKLINE(神炎>0 ,0 ,神炎 ,4 ,1); }
{㊣:神炎,COLORRED;
STICKLINE(神炎>0,0 ,㊣*1.2,8,0 ),COLOR00EEFF;
STICKLINE(神炎>0,0 ,㊣*0.8,8,0 ),COLOR00BBFF;
STICKLINE(神炎>0,0 ,㊣*0.6,8,0 ),COLOR0099FF;
STICKLINE(神炎>0,0 ,㊣*0.4,8,0 ),COLOR0066FF;
STICKLINE(神炎>0,0 ,㊣*0.2,8,0 ),COLOR0000FF;}
VAR1111:=(CLOSE-MA(CLOSE,21))/MA(CLOSE,21)*100;
VAR2222:=(CLOSE-LLV(LOW,43))/(HHV(HIGH,43)-LLV(LOW,43))*100;
VAR3333:=SMA(VAR2222,2,1);
天:100+(-ABS(VAR1111)),COLORRED;
下:SMA(VAR3333,2,1);
无:ABS(VAR1111),COLORGREEN;
敌:50,COLORFFAA00,LINETHICK3;
A8:80;
B8:20;
买:STICKLINE(CROSS(下,无),3,20,2,0),COLORRED,LINETHICK1;
STICKLINE(CROSS(下,无),20,25,2,0),COLORFF9900,LINETHICK1;
DRAWTEXT(CROSS(下,无),30,' '),COLORFFFFCC;
卖:STICKLINE(CROSS(下,天),70,90,2,0),COLORRED,LINETHICK1;
STICKLINE(CROSS(下,天),90,99,2,0),COLORFF9900,LINETHICK1;
DRAWTEXT(CROSS(下,天),70,' '),COLORFFFFCC;

通达信组合分时指标公式

 

相关文章