在线检测未来函数

通达信雪白主图指标公式

来源:Internet,编辑:股旁网,2014-07-27

MA5:MA(C,5);
MA10:MA(C,10);
MA20:MA(C,20);
MA60:MA(C,60);
MA120:MA(C,120);
MA250:MA(C,250);
涨2停:=C>=INTPART(REF(C,1)*(1.0991)*100)/100 AND C=H AND CURRBARSCOUNT<=20;
TT:=BARSLAST(涨2停);
AA:=IF(TT<20,涨2停,0);
涨停处开盘:=REF(O,BARSLAST(涨2停));
涨停处收盘:=REF(H,BARSLAST(涨2停));
STICKLINE(CURRBARSCOUNT<=10 ,涨停处开盘,涨停处开盘,2,0),COLORMAGENTA;
STICKLINE(CURRBARSCOUNT<=10 ,涨停处收盘,涨停处收盘,2,0),COLORGREEN;
EMA18:=MA(C,18),COLORYELLOW;
中线买入】:=COUNT(CLOSE<EMA18,5)=4 AND
CLOSE/EMA18>1.004 AND CROSS(CLOSE,EMA18) AND EMA18>=
REF(EMA18,1) AND BETWEEN(C/MA(C,250),0.98,1.02);
DRAWTEXT(ABS(中线【买入】)>0,L, '中买'),COLORGREEN;
VL:=REF(LOW,1);
VAR12:=(SMA(ABS(LOW-VL),13,1))/(SMA(MAX(LOW-VL,0),13,1))*100;
VAR14:=MA(VAR12,13);
VAR15:=LLV(LOW,34);
VAR18:=EMA(IF(LOW<=VAR15,VAR14,0),3);
VAR110:=SMA(SMA((CLOSE-LLV(LOW,54))/(HHV(HIGH,54)-LLV(LOW,54))*100,7,1),5,1);
VAR111:=SMA((CLOSE-LLV(LOW,54))/(HHV(HIGH,54)-LLV(LOW,54))*100,7,1)*16.18-VAR110*10.9;
洗盘结束:=FILTER(IF(VAR111<=VAR110 AND VAR18>REF(VAR18,1),VAR18*8,0),20) AND BETWEEN(C/MA(C,250),0.98,1.02);
DRAWTEXT(ABS(洗盘结束)>0,L, '洗结'),COLORYELLOW;
VAR21:=(CLOSE-LLV(LOW,36))/(HHV(HIGH,36)-LLV(LOW,36))*100;
VAR22:=SMA(VAR21,3,1);
VAR23:=SMA(VAR22,3,1);
VAR24:=SMA(VAR23,3,1);
VAR25:=CROSS(VAR23,VAR24) AND VAR23<20;
抄底:=FILTER(VAR25,10)=1 AND BETWEEN(C/MA(C,250),0.98,1.02);
DRAWTEXT(ABS(抄底)>0,L, '抄底'),COLORRED;
EXP12:=EXPMA(C,12);
EXP50:=EXPMA(C,50);
中期方向线:=EXP12-EXP50;
MB:=EXPMA(中期方向线,20),COLORWHITE;
超买线:=MB+1.96*STD(中期方向线,20),COLORYELLOW;
超卖线:=MB-1.96*STD(中期方向线,20),COLORCYAN;
XG:=CROSS(中期方向线,0);
DRAWTEXT(ABS(XG)>0,L, '中起点'),COLORRED;
DRAWTEXT_FIX(ISLASTBAR,0.5,0.05,0,CODE),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR,0.55,0.05,0,STKNAME)COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR,0.6,0.05,0,HYBLOCK),COLORCYAN;
DRAWTEXT_FIX(ISLASTBAR,0.6,0,0,DYBLOCK),COLORCYAN;
DRAWTEXT_FIX(ISLASTBAR,0.55,0.85,0,GNBLOCK),COLORMAGENTA;
DRAWTEXT_FIX(ISLASTBAR,0.55,0.90,0,FGBLOCK),COLORMAGENTA;
DRAWTEXT_FIX(ISLASTBAR,0.55,0.95,0,ZSBLOCK);

通达信雪白主图指标公式

 

相关文章