在线检测未来函数

通达信王者归来主图指标公式

来源:Internet,编辑:股旁网,2014-07-31

N:=5;
{柱型显示}
STICKLINE(CLOSE>REF(CLOSE,1)*1.0985 AND CLOSE=HIGH,CLOSE,OPEN,4,-1),COLOR00FFFF;
STICKLINE(CLOSE<REF(CLOSE,1)*0.9015 AND CLOSE=LOW,CLOSE,OPEN,4,-1),COLORGREEN;
{蓝}
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,3,0),COLORFF7700;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,2.2,0),COLORFF9900;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,1.5,0),COLORFFBB00;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,0.5,0),COLORCYAN;
{红}
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,3,0),COLOR000099;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2.2,0),COLOR0000CC;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1.5,0),COLOR0000FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,0.5,0),COLORCC66FF;
M5:MA(CLOSE,N),COLORWHITE;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
SWL:=(EXPMA(CLOSE,5)*7+EXPMA(CLOSE,10)*3)/10,COLORGRAY;
SWS:DMA(EMA(CLOSE,12),MAX(1,100*(SUM(VOL,5)/(3*CAPITAL)))),COLORMAGENTA,LINETHICK2;
SS:IF(SWS<=REF(SWS,1),SWS,DRAWNULL),COLORGREEN,LINETHICK2;
BBI:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4,COLORWHITE;
压:= BBI+6*STD(BBI,11); 撑:= BBI-6*STD(BBI,11);
MA30: MA(CLOSE,30),CIRCLEDOT,COLORFFFF00;
安:IF(MA30>=REF(MA30,1) AND C>=MA30,MA30,DRAWNULL),CIRCLEDOT,COLORMAGENTA;
顶:PEAK(CLOSE,10,1);
底:TROUGH(CLOSE,10,1);
BUY:=ZIG(3,10); SELL:=MA(BUY,2);
DRAWICON(CROSS(BUY,SELL),L*0.98,7); DRAWICON(CROSS(SELL,BUY),H*1.01,8);
LJB:=1/WINNER(CLOSE);
STICKLINE(LJB >10,L-0.45,L-0.4,-1,1),COLORYELLOW;
平均:=(L+H)/2;
KB:=ZIG(平均,10);
KS:=MA(KB,2);
DRAWICON(CROSS(KB,KS),L*0.95,1);
DRAWICON(CROSS(KS,KB),H*1.04,2);

通达信王者归来主图指标公式

 

相关文章