在线检测未来函数

同花顺长期趋势主图指标公式

来源:Internet,编辑:股旁网,2014-08-03

上月天数:=REF(BARSLAST(BARSLASTCOUNT(NOT(MONTH-REF(MONTH,1)=0))),1);
本月天数:=BARSLAST(BARSLASTCOUNT(NOT(MONTH-REF(MONTH,1)=0)));
月1:=IF(本月天数-上月天数=1,REF(C,本月天数+1),DRAWNULL);
月2:=IF(本月天数-上月天数=1,REF(月1,本月天数+1),DRAWNULL);
月3:=IF(本月天数-上月天数=1,REF(月2,本月天数+1),DRAWNULL);
月4:=IF(本月天数-上月天数=1,REF(月3,本月天数+1),DRAWNULL);
月5:=IF(本月天数-上月天数=1,REF(月4,本月天数+1),DRAWNULL);
月6:=IF(本月天数-上月天数=1,REF(月5,本月天数+1),DRAWNULL);
月7:=IF(本月天数-上月天数=1,REF(月6,本月天数+1),DRAWNULL);
月8:=IF(本月天数-上月天数=1,REF(月7,本月天数+1),DRAWNULL);
月9:=IF(本月天数-上月天数=1,REF(月8,本月天数+1),DRAWNULL);
月10:=IF(本月天数-上月天数=1,REF(月9,本月天数+1),DRAWNULL);
月11:=IF(本月天数-上月天数=1,REF(月10,本月天数+1),DRAWNULL);
五月均:(月1+月2+月3+月4+C)/5;
十月均:(月1+月2+月3+月4+月5+月6+月7+月8+月9+C)/10;
{STICKLINE(五月均>十月均 AND MONTH=REF(MONTH,1),五月均,十月均,6,0),colorred;
STICKLINE(五月均<十月均 AND MONTH=REF(MONTH,1),五月均,十月均,6,0),colorblue;}
DRAWBAND(五月均,RGB(255,0,0),十月均,RGB(20,200,80));
STICKLINE(C>=O,C,O,3,0),COLOR000045;
STICKLINE(C>=O,C,O,2.5,0),COLOR000065;
STICKLINE(C>=O,C,O,2,0),COLOR000085;
STICKLINE(C>=O,C,O,1.5,0),COLOR0000A5;
STICKLINE(C>=O,C,O,1,0),COLOR0000C5;
STICKLINE(C>=O,C,O,0.5,0),COLOR0000E5;
STICKLINE(C>=O,H,L,0,0),COLOR0000F5;
STICKLINE(C<O,C,O,3,0),COLOR353500;
STICKLINE(C<O,C,O,2.5,0),COLOR454500;
STICKLINE(C<O,C,O,2,0),COLOR555500;
STICKLINE(C<O,C,O,1.5,0),COLOR656500;
STICKLINE(C<O,C,O,1,0),COLOR757500;
STICKLINE(C<O,C,O,0.5,0),COLOR858500;
STICKLINE(C<O,H,L,0,0),COLOR959500;
EMA120:EMA(C,120),colorliblue,LINETHICK2;
EMA250:EMA(C,250),coloryellow,LINETHICK2;
MA20:MA(C,20),LINETHICK4;

同花顺长期趋势主图指标公式

 

相关文章