在线检测未来函数

通达信牛熊股都能赚钱指标公式

来源:Internet,编辑:股旁网,2014-08-03

LB:=VOL/REF(MA(VOL,5),1)/(FROMOPEN/240);
量比:=LB,VOLSTICK;
{量比}关注线:1,COLOR00DDDD,LINETHICK1;
{量比}突破线:4,COLOR555555,LINETHICK1;
BIAS1:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
BIAS2:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
BIAS3:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
BIAS:=(BIAS1+2*BIAS2+3*BIAS3)/6;
乖离:=MA(BIAS,3);
抄底:IF(乖离<-12 AND 乖离>=-18,-4,0), COLORCYAN,LINETHICK1;
STICKLINE(乖离<-12 AND 乖离>=-18,2,0,6,1) , COLORCYAN;
抄底二:IF(乖离<-18,3,0),COLORFF35FF,LINETHICK1;
STICKLINE(乖离<-18,3,0,6,1),COLORFF35FF;
抄底三:IF(乖离<-6,5,0),COLORRED,LINETHICK1;
STICKLINE(乖离<-6,5,3,2,1),COLORRED;
抄底四:IF(乖离<-4.5,0,1),COLOR00FFFF,LINETHICK1;
STICKLINE(乖离<-4.5,0,1,3,1),COLOR00FFFF;
VARD1:=DMA(CLOSE,VOL/MA(VOL,4)/4);
VARD2:=DMA(CLOSE,VOL/MA(VOL,31)/31);
VARD3:=(CLOSE-VARD1)/VARD1*100<-10;
VARD4:=(VARD1-VARD2)/VARD2*100<-16;
VARD5:=(CLOSE-MA(CLOSE,50))/MA(CLOSE,50)*100<-23;
VARD6:=SMA(MAX(CLOSE-REF(CLOSE,1),0),3,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),3,1)*100>16;
VARD7:=100*(HHV(HIGH,27)-CLOSE)/(HHV(HIGH,27)-LLV(LOW,27));
VARD8:=INDEXC;
VARD9:=MA(VARD8,6);
VARDA:=MA(VARD8,24);
VARDB:=MA(VARD8,32);
VARDC:=VARDB>VARD9*1.11 AND VARDA>VARD9*1.095;
SSS:=(VARD3 AND VARD4 AND (OPEN-REF(CLOSE,1))/REF(CLOSE,1)>-0.07 OR VARD5 AND VARD6 AND CROSS(VARD7,79) OR VARDC AND CLOSE/COST(8)<=0.8)*100;
抄底王:SSS>0,COLORWHITE,LINETHICK1;
STICKLINE(SSS>0,0,6,6,1),COLORWHITE;
{叶烨专用}
VAR1:=1992231;
VAR2:=IF(DATE<=VAR1,1,0);
VAR3:=1/WINNER(CLOSE);
VAR4:=MA(CLOSE,13);
VAR5:=100-ABS((CLOSE-VAR4)/VAR4*100);
VAR6:=LLV(LOW,75);
VAR7:=HHV(HIGH,75);
VAR8:=(VAR7-VAR6)/100;
VAR9:=SMA((CLOSE-VAR6)/VAR8,20,1);
VARA:=SMA((OPEN-VAR6)/VAR8,20,1);
VARB:=3*VAR9-2*SMA(VAR9,15,1);
VARC:=3*VARA-2*SMA(VARA,15,1);
VARD:=100-VARC;
VARE:=REF(LOW,1)*0.9;
VARF:=LOW*0.9;
VAR10:=(VARF*VOL+VARE*(CAPITAL-VOL))/CAPITAL;
VAR11:=EMA(VAR10,30);
VAR12:=CLOSE-REF(CLOSE,1);
VAR13:=MAX(VAR12,0);
VAR14:=ABS(VAR12);
VAR15:=SMA(VAR13,7,1)/SMA(VAR14,7,1)*100;
VAR16:=SMA(VAR13,13,1)/SMA(VAR14,13,1)*100;
VAR17:=BARSCOUNT(CLOSE);
VAR18:=SMA(MAX(VAR12,0),6,1)/SMA(ABS(VAR12),6,1)*100;
VAR19:=(-200)*(HHV(HIGH,55)-CLOSE)/(HHV(HIGH,55)-LLV(LOW,55))+100;
VAR1A:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
VAR1B:=SMA((SMA(VAR1A,4,1)-50)*2,3,1);
VAR1C:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;
VAR1D:=SMA(VAR1C,4,1);
VAR1E:=SMA(VAR1D,3,1);
VAR1F:=(HHV(HIGH,30)-CLOSE)/CLOSE*100;
VAR20:=VAR18<=25 AND VAR19<-95 AND VAR1F>20 AND VAR1B<-30 AND VAR1E<30 AND VAR11-CLOSE>=-0.25 AND VAR15<22 AND VAR16<55 AND VAR17>50;
明天低买CGL90%: IF(CROSS(VAR20,0.5),8,0)*VAR2,COLOR00FFFF ,LINETHICK2;
AA:=LLV(LOW,34);
BB:=HHV(HIGH,30);
DD:=(EMA(((CLOSE-AA)/(BB-AA))*(4),4))*(25);
绝谷:=(((DD-LLV(DD,21))/(HHV(DD,21)-LLV(DD,21)))*(4))*(25);
买入成功率80%:IF(CROSS(绝谷,90) AND (DD<40),8,0),COLORFFFF00;
{MA10:MA(LB,10);
MA5:MA(LB,5);};

通达信牛熊股都能赚钱指标公式

 

相关文章