在线检测未来函数

通达信长线操盘主图指标公式

来源:Internet,编辑:股旁网,2014-08-05

VARA:=(((CLOSE - EMA(CLOSE,13)) / EMA(CLOSE,13)) * (0 - 100));
趋势线:EMA(((VARA/10)+EMA(CLOSE,10)),3),COLORFFFF00,LINETHICK2;
VARB:=(OPEN+HIGH+LOW)/3;
VARC:=EMA(VARB,4);
行情线:VARC,COLORYELLOW;
FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);
FA:=IF(CROSS(FF,MA15),1,0);
BUYA:=IF(CROSS(行情线,趋势线) OR (REF(行情线,1)=REF(趋势线,1) AND 行情线>趋势线),1,0);
ATR:=MA(TR,14);
AA:=(HHV(HIGH,20) - (2 * ATR));
BB:=CROSS(CLOSE,REF(HHV(HIGH,55),1));
SSS:=CROSS(MIN(MA(CLOSE,13),AA),CLOSE);
BBB:=BARSLAST(BB);
SSSB:=BARSLAST(SSS);
B1:=((BBB = 0) AND (REF(SSSB,1) < REF(BBB,1)));
B1B:=BARSLAST(B1);
B2:=((((BB = 1) AND (B1B < SSSB)) AND (B1B > 0)) AND (COUNT(BB,SSSB) < 3));
B2B:=BARSLAST(B2);
B3:=((((BB = 1) AND (B2B < B1B)) AND (COUNT(BB,SSSB) < 4)) AND (COUNT(BB,SSSB) > 2));
DRAWTEXT((B1=1 AND 行情线>=趋势线 AND BUYA=0) OR (B2=1 AND 行情线>=趋势线 AND BUYA=0),LOW*0.98,'加仓'),COLORFF00FF;
A:=(3*CLOSE+LOW+OPEN+HIGH)/6;
X:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+
14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+
REF(A,20))/210;
Y:=EMA(X,13);
加仓A:=SMA(EMA((C-REF(C,1))/REF(C,1),5)*100,3,1)*10;
DRAWTEXT(FILTER((CROSS(加仓A,0) OR CROSS(CLOSE,Y)) AND 行情线>=趋势线 AND BUYA=0 AND FA=0,3),LOW*0.98,'加仓'),COLORFF00FF;
加仓:=(B1=1 AND 行情线>=趋势线 AND BUYA=0) OR (B2=1 AND 行情线>=趋势线 AND BUYA=0) OR FILTER((CROSS(加仓A,0) OR CROSS(CLOSE,Y)) AND 行情线>=趋势线 AND BUYA=0 AND FA=0,3);
{减仓}
VARJ1:=REF(CLOSE,1);
VARJ2:=((SMA(MAX(CLOSE-VARJ1,0),6,1))/(SMA(ABS(CLOSE-VARJ1),6,1)))*(100);
减仓A:=CROSS(85,VARJ2);
DRAWTEXT(CROSS(85,VARJ2),(HIGH * 1.02),'减仓'),COLORYELLOW;
MTM:=C-REF(C,1);
DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
DY:=HHV(DX,2)=HHV(DX,7) AND COUNT(DX>50,2) AND CROSS(MA(DX,2),DX);
LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
减仓B:=FILTER(CROSS(84,RSI) OR DY,5);{下穿84}
DRAWTEXT(CROSS(84,RSI),(HIGH * 1.02),'减仓'),COLORYELLOW;
减仓:=减仓A OR 减仓B;
DRAWTEXT(减仓B AND 行情线>=趋势线,H*1.02,'减仓'),COLORYELLOW;
{一阳穿三线}
BBI:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
上:=BBI+3*STD(BBI,10);
中:=BBI;
下:=BBI-3*STD(BBI,10);
优选:=BETWEEN(上,OPEN,CLOSE) AND BETWEEN(中,OPEN,CLOSE) AND BETWEEN(下,OPEN,CLOSE) AND CLOSE>OPEN AND 上>=REF(上,1) AND 中>=REF(中,1) AND 下>REF(下,1);
DRAWTEXT(FILTER(优选,2),LOW*0.95,'优选'),COLOR00FF00;
{底背离}
DRAWTEXT(FA AND BUYA=0,(LOW * 0.98),'底背离'),COLOR0099FF;
{波浪顶底}
TY:=C;
HD:=FILTER(BACKSET(FILTER(REF(TY,10)=HHV(TY,2*10+1),10),10+1),10);
LD:=FILTER(BACKSET(FILTER(REF(TY,10)=LLV(TY,2*10+1),10),10+1),10);
A2:=REF(C,BARSLAST(HD));
B2A:=REF(C,BARSLAST(LD));
T1:=BARSLAST(HD)<BARSLAST(LD) AND NOT(HD) ;
T2:=BARSLAST(HD)>BARSLAST(LD) AND NOT(LD);
顶:IF(T1,A2,A2),COLOR00FF00,POINTDOT,LINETHICK2;
STICKLINE(T1,A2,A2,9,0),COLOR00FF00;
底:IF(T2,B2A,B2A),COLORFF00FF,POINTDOT,LINETHICK2;
STICKLINE(T2,B2A,B2A,9,0),COLORFF00FF;
{多空线}
VAR2:=(C+L+O+H)/4;
多头线:=(20*VAR2+19*REF(VAR2,1)+18*REF(VAR2,2)+17*REF(VAR2,3)+16*REF(VAR2,4)+15*REF(VAR2,5)+14*REF(VAR2,6)+13*REF(VAR2,7)+12*REF(VAR2,8)+11*REF(VAR2,9)+10*REF(VAR2,10)+9*REF(VAR2,11)+8*REF(VAR2,12)+7*REF(VAR2,13)+6*REF(VAR2,14)+5*REF(VAR2,15)+4*REF(VAR2,16)+3*REF(VAR2,17)+2*REF(VAR2,18)+REF(VAR2,20))/210;
空头线:=EMA(多头线,4);
STICKLINE(多头线>空头线,多头线,空头线,4,10),COLORYELLOW;
STICKLINE(多头线<空头线,多头线,空头线,4,10),COLORCCCCCC;

通达信长线操盘主图指标公式

 

相关文章