在线检测未来函数

飞狐测量趋势强度指标公式

来源:Internet,编辑:股旁网,2014-08-10

nx:=9;
ATR := SMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),Nx,1);
HD := HIGH-REF(HIGH,1);
LD := REF(LOW,1)-LOW;
DMP:= SMA(IF(HD>0 AND HD>LD,HD,0),Nx,1);
DMM:= SMA(IF(LD>0 AND LD>HD,LD,0),Nx,1);
PDI:= DMP*100/ATR;
MDI:= DMM*100/ATR;
ADX: SMA(ABS(MDI-PDI)/(MDI+PDI)*100,Nx,1);
ADXR:=(ADX+REF(ADX,Nx))/2;
30;50;
STICKLINE(cross(ADX,30),ADX,30,10,0),Color00FFFF,LINETHICK5;

飞狐测量趋势强度指标公式

 

相关文章