在线检测未来函数

飞狐红底淘金指标公式

来源:Internet,编辑:股旁网,2014-08-11

n:=5;m:=26;
zx:=MA(CLOSE,M);
来势线:=EMA(CLOSE,7)-EMA(CLOSE,21),COLORYELLOW;
阻力线:=(zx + N*STD(CLOSE,M)),POINTDOT,LINETHICK2,colorgreen;
拉升力:=(CLOSE-LLV(LOW,25))/(HHV(HIGH,25)-LLV(LOW,47))*1.8*CLOSE;
拉升力A:=SMA(拉升力,9,1);
波峰波谷:=SMA(拉升力A,4,1),colorwhite;
拉升力B:=3*拉升力A-2*波峰波谷;
空方:=3*波峰波谷-1* 拉升力A;
做空:=IF(空方>拉升力B,拉升力B,空方),LINETHICK2,Color00FF00;
短线:=(CLOSE-ma(CLOSE,13))/ma(CLOSE,13)*40,LINETHICK0,COLORYELLOW;
中线:=(CLOSE-MA(CLOSE,4))/MA(CLOSE,4)*40,LINETHICK0,colorwhite;
红柱:=sma(短线,3,1),LINETHICK0,Color0000FF;
蓝柱:=sma(中线,3,1),colorstick,ColorFFFF00;
{红柱}
STICKLINE(红柱<ref(红柱,0.5)and 红柱>0,0,红柱,4,0),COLOR0000AA;
STICKLINE(红柱<ref(红柱,0.5)and 红柱>0,0,红柱,4,0),COLOR0000BB;
STICKLINE(红柱<ref(红柱,0.5)and 红柱>0,0,红柱,4,0),COLOR0000CC;
STICKLINE(红柱<ref(红柱,0.5)and 红柱>0,0,红柱,4,0),COLOR0000DD;
STICKLINE(红柱<ref(红柱,0.5)and 红柱>0,0,红柱,4,0),COLOR0000EE;
STICKLINE(红柱<ref(红柱,1)and 红柱>0,0,红柱,2,0),COLOR0000FF;
STICKLINE(红柱<ref(红柱,1)and 红柱>0,0,红柱,1,0),COLORRED;
STICKLINE(红柱>ref(红柱,1)and 红柱>0,0,红柱,4,0),COLOR0000AA;
STICKLINE(红柱>ref(红柱,1)and 红柱>0,0,红柱,4,0),COLOR0000BB;
STICKLINE(红柱>ref(红柱,1)and 红柱>0,0,红柱,4,0),COLOR0000CC;
STICKLINE(红柱>ref(红柱,1)and 红柱>0,0,红柱,4,0),COLOR0000DD;
STICKLINE(红柱>ref(红柱,1)and 红柱>0,0,红柱,4,0),COLOR0000EE;
STICKLINE(红柱>ref(红柱,1)and 红柱>0,0,红柱,2,0),COLOR0000FF;
STICKLINE(红柱>ref(红柱,1)and 红柱>0,0,红柱,1,0),COLORRED;
STICKLINE(蓝柱<ref(蓝柱,1) and 蓝柱>0,0,蓝柱,4,0),COLOR0000FF;
STICKLINE(蓝柱<ref(蓝柱,1) and 蓝柱>0,0,蓝柱,4,0),COLOR0033FF;
STICKLINE(蓝柱<ref(蓝柱,1) and 蓝柱>0,0,蓝柱,4,0),COLOR0055FF;
STICKLINE(蓝柱<ref(蓝柱,1) and 蓝柱>0,0,蓝柱,4,0),COLOR0077FF;
STICKLINE(蓝柱<ref(蓝柱,1) and 蓝柱>0,0,蓝柱,4,0),COLOR0099FF;
STICKLINE(蓝柱<ref(蓝柱,1) and 蓝柱>0,0,蓝柱,2,0),COLOR00BBFF;
STICKLINE(蓝柱<ref(蓝柱,1) and 蓝柱>0,0,蓝柱,1,0),COLOR00DDFF;
STICKLINE(蓝柱<ref(蓝柱,1) and 蓝柱>0,0,蓝柱,1,0),COLOR00FFFF;
{蓝柱}
STICKLINE(红柱>ref(红柱,0)and 红柱<0,0,红柱,4,0),COLORFF0000;
STICKLINE(红柱>ref(红柱,0)and 红柱<0,0,红柱,4,0),COLORFF3300;
STICKLINE(红柱>ref(红柱,0)and 红柱<0,0,红柱,4,0),COLORFF5500;
STICKLINE(红柱>ref(红柱,0)and 红柱<0,0,红柱,4,0),COLORFF7700;
STICKLINE(红柱>ref(红柱,0)and 红柱<0,0,红柱,4,0),COLORFF9900;
STICKLINE(红柱>ref(红柱,1)and 红柱<0,0,红柱,2,0),COLORFFBB00;
STICKLINE(红柱>ref(红柱,1)and 红柱<0,0,红柱,1,0),COLORFFDD00;
STICKLINE(红柱>ref(红柱,1)and 红柱<0,0,红柱,1,0),COLORFFFF00;
STICKLINE(红柱<ref(红柱,1)and 红柱<0,0,红柱,4,0),COLORFF0000;
STICKLINE(红柱<ref(红柱,1)and 红柱<0,0,红柱,4,0),COLORFF3300;
STICKLINE(红柱<ref(红柱,1)and 红柱<0,0,红柱,4,0),COLORFF5500;
STICKLINE(红柱<ref(红柱,1)and 红柱<0,0,红柱,4,0),COLORFF7700;
STICKLINE(红柱<ref(红柱,1)and 红柱<0,0,红柱,4,0),COLORFF9900;
STICKLINE(红柱<ref(红柱,1)and 红柱<0,0,红柱,2,0),COLORFFBB00;
STICKLINE(红柱<ref(红柱,1)and 红柱<0,0,红柱,1,0),COLORFFDD00;
STICKLINE(红柱<ref(红柱,1)and 红柱<0,0,红柱,1,0),COLORFFFF00;
STICKLINE(蓝柱>ref(蓝柱,1)and 蓝柱<0,0,蓝柱,4,0),COLOR998800;
STICKLINE(蓝柱>ref(蓝柱,1)and 蓝柱<0,0,蓝柱,4,0),COLORBBAA90;
STICKLINE(蓝柱>ref(蓝柱,1)and 蓝柱<0,0,蓝柱,4,0),COLORDDCC99;
STICKLINE(蓝柱>ref(蓝柱,1)and 蓝柱<0,0,蓝柱,1,0),COLORFFEEBB;
主力:(((CLOSE - MA(LLV(LOW,40),40)) / MA(LLV(LOW,40),40)) * 100),COLORF0F000;
AA:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*1000;
BB:=MA(AA,10);
CC:=(((CLOSE - LLV(LOW,26)) / (HHV(HIGH,26) - LLV(LOW,26))) * 100);
判势:SMA(CC,32,1)-20,COLOR00FF00,LINETHICK1;
加码:DRAWTEXT(CROSS(主力,判势),判势-10,'低◆买'),COLOR00FF00;
{红底淘金}
把红柱蓝柱也表现出来n:=5;m:=26;
zx:=MA(CLOSE,M);
来势线: EMA(CLOSE,7)-EMA(CLOSE,21),COLORYELLOW;
阻力线:=(zx + N*STD(CLOSE,M)),POINTDOT,LINETHICK2,colorgreen;
拉升力:=(CLOSE-LLV(LOW,25))/(HHV(HIGH,25)-LLV(LOW,47))*1.8*CLOSE;
拉升力A:=SMA(拉升力,9,1);
波峰波谷:=SMA(拉升力A,4,1),colorwhite;
拉升力B:=3*拉升力A-2*波峰波谷;
空方:=3*波峰波谷-1* 拉升力A;
做空:=IF(空方>拉升力B,拉升力B,空方),LINETHICK2,Color00FF00;
短线:=(CLOSE-ma(CLOSE,13))/ma(CLOSE,13)*40,LINETHICK0,COLORYELLOW;
中线:=(CLOSE-MA(CLOSE,4))/MA(CLOSE,4)*40,LINETHICK0,colorwhite;
红柱:=sma(短线,3,1),LINETHICK0,Color0000FF;
蓝柱:=sma(中线,3,1),colorstick,ColorFFFF00;
{红柱}
STICKLINE(红柱<ref(红柱,0.5)and 红柱>0,0,红柱,4,0),COLOR0000AA;
STICKLINE(红柱<ref(红柱,0.5)and 红柱>0,0,红柱,4,0),COLOR0000BB;
STICKLINE(红柱<ref(红柱,0.5)and 红柱>0,0,红柱,4,0),COLOR0000CC;
STICKLINE(红柱<ref(红柱,0.5)and 红柱>0,0,红柱,4,0),COLOR0000DD;
STICKLINE(红柱<ref(红柱,0.5)and 红柱>0,0,红柱,4,0),COLOR0000EE;
STICKLINE(红柱<ref(红柱,1)and 红柱>0,0,红柱,2,0),COLOR0000FF;
STICKLINE(红柱<ref(红柱,1)and 红柱>0,0,红柱,1,0),COLORRED;
STICKLINE(红柱>ref(红柱,1)and 红柱>0,0,红柱,4,0),COLOR0000AA;
STICKLINE(红柱>ref(红柱,1)and 红柱>0,0,红柱,4,0),COLOR0000BB;
STICKLINE(红柱>ref(红柱,1)and 红柱>0,0,红柱,4,0),COLOR0000CC;
STICKLINE(红柱>ref(红柱,1)and 红柱>0,0,红柱,4,0),COLOR0000DD;
STICKLINE(红柱>ref(红柱,1)and 红柱>0,0,红柱,4,0),COLOR0000EE;
STICKLINE(红柱>ref(红柱,1)and 红柱>0,0,红柱,2,0),COLOR0000FF;
STICKLINE(红柱>ref(红柱,1)and 红柱>0,0,红柱,1,0),COLORRED;
STICKLINE(蓝柱<ref(蓝柱,1) and 蓝柱>0,0,蓝柱,4,0),COLOR0000FF;
STICKLINE(蓝柱<ref(蓝柱,1) and 蓝柱>0,0,蓝柱,4,0),COLOR0033FF;
STICKLINE(蓝柱<ref(蓝柱,1) and 蓝柱>0,0,蓝柱,4,0),COLOR0055FF;
STICKLINE(蓝柱<ref(蓝柱,1) and 蓝柱>0,0,蓝柱,4,0),COLOR0077FF;
STICKLINE(蓝柱<ref(蓝柱,1) and 蓝柱>0,0,蓝柱,4,0),COLOR0099FF;
STICKLINE(蓝柱<ref(蓝柱,1) and 蓝柱>0,0,蓝柱,2,0),COLOR00BBFF;
STICKLINE(蓝柱<ref(蓝柱,1) and 蓝柱>0,0,蓝柱,1,0),COLOR00DDFF;
STICKLINE(蓝柱<ref(蓝柱,1) and 蓝柱>0,0,蓝柱,1,0),COLOR00FFFF;
{蓝柱}
STICKLINE(红柱>ref(红柱,0)and 红柱<0,0,红柱,4,0),COLORFF0000;
STICKLINE(红柱>ref(红柱,0)and 红柱<0,0,红柱,4,0),COLORFF3300;
STICKLINE(红柱>ref(红柱,0)and 红柱<0,0,红柱,4,0),COLORFF5500;
STICKLINE(红柱>ref(红柱,0)and 红柱<0,0,红柱,4,0),COLORFF7700;
STICKLINE(红柱>ref(红柱,0)and 红柱<0,0,红柱,4,0),COLORFF9900;
STICKLINE(红柱>ref(红柱,1)and 红柱<0,0,红柱,2,0),COLORFFBB00;
STICKLINE(红柱>ref(红柱,1)and 红柱<0,0,红柱,1,0),COLORFFDD00;
STICKLINE(红柱>ref(红柱,1)and 红柱<0,0,红柱,1,0),COLORFFFF00;
STICKLINE(红柱<ref(红柱,1)and 红柱<0,0,红柱,4,0),COLORFF0000;
STICKLINE(红柱<ref(红柱,1)and 红柱<0,0,红柱,4,0),COLORFF3300;
STICKLINE(红柱<ref(红柱,1)and 红柱<0,0,红柱,4,0),COLORFF5500;
STICKLINE(红柱<ref(红柱,1)and 红柱<0,0,红柱,4,0),COLORFF7700;
STICKLINE(红柱<ref(红柱,1)and 红柱<0,0,红柱,4,0),COLORFF9900;
STICKLINE(红柱<ref(红柱,1)and 红柱<0,0,红柱,2,0),COLORFFBB00;
STICKLINE(红柱<ref(红柱,1)and 红柱<0,0,红柱,1,0),COLORFFDD00;
STICKLINE(红柱<ref(红柱,1)and 红柱<0,0,红柱,1,0),COLORFFFF00;
STICKLINE(蓝柱>ref(蓝柱,1)and 蓝柱<0,0,蓝柱,4,0),COLOR998800;
STICKLINE(蓝柱>ref(蓝柱,1)and 蓝柱<0,0,蓝柱,4,0),COLORBBAA90;
STICKLINE(蓝柱>ref(蓝柱,1)and 蓝柱<0,0,蓝柱,4,0),COLORDDCC99;
STICKLINE(蓝柱>ref(蓝柱,1)and 蓝柱<0,0,蓝柱,1,0),COLORFFEEBB;
主力:=(((CLOSE - MA(LLV(LOW,40),40)) / MA(LLV(LOW,40),40)) * 100),COLORF0F000;
AA:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*1000;
BB:=MA(AA,10);
CC:=(((CLOSE - LLV(LOW,26)) / (HHV(HIGH,26) - LLV(LOW,26))) * 100);
判势:=SMA(CC,32,1)-20,COLOR00FF00,LINETHICK1;
加码:=DRAWTEXT(CROSS(主力,判势),判势-10,'低◆买'),COLOR00FF00;

飞狐红底淘金指标公式

 

相关文章