在线检测未来函数

飞狐买入合成指标公式

来源:Internet,编辑:股旁网,2014-08-14

TYP := (HIGH + LOW + CLOSE)/3;
CCI:(TYP-MA(TYP,12))/(0.015*AVEDEV(TYP,12)),COLORGREEN;
CC:0;
TRV:=EMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),12);
HD :=HIGH-REF(HIGH,1);
LD :=REF(LOW,1)-LOW;
DMP:=EMA(IF(HD>0 AND HD>LD,HD,0),12);
DMM:=EMA(IF(LD>0 AND LD>HD,LD,0),12);
PDI:= DMP*100/TRV;
MDI:= DMM*100/TRV;
ADX:= EMA(ABS(MDI-PDI)/(MDI+PDI)*100,2);
ADXR:=EMA(ADX,2);
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:SMA(RSV,3,1),COLORWHITE;
D:SMA(K,3,1),COLORYELLOW;
J:3*K-2*D,COLORMAGENTA;
J1:=CROSS(J,K) AND J>0;
J2:=J>REF(J,1) AND J>5 AND J<100;
JJ:=J1 OR J2;
MA3:=MA(C,3);MA5:=MA(C,5);MA10:=MA(C,10);
M3:=MA3>REF(MA3,1) AND REF(MA3,1)<=REF(MA3,2);
MM:=C>MA3 OR M3 OR CROSS(MA3,MA5);
{ADX与ADXR死叉,PDI上行中}
买1:IF(CROSS(ADXR,ADX) AND PDI>REF(PDI,1),150,0),COLORRED;
{ADX,ADXR死叉,KDJ金叉,MA3上行出红柱}
买2:IF(CROSS(ADXR,ADX) AND JJ AND MM AND COUNT(CROSS(MA10,MA5),20)>=1,80,0),COLORYELLOW;
{角度}
JD:=ATAN((C/REF(C,1)-1)*100)*57.29>45 AND
ATAN((REF(C,1)/REF(C,2)-1)*100)*57.29<45 AND MM;
JJJ:=ATAN((MA3/(REF(MA3,1))-1)*100)*57.29>45 AND
ATAN((MA3/(REF(MA3,2))-1)*100)*57.29<45 AND MM;

飞狐买入合成指标公式

 

相关文章