在线检测未来函数

通达信量能平台突破画线主图指标公式

来源:Internet,编辑:股旁网,2014-08-16

MA5:MA(C,5);
MA10:MA(C,10);
MA30:MA(C,30);N:=10;
T1:=CONST(HHVBARS(V,N));
T0:IF(CURRBARSCOUNT<=N+3,CONST(IF(T1=0,C,REF(C,T1))),DRAWNULL),COLORFF00FF;
IF(CURRBARSCOUNT=T1+1,T0,DRAWNULL),CIRCLEDOT,COLORFF00FF;
DRAWTEXT(ISLASTBAR,T0, '量能平台'),COLORCC00CC;
W:=20;
W1:=CONST(REF(HHVBARS(V,W),T1+1)+T1+1);
W0:IF(CURRBARSCOUNT<=T1+W+3 AND CURRBARSCOUNT>=T1+1,CONST(REF(C,W1)),DRAWNULL),COLOR009999;
IF(CURRBARSCOUNT=W1+1,W0,DRAWNULL),CIRCLEDOT,COLOR00CCCC;
M:=10;
Q1:=CONST(REF(HHVBARS(V,M),T1+1)+T1+1);
Q0:IF(CURRBARSCOUNT<=T1+M+3 AND CURRBARSCOUNT>=T1+1,CONST(REF(C,Q1)),DRAWNULL),COLOR009900;
IF(CURRBARSCOUNT=Q1+1,Q0,DRAWNULL),CIRCLEDOT,COLOR00CC00;
BB:=CROSS(H,T0);
STICKLINE(BB,O,C,2,0),COLOR00FFFF;

通达信量能平台突破画线主图指标公式

 

相关文章