在线检测未来函数

通达信直观牛熊主图指标公式

来源:Internet,编辑:股旁网,2014-08-26

CC:IF(CURRBARSCOUNT<18,CONST(REF(C,1)),DRAWNULL),COLOR000000;
止赢:1.05*CC,COLORFFFFFF,LINETHICK2;
止损:0.97*CC,COLORFFFFFF,LINETHICK2;
V1:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
V2:=(1-7/100)*(DMA(CLOSE,V1));
V3:=(1+7/100)*(DMA(CLOSE,V1));
V5:=MA((LOW+HIGH+CLOSE)/3,5);
支撑:REFDATE(V2,DATE),DOTLINE,LINETHICK1,COLORFF0080;
阻力:REFDATE(V3,DATE),DOTLINE,LINETHICK1,COLOR676767;
DRAWGBK(O>C,RGB(360,0,10),RGB(10,0,1),0,'01',0);
P0:=MA(INDEXC,34);
P1:=(55*P0+34*REF(P0,1)+21*REF(P0,2)+13*REF(P0,3)+8*REF(P0,4)+5*REF(P0,5)
+3*REF(P0,6)+2*REF(P0,7)+REF(P0,8)+REF(P0,9))/143;
P2:=REF(P1,1);
大盘长牛熊:=0.5*(P1+P2);
H0:=MA(C,8);
H1:=(55*H0+34*REF(H0,1)+21*REF(H0,2)+13*REF(H0,3)+8*REF(H0,4)+5*REF(H0,5)
+3*REF(H0,6)+2*REF(H0,7)+REF(H0,8)+REF(H0,9))/143;
H2:=REF(H1,1);
短期牛熊:0.5*(H1+H2),NODRAW,COLORYELLOW;
DRAWBAND(H1,RGB(255,255,0),H2,RGB(0,0,255));
STICKLINE(H1>H2,H1,H2,10,0),COLORYELLOW;
I0:=MA(C,34);
I1:=(55*I0+34*REF(I0,1)+21*REF(I0,2)+13*REF(I0,3)+8*REF(I0,4)+5*REF(I0,5)
+3*REF(I0,6)+2*REF(I0,7)+REF(I0,8)+REF(I0,9))/143;
I2:=REF(I1,1);
长期牛熊:0.5*(I1+I2),NODRAW,COLORRED;
DRAWBAND(I1,RGB(255,0,0),I2,RGB(0,255,0));
STICKLINE(I1>I2,I1,I2,10,0),COLORRED;
差:100*(短期牛熊-长期牛熊)/长期牛熊,COLORMAGENTA,NODRAW;
VAR1:=(100 - ((90 * (HHV(HIGH,14) - CLOSE)) / (HHV(HIGH,14) - LLV(LOW,14))));
VAR2:=(100 - ((90 * (HHV(HIGH,14) - CLOSE)) / (HHV(HIGH,14) - LLV(LOW,14))));
VAR3:=(100 - MA(((100 * (HHV(HIGH,6) - CLOSE)) / (HHV(HIGH,6) - LLV(LOW,6))),34));
DIR1:=ABS(CLOSE-REF(CLOSE,5));
VIR1:=SUM(ABS(CLOSE-REF(CLOSE,1)),5);
ER1:=DIR1/VIR1;
CS1:=ER1*(0.8-2/8)+2/8;
CQ1:=CS1*CS1;
DIR2:=ABS(CLOSE-REF(CLOSE,10));
VIR2:=SUM(ABS(CLOSE-REF(CLOSE,1)),10);
ER2:=DIR2/VIR2;
CS2:=ER2*(0.8-2/24)+2/24;
CQ2:=CS2*CS2;
STICKLINE(VAR2 < MA(VAR3,6),LOW,HIGH,0,1),COLORLIBLUE;
STICKLINE(VAR2 > MA(VAR3,6),LOW,HIGH,0,1),COLORRED;
STICKLINE(((OPEN>CLOSE)AND(VAR2<MA(VAR3,6))),(CLOSE-0.03),OPEN,3.05,0),COLORLIBLUE;
STICKLINE(((OPEN<CLOSE)AND(VAR2<MA(VAR3,6))),CLOSE,OPEN,3.05,1),COLORLIBLUE;
STICKLINE(((OPEN>CLOSE)AND(VAR2>MA(VAR3,6))),OPEN,(CLOSE-0.03),3.05,0),COLORRED;
STICKLINE(((OPEN<CLOSE)AND(VAR2>MA(VAR3,6))),OPEN,CLOSE,3.05,1),COLORRED;
DRAWICON(CROSS(VAR2,MA(VAR3,6)),(LOW - (LOW*0.02)),23);
DRAWICON(CROSS(MA(VAR3,6),VAR1),(HIGH+(HIGH*0.01)),15);
PT:=REF(H,1)-REF(L,1);
CDP:=(REF(H,1)+REF(L,1)+REF(C,1)*2)/4;
AH:=CDP+PT;
AL:=CDP-PT;
NH:=CDP*2-REF(L,1);
NL:=CDP*2-REF(H,1);
强:IF(AH>REF(C,1)*1.1,REF(C,1)*1.1,AH)NODRAW;
阻:IF(NH>强,(强-CDP)*0.618+CDP,NH)NODRAW,COLORBLUE;
M:=IF(AL<REF(C,1)/1.1,REF(C,1)/1.1,AL);
撑:IF(NL<M,CDP-(CDP-M)*0.618,NL)NODRAW;
底:IF(AL<REF(C,1)/1.1,REF(C,1)/1.1,AL)NODRAW;
STICKLINE(C>=O,C,O,3.4,0),COLOR0000AA;
STICKLINE(C>=O,C,O,3.0,0),COLOR0000BB ;
STICKLINE(C>=O,C,O,2.4,0),COLOR0000CC;
STICKLINE(C>=O,C,O,2.0,0),COLOR0000DD ;
STICKLINE(C>=O,C,O,1.6,0),COLOR0000EE;
STICKLINE(C>=O,C,O,1.2,0),COLOR0000FF;
STICKLINE(C>=O,C,O,0.6,0),COLOR0000FF;
STICKLINE(C>=O,H,L,0,0),COLORRED;
STICKLINE(C<=O,C,O,3.4,0),COLORAAAA00;
STICKLINE(C<=O,C,O,3.0,0),COLORBBBB00;
STICKLINE(C<=O,C,O,2.4,0),COLORCCCC00;
STICKLINE(C<=O,C,O,2.0,0),COLORDDDD00;
STICKLINE(C<=O,C,O,1.6,0),COLOREEEE00;
STICKLINE(C<=O,C,O,1.2,0),COLORFFFF00;
STICKLINE(C<=O,C,O,0.6,0),COLORFFFF00;
STICKLINE(C<=O,H,L,0,0),COLORFFFF00;
AA:=(REF(CLOSE,1)+REF(CLOSE,2)+OPEN)/3;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.8,0.05,1,'今日保护价'),LINETHICK2,COLOR00FFFF;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.84,0.05,1,AA);
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.86,0.05,1,'元');

通达信直观牛熊主图指标公式

 

相关文章