在线检测未来函数

通达信周日KDJ金叉指标公式

来源:Internet,编辑:股旁网,2014-08-28

DDATE:=DATE,NODRAW,COLOR0000FF;
RSV:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
K:SMA(RSV,3,1),COLORFFFFFF;
D:SMA(K,3,1),COLOR00FFFF;
J:3*K-2*D,COLORFF00FF;
D1:=DATE;
K01:=KDJ.K#WEEK;
D01:=KDJ.D#WEEK;
J01:=KDJ.J#WEEK;
WEK:=REFX(WEEKDAY<REF(WEEKDAY,1) OR DATETODAY(DATE)-DATETODAY(REF(DATE,1))>=7,1) OR ISLASTBAR;
D2:=IF(WEK,D1,DRAWNULL);
K02:=IF(WEK,K01,DRAWNULL);
D02:=IF(WEK,D01,DRAWNULL);
J02:=IF(WEK,J01,DRAWNULL);
WDATE:=ALIGNRIGHT(D2),NODRAW,COLOR00BB99;
周K:ALIGNRIGHT(K02),NODRAW,COLORFFFFFF;
周D:ALIGNRIGHT(D02),NODRAW,COLOR00FFFF;
周J:ALIGNRIGHT(J02),NODRAW,COLORFF00FF;
A1:=CONST(LLV(J,200))*5;
Q:=0.6;
NOTEXT1:A1,COLOR336699,DOTLINE;
周K虚:周K*Q+A1,COLORFFFFFF,DOTLINE;
周D虚:周D*Q+A1,COLOR00FFFF,DOTLINE;
周J虚:周J*Q+A1,COLORFF00FF,DOTLINE;
金叉:IF(CROSS(K,D),J,DRAWNULL),COLOR00FFFF,LINETHICK7,POINTDOT;
周金叉:IF(ISLASTBAR AND CROSS(周K,周D),周J虚,DRAWNULL),COLOR5555FF,LINETHICK7,POINTDOT;
0,COLOR00AA00;

通达信周日KDJ金叉指标公式

 

相关文章