在线检测未来函数

通达信MA3操盘主图指标公式

来源:Internet,编辑:股旁网,2014-09-10

J5:EMA(C,5);
J10:EMA(C,10);
J20:EMA(C,20);
J30:EMA(C,30);
J60:EMA(C,60);
J120:EMA(C,120);
J250:EMA(C,250)COLORRED;
DRAWICON(H<REF(L,1),H*1.02,12)COLORGREEN;
DRAWICON(L>REF(H,1),L*0.98,11)COLORRED;
N:=80;
M:=3;
VAR1:=(100 - ((90 * (HHV(HIGH,14) - CLOSE)) / (HHV(HIGH,14) - LLV(LOW,14))));
VAR2:=(100 - ((90 * (HHV(HIGH,14) - CLOSE)) / (HHV(HIGH,14) - LLV(LOW,14))));
VAR3:=(100 - MA(((100 * (HHV(HIGH,6) - CLOSE)) / (HHV(HIGH,6) - LLV(LOW,6))),34));
DIR1:=ABS(CLOSE-REF(CLOSE,5)); VIR1:=SUM(ABS(CLOSE-REF(CLOSE,1)),5);
ER1:=DIR1/VIR1; CS1:=ER1*(0.8-2/8)+2/8; CQ1:=CS1*CS1;
DIR2:=ABS(CLOSE-REF(CLOSE,10)); VIR2:=SUM(ABS(CLOSE-REF(CLOSE,1)),10);
ER2:=DIR2/VIR2; CS2:=ER2*(0.8-2/24)+2/24;
CQ2:=CS2*CS2;
STICKLINE(VAR2 < MA(VAR3,6),LOW,HIGH,0,1),COLORLIBLUE;
STICKLINE(VAR2 > MA(VAR3,6),LOW,HIGH,0,1),COLORRED;
STICKLINE(((OPEN>CLOSE)AND(VAR2<MA(VAR3,6))),(CLOSE-0.03),OPEN,3.05,0),COLORLIBLUE;
STICKLINE(((OPEN<CLOSE)AND(VAR2<MA(VAR3,6))),CLOSE,OPEN,3.05,1),COLORLIBLUE;
STICKLINE(((OPEN>CLOSE)AND(VAR2>MA(VAR3,6))),OPEN,(CLOSE-0.03),3.05,0),COLORRED;
STICKLINE(((OPEN<CLOSE)AND(VAR2>MA(VAR3,6))),OPEN,CLOSE,3.05,1),COLORRED;
DRAWICON(CROSS(VAR2,MA(VAR3,6)),LOW,1);
DRAWICON(CROSS(MA(VAR3,6),VAR1),HIGH,2);
PT:=REF(H,1)-REF(L,1); CDP:=(REF(H,1)+REF(L,1)+REF(C,1)*2)/4; AH:=CDP+PT;
AL:=CDP-PT;
NH:=CDP*2-REF(L,1); NL:=CDP*2-REF(H,1);
强:IF(AH>REF(C,1)*1.1,REF(C,1)*1.1,AH)NODRAW;
阻:IF(NH>强,(强-CDP)*0.618+CDP,NH)NODRAW,COLORBLUE;
MM:=IF(AL<REF(C,1)/1.1,REF(C,1)/1.1,AL);
撑:IF(NL<M,CDP-(CDP-M)*0.618,NL)NODRAW;
底:IF(AL<REF(C,1)/1.1,REF(C,1)/1.1,AL)NODRAW;

通达信MA3操盘主图指标公式

 

相关文章